Déjà Dup Backup Tool

Single-file restore downloads whole backup

Reported by Michael Terry on 2009-11-12
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Déjà Dup
High
Michael Terry
10
High
Michael Terry
11
High
Michael Terry
deja-dup (Ubuntu)
Undecided
Unassigned
Karmic
Wishlist
Unassigned

Bug Description

From user Matthew:

"I made a backup of a directory to an external, NTFS hard drive. To test it out, I right clicked on one of the files in the original directory and hit restore previous version. Everything worked like it was supposed to except that, instead of restoring the file I had selected, deja-dup restored the entire directory, which is 30GB+. All I wanted was the single file. Do you have any Idea why it would have done this?"

I've confirmed that Deja Dup downloads the whole backup to /tmp, but correctly only overwrites the file you wanted. The bug is that it downloads everything, which is silly.

Michael Terry (mterry) on 2009-11-12
Changed in deja-dup:
assignee: nobody → Michael Terry (mterry)
importance: Undecided → High
milestone: none → 12.0
status: New → Fix Committed
tags: added: restore
Michael Terry (mterry) wrote :

Thanks Matthew! A simple mistake in the code (one line in the wrong place) caused this. Fixed in trunk, and hopefully I can release fixes for 11 and 10 series.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deja-dup - 11.1-0ubuntu1

---------------
deja-dup (11.1-0ubuntu1) lucid; urgency=low

  * New upstream release
    - Fixes some restore issues (LP: #483631 and LP: #481582)
    - Can delete old backups (LP: #325005)
    - Can cleanly handle changed hostnames (LP: #454591)
  * Drop 01_lpi.patch: It doesn't make sense to include launchpad
    integration for a non-main app (no translation page). Plus, deja-dup
    already has such links for its own upstream LP page.
  * debian/control: Update dependencies
 -- Michael Terry <email address hidden> Sun, 22 Nov 2009 09:39:39 -0600

Changed in deja-dup (Ubuntu):
status: New → Fix Released

Accepted deja-dup into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Michael Terry (mterry) wrote :

As I commented in bug 483631, I tested this with the -proposed version and it worked for me.

Martin Pitt (pitti) on 2009-11-24
Changed in deja-dup (Ubuntu Karmic):
status: New → Fix Committed
tags: added: verification-done
removed: verification-needed
Michael Terry (mterry) on 2009-11-29
Changed in deja-dup (Ubuntu Karmic):
importance: Undecided → Medium
importance: Medium → Wishlist
Changed in deja-dup:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deja-dup - 10.2-0ubuntu1.1

---------------
deja-dup (10.2-0ubuntu1.1) karmic-proposed; urgency=low

  * 02_restore-fixes.patch: Some restore fixes backported from 10.3:
    - Allow restoring files in a read-only directory (LP: #483631)
    - Don't download all files to restore just one (LP: #481582)
    - Allow restoring a file from a directory that doesn't exist yet
 -- Michael Terry <email address hidden> Mon, 16 Nov 2009 14:00:50 -0600

Changed in deja-dup (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions