Changed host name prevents backup

Bug #454591 reported by sampattuzzi on 2009-10-18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Déjà Dup
Michael Terry
deja-dup (Ubuntu)

Bug Description

I know that this is intended behaviour for duplicity. However, I have recently installed Karmic and in doing so I changed my host name to something more imaginative. I tend to keep the same home partition when I upgrade so all my Déjà Dup setting where kept. I thought I would be able to backup but instead I get this error about the hostname mismatch. I could probably over come this by dropping to the commandline and adding the option --allow-source-mismatch. However, it would be much easier if I could do this with a GUI option, or at least tell the GUI that I want to add an extra switch to the command it uses.

The steps to reproduce are easy. Backup with one computer then try and backup to the same place with a different hostname.

Just for completeness sake:

The message:

Fatal Error: Backup source host has changed.
Current hostname: rincewind
Previous hostname: sams-desktop

Aborting because you may have accidentally tried to backup two different data sets to the same remote location, or using the same archive directory. If this is not a mistake, use the --allow-source-mismatch switch to avoid seeing this message.

dpkg-query -W deja-dup duplicity:

deja-dup 10.2-0ubuntu1
duplicity 0.6.05-0karmic1

lsb_release -d:

Description: Ubuntu karmic (development branch)

Related branches

Michael Terry (mterry) wrote :

I've fixed this in the hopefully-soon-to-be-released 11.0. I'll open a task for a workaround for the 10 branch, hopefully to be finished in time for Karmic.

In the meantime, if you want to try the new 11.0 to work around this, you can using the testing PPA: Frankly, this is not recommended if you care about your backup, as it is testing code. Else wait a bit. I hope to release a band-aid 10.3 that will just always pass --allow-source-mismatch (11.0 will actually ask user).

Changed in deja-dup:
assignee: nobody → Michael Terry (mterry)
importance: Undecided → Medium
milestone: none → 11.0
status: New → Fix Committed
Michael Terry (mterry) wrote :

Actually, upon reflection, always setting --allow-source-mismatch could be bad. A user might reasonably try to backup two computers to the same folder. With --allow-source-mismatch, the backups would keep flopping back and forth between a backup of one computer vs. the other. And the 11.0 solution (which asks the user what to do) is too invasive to backport. So I don't think I'll release a new 10.x version.

For the moment, I recommend a workaround of backing up to a different folder. You can always restore from the previous folder if you need to by pointing Deja Dup at it again.

Good point actually. Yeah I think I will have to backup to a different
folder. It's just that a full backup obviously takes longer than an
incremental one.

On a side note, it's really nice to see how involved you are with this
project. It's really nice to see when the lead of a project gets so
involved in almost every bug. Wonderful project, keep up the good work!

benste (benste) wrote :

Hi all, I've tried to restore my test data into a VM with karmic (part of doing my upgrade) but I've had the same source mismatch error.

I got an error message in karmic that I should use this duplicity option, but using a terminal I get the following:

karmicvm@karmicVM:~$ deja-dup --allow-source-mismatch
Unknown option --allow-source-mismatch
Version is 10.2

As i would like to perform my upgrade today, I'd like to know what I could change if I use another hostname.

Michael Terry (mterry) wrote :

You got the message on restore?

If you want to workaround this, either use the same hostname as before or backup to a different directory. You should be able to restore from the old files by pointing to the old directory again. But if you're seeing this on restore... Might be a different issue.

Michael Terry (mterry) on 2009-10-30
Changed in deja-dup:
status: Fix Committed → Fix Released
Changed in deja-dup (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deja-dup - 11.1-0ubuntu1

deja-dup (11.1-0ubuntu1) lucid; urgency=low

  * New upstream release
    - Fixes some restore issues (LP: #483631 and LP: #481582)
    - Can delete old backups (LP: #325005)
    - Can cleanly handle changed hostnames (LP: #454591)
  * Drop 01_lpi.patch: It doesn't make sense to include launchpad
    integration for a non-main app (no translation page). Plus, deja-dup
    already has such links for its own upstream LP page.
  * debian/control: Update dependencies
 -- Michael Terry <email address hidden> Sun, 22 Nov 2009 09:39:39 -0600

Changed in deja-dup (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers