Expose better UI for file-based restore

Bug #306982 reported by Michael Terry on 2008-12-10
230
This bug affects 45 people
Affects Status Importance Assigned to Milestone
Déjà Dup
Wishlist
Unassigned
deja-dup (Ubuntu)
Wishlist
Unassigned

Bug Description

It would be nice if the user can say "I only want to restore these files/folders".

Michael Terry (mterry) on 2008-12-13
Changed in deja-dup:
importance: Undecided → Wishlist
status: New → Confirmed
Michael Terry (mterry) wrote :

I'll note that as of 7.0, there is a command line syntax for this ('deja-dup --restore [FILES...]'). There is also a nautilus extension that exposes this functionality for existing files (to restore them to a previous version) by right clicking.

So this bug can be adjusted to 'Expose better UI for allowing file-based restore'. I would like to:

1) Improve nautilus extension to allow restoring missing files. This is presumably a big use case ("Oh, I just deleted that file, stupid me").

2) Add a screen to the restore wizard to offer to restore certain files, and let the user pick ones from the backup.

Jay S (topdownjimmy) wrote :

"2) Add a screen to the restore wizard to offer to restore certain files, and let the user pick ones from the backup."

This, I feel, is very much needed. Examine the way Back in Time (http://backintime.le-web.org/) handles this, for instance; it displays the whole folder structure of your backups (or "snapshots") as if you were looking at them in Nautilus.

This sounds like a great solution to the problem. I came to Launchpad to request the feature of being able to restore single files rather than having to do an entire backup -- from the GUI, I didn't realise that there was the Nautilus extension or any other way to restore files (e.g. the commandline method).

Even before this is implemented, maybe a note could be added to the "Restore" screen alerting users to the ability to restore files directly through Nautilus.

Michael Terry (mterry) on 2010-03-17
Changed in deja-dup:
milestone: none → 16.0
Dylan McCall (dylanmccall) wrote :

I think the current wizard-based approach is a problem, too. I was fiddling with Deja Dup's file restore and had absolutely no way of knowing what would happen next as I stepped through the process. Would it suddenly start murdering my home directory, replacing every single file in a slow crunch of madness, or would it let me select them one by one? Would I be able to select where to restore the files to?

A dialog that shows / enables options as they become available, with an obvious Restore button at the bottom to assure us that it won't do anything until we press that button, could be a gentler approach.

Peter Bojtos (peter-bojtos) wrote :

I experienced, that when I try to restore a single file from nautilus, deja-dup lists all of my backups from the past. If I select a date when the file did't existed yet, I get an error, that the file doesn't exist in the backup (of course, because i had't created the file before that backup).
Is there any way from deja-dup to check that a file is in the backup and list only backups, that contains the file?

david6 (andrew-dowden) wrote :

This needs to be done in stages:

(1.) Add dialog button, for Restore Files/Folder. CRITICAL

This should already be present. I petulantly disabled Déjà Dup, and installed Simple Backup, before I found this Bug.

(As per Comment #1) "This is not yet a feature. You can however restore files (or folders) using the command line ('deja-dup --restore [FILES...]'), or by right-clicking in Nautilus (? requires extension). This feature will be added in a future release. SEE Bug #306982 ."

(2.) Add simple dialog field for files/folders, and feed to command line. IMPORTANT

(3.) Add complex dialog box(es), for files/folders, version to replace with, and exception handling. NICE TO HAVE

(4.) A Wizard tool, for all of the above. NICE TO HAVE, ONE DAY

Michael Terry (mterry) on 2010-09-11
Changed in deja-dup:
milestone: 16.0 → none
Kip Warner (kip) wrote :

Like Aaron and Michael, I also came to Launchpad to request such a feature, but it looks like others have been already asking for it.

An idea is in the Restore to Where? dialogue, it could ask below the first two options of "Restore items to their original locations" and "Restore to specific folder", perhaps ask below whether to restore all or to peek inside the backup and select individually what you'd like to restore.

Michael Terry (mterry) wrote :

Agreed, Kip. Also note that as of 17.2, Deja Dup has a restore-missing-files view, fixing the below issue from comment 1.

"1) Improve nautilus extension to allow restoring missing files. This is presumably a big use case ("Oh, I just deleted that file, stupid me")."

So the only thing missing now is:

"2) Add a screen to the restore wizard to offer to restore certain files, and let the user pick ones from the backup."

I anticipate adding a simple screen in the wizard to pick files/folders from a folder tree for a first pass at this functionality. For a future iteration, it would be nice to add support to nautilus for "browsing" a backup in some fashion, which would allow restoring in a more intuitive, drag&drop manner.

Changed in deja-dup (Ubuntu):
status: New → Confirmed
Vej (vej) on 2017-10-10
Changed in deja-dup (Ubuntu):
importance: Undecided → Wishlist
Michael Terry (mterry) wrote :

A browse and restore interface was released with 42.0.

Changed in deja-dup:
status: Confirmed → Fix Released
Changed in deja-dup (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers