BackendException: Could not initialize backend: cannot import name _gi

Bug #1821761 reported by Daniel Rice on 2019-03-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Déjà Dup
Undecided
Unassigned

Bug Description

I get the error in the summary any time I try to run a backup. I just downloaded the tool from the Ubuntu Software marketplace, picked an external drive, and pushed "Backup Now." As far as I can tell, I haven't done anything crazy.

Ubuntu 18.04.2 LTS
deja-dup 37.1-2fakesync1ubuntu0.1
duplicity 0.7.17-0ubuntu1.1

org.gnome.DejaDup last-restore ''
org.gnome.DejaDup periodic false
org.gnome.DejaDup periodic-period 1
org.gnome.DejaDup full-backup-period 90
org.gnome.DejaDup backend 'drive'
org.gnome.DejaDup last-run '2019-02-13T07:47:19.506525Z'
org.gnome.DejaDup nag-check '2019-02-12T20:51:54.957882Z'
org.gnome.DejaDup prompt-check '2019-01-18T15:05:22.570894Z'
org.gnome.DejaDup root-prompt true
org.gnome.DejaDup include-list ['/home/daniel']
org.gnome.DejaDup exclude-list ['/home/daniel/.local/share/Trash', '/home/daniel/.rvm', '/home/daniel/.cache']
org.gnome.DejaDup last-backup '2019-02-13T07:47:19.506525Z'
org.gnome.DejaDup allow-metered false
org.gnome.DejaDup delete-after 182
org.gnome.DejaDup.Rackspace username ''
org.gnome.DejaDup.Rackspace container 'daniel-HP-ProBook-450-G1'
org.gnome.DejaDup.S3 id ''
org.gnome.DejaDup.S3 bucket ''
org.gnome.DejaDup.S3 folder 'daniel-HP-ProBook-450-G1'
org.gnome.DejaDup.OpenStack authurl ''
org.gnome.DejaDup.OpenStack tenant ''
org.gnome.DejaDup.OpenStack username ''
org.gnome.DejaDup.OpenStack container 'daniel-HP-ProBook-450-G1'
org.gnome.DejaDup.GCS id ''
org.gnome.DejaDup.GCS bucket ''
org.gnome.DejaDup.GCS folder 'daniel-HP-ProBook-450-G1'
org.gnome.DejaDup.Local folder 'daniel-HP-ProBook-450-G1'
org.gnome.DejaDup.Remote uri ''
org.gnome.DejaDup.Remote folder 'daniel-HP-ProBook-450-G1'
org.gnome.DejaDup.Drive uuid 'EF27-8EAD'
org.gnome.DejaDup.Drive icon '. GThemedIcon drive-harddisk-usb drive-harddisk drive'
org.gnome.DejaDup.Drive folder 'daniel-HP-ProBook-450-G1'
org.gnome.DejaDup.Drive name 'BACKUP'
org.gnome.DejaDup.GOA id ''
org.gnome.DejaDup.GOA folder 'daniel-HP-ProBook-450-G1'
org.gnome.DejaDup.GOA type 'google'
org.gnome.DejaDup.File short-name ''
org.gnome.DejaDup.File type 'normal'
org.gnome.DejaDup.File migrated true
org.gnome.DejaDup.File name ''
org.gnome.DejaDup.File path ''
org.gnome.DejaDup.File uuid ''
org.gnome.DejaDup.File icon ''
org.gnome.DejaDup.File relpath @ay []

Log is literally an empty file: `ls -al /tmp/deja-dup.log`

-rw-r--r-- 1 daniel daniel 0 Mar 26 10:41 /tmp/deja-dup.log

When I run `DEJA_DUP_DEBUG=1 deja-dup --backup | tail -n 1000 > /tmp/deja-dup.log` all that happens is the same error popup appears with the same error as in the summary, the same error as when I ran the backup via the GUI.

Not sure what the issue is here :(

Daniel Rice (danielricecodes) wrote :

Oh, `python-gi` and `duplicity` are already installed.

python-gi is already the newest version (3.26.1-2ubuntu1)
duplicity is already the newest version (0.7.17-0ubuntu1.1)

Daniel Rice (danielricecodes) wrote :

Closing this. I must have installed two versions of Deja Dup on accident. There is one in the "app store" called "Déjà Dup Backup Tool" and its version is 37.1-2fakesync1ubuntu0.1. This one is working.

There is another version, just called "Deja Dup", and its version is 38.4. This version did not work. My advice is to just install the version that works, 37.1-2 :)

Case closed.

Changed in deja-dup:
status: New → Incomplete
status: Incomplete → Invalid
Michael Terry (mterry) wrote :

Interesting. Looks like the snap version of deja-dup was not working for you, but the built-in deb version was.

I can't reproduce on 18.04... so not sure why that message would be given (it means that deja-dup couldn't find some of the files in the snap package).

But regardless, glad you got it working.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers