Encryption password needed on restore ignores correct password

Bug #1789674 reported by James Wilson on 2018-08-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Déjà Dup
Undecided
Unassigned

Bug Description

The 'encryption password needed' returns after I have entered the correct password.
The backups were done on Ubuntu 18.04 and this system was reinstalled due to hard drive problems.
Now trying to restore files from this backup the above problem occurs.
I have also tried from the terminal using Duplicity. When asked for 'GnuPG passphrase for decryption:' I enter the password that I used in Backup and receive the following:

Synchronising remote metadata to local cache...
Copying duplicity-full-signatures.20180807T183836Z.sigtar.gpg to local cache.
Copying duplicity-full.20180807T183836Z.manifest.gpg to local cache.
Copying duplicity-inc.20180807T183836Z.to.20180809T101504Z.manifest.gpg to local cache.
Copying duplicity-inc.20180809T101504Z.to.20180816T175626Z.manifest.gpg to local cache.
GPGError: GPG Failed, see log below:
===== Begin GnuPG log =====
gpg: AES256 encrypted data
gpg: encrypted with 1 passphrase
gpg: decryption failed: Bad session key
===== End GnuPG log =====

Ubuntu 18.04.1 LTS
deja-dup 37.1-2fakesync1
duplicity 0.7.17-0ubuntu1

Thanks

James Wilson (jawi2300) wrote :
James Wilson (jawi2300) wrote :

I used the procedure given at https://askubuntu.com/questions/793135/how-to-restore-a-broken-deja-dup-backup-manually. I was able to recover files from backup but not the latest incremental; which gave the same error as above 'Bad session key' on the latest incremental files. My password was correct for the first full backup and the first incremental but seems to fail on the second and last incremental.

Eero (eero+launchpad) wrote :

This software is totally unusable for reliable backups. I've been using it as a secondary backup and cautionary tale for others. Examples: https://bugs.launchpad.net/ubuntu/+source/deja-dup/+bug/1790995 https://bugs.launchpad.net/ubuntu/+source/deja-dup/+bug/1651396

I'd recommend using something properly maintained like borgbackup.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments