Restore ignores what I type into the folder box

Bug #1755023 reported by Paul Nickerson on 2018-03-11
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Déjà Dup
High
Unassigned
deja-dup (Ubuntu)
Medium
Unassigned

Bug Description

I have my computer using Deja Dup to backup everything to a particular folder on a secondary drive. When I try to use Deja Dup to restore a backup from a different folder on that drive, it does not scan that folder.

1. Open Deja Dup and click the Restore... button.
2. In the Restore From Where? window, the Backup location is set to my external hard drive, and the Folder field is set to my current backup folder. From here, I try paths "a" and "b" below:
3a. Change the text in the Folder field to be the name of the folder containing my previous computer's backup, and click Forward.
4a. I am presented with a list of backups from my current backup folder, not from the other folder I tried to select.
3b. Change the Backup location field to Local Folder, and now click the Choose Folder... button that has appeared next to the Folder field.
4b. Browse to the mount point of my secondary drive, and select the backup folder that was used for my previous computer. Click OK, and then Forward.
5b. I am presented with the message "Restore Failed" "No backups to restore"

I'm on Ubuntu 17.10 with deja-dup 36.3-0ubuntu0.1 and duplicity 0.7.12-1ubuntu1

I have attached deja-dup.gsettings to this bug report. I will add debug outputs in comments below.
In those logs, it should be noted that my secondary drive is named "Octonary" and is mounted at "/media/paul/Octonary". My current backup folder is "/media/paul/Octonary/Ubuntu Backup 3", and the backup folder of my previous computer is "/media/paul/Octonary/Ubuntu Backup 2".

Paul Nickerson (pgn674) wrote :
Paul Nickerson (pgn674) wrote :

Attached is the debug output from path "a" as described above, named deja-dup-path-a.log

Paul Nickerson (pgn674) wrote :

And here is the debug output from path "b", named deja-dup-path-b.log

Oh, I just noticed that I forgot two details:
In path "a", the Folder field is originally "Ubuntu Backup 3", and I change that to be "Ubuntu Backup 2" before clicking Forward.
In path "b", after I change the Backup location to Local Folder, the Folder field is originally "paul-desk-linux" (my hostname), and I change that to be "/media/paul/Octonary/Ubuntu Backup 2" before clicking Forward.

Paul Nickerson (pgn674) wrote :

Does anybody need additional information to troubleshoot this bug?

Vej (vej) wrote :

Hello Paul!

Have you tried to set the path in the location tab of the settings *before* restoring?

If so does that change anything?

Changed in deja-dup:
status: New → Incomplete
Paul Nickerson (pgn674) wrote :

That worked, thank you! I went to Storage location, and changed Folder to be "Ubuntu Backup 2". Then, when I went to Overview > Restore..., the Folder was already "Ubuntu Backup 2", and clicking Forward from there worked correctly. I was able to restore my backup where I wanted and access my files. Before closing Backups, I made sure to change the storage location back to my current backup folder.

Thank you for the suggestion. My specific problem has been solved by this workaround. But I think this is still a bug that should be tracked and addressed.

Vej (vej) wrote :

Hello Paul.

Good to know that the workaround worked for you (which also limits the probable causes of the problem).

This is of course still a bug which needs to be fixed.

Best Regards

Vej

Changed in deja-dup:
status: Incomplete → Triaged
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in deja-dup (Ubuntu):
status: New → Confirmed
Vej (vej) on 2018-04-13
Changed in deja-dup (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium

I finally figured out the trick to change the restore location in Deja Dup's settings before attempting to restore. The bug is indeed that Deja Dup ignores the location selection in the Restore dialog and always attempts to use the previously-configured setting. This is the cause of a bunch of 1-star GNOME Software reviews from people who just say "restore doesn't work." I'm guilty of leaving one of those myself, before figuring this out.

Jim Harris (jimbobstpaul) wrote :

I have exactly the same problem, on a clean install of Bionic/18.04 Desktop AMD64, with a locally-attached (USB) 2TB SATA hard drive which works perfectly AFAIK for all functions other than Deja Dup.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers