Deja Dup Restore fails: "No backups to restore"

Bug #1749984 reported by Nicolas Diogo on 2018-02-16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Déjà Dup

Bug Description

posted on the forum:

another similar bug report:

Deja Dup Restore fails: "No backups to restore"


    I posting here in case others come across this minor problem.

    In my case, I backup the dejadup/deja-dup to back-up my user's home

    when I tried to restore the back up onto a fresh install on the same machine I found the error

    "No backups to restore"

    the steps to replicate this error:
    - complete a fresh installation of ubuntu
    - plug a usb storage with the back-up from the previous installation
    - try to restore the previous back-up
    - give the directory of the previous back-up and click forward
    - the Error is shown

    the reason for this error seems to be the configuration of the 'Backup Tool/
    the path to the location of the previous back-up *has* to be entered in the tab 'Storage Location'

    then repeat the process for Restoring the back-up and everything works fine

    I hope it saves others from having a 'big scare'


System / package details:

$ lsb_release -d
Description: Ubuntu 17.10

$ dpkg-query -W deja-dup duplicity
deja-dup 36.3-0ubuntu0.1
duplicity 0.7.12-1ubuntu1

Vej (vej) on 2018-02-26
description: updated
Vej (vej) wrote :

I was not able to reproduce this on Ubuntu 16.04 with deja-dup 34.2-0ubuntu1.1 and duplicity 0.7.06-2ubuntu2.

Rob Frohne (frohro) wrote :

This occurs for me too on Ubuntu 18.04. I'm grateful for the work around above!

Eeyore ofBorg (eeyoreofborg) wrote :

Can confirm on 18.04.1 LTS, except now it says Google must be configured no matter which option I choose. Thanks for the help!

Jose M (punksolid) wrote :

Same problem here, I've been using deja-dup on manjaro with KDE I been using backup from several months and I just restored in the same machine once. But now I'm migrating from one laptop to another and instead of copying I wanted to restore from deja dup but in the fresh install appeared the Google second message and right after I defined the Local Backup, tried again and now says that restore failed.

I think it is some usability problem in some configuration that I need to make.

I'm using an external hard drive to backup and the previous hard disk was encrypted and the backup is also protected.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers