Unknown error during daily save

Bug #1746334 reported by Tommy Beauclair-Mariotti on 2018-01-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Déjà Dup
Undecided
Unassigned

Bug Description

Distro used : Archlinux
Version used :
-Deja-dup 37.1 (compiled using arch's own PKGBUID, just changed the version n° to have this version that fixes another bug I had
-Duplicity 0.7.16

What I did : Just let the daily backup running
What happened : The backup fails with this message :

Traceback (innermost last):
  File "/usr/bin/duplicity", line 1559, in <module>
    with_tempdir(main)
  File "/usr/bin/duplicity", line 1545, in with_tempdir
    fn()
  File "/usr/bin/duplicity", line 1394, in main
    do_backup(action)
  File "/usr/bin/duplicity", line 1526, in do_backup
    check_last_manifest(col_stats) # not needed for full backup
  File "/usr/bin/duplicity", line 1228, in check_last_manifest
    last_backup_set.check_manifests()
  File "/usr/lib/python2.7/site-packages/duplicity/collections.py", line 208, in check_manifests
    remote_manifest = self.get_remote_manifest()
  File "/usr/lib/python2.7/site-packages/duplicity/collections.py", line 249, in get_remote_manifest
    return manifest.Manifest().from_string(manifest_buffer)
  File "/usr/lib/python2.7/site-packages/duplicity/manifest.py", line 202, in from_string
    vi = VolumeInfo().from_string(match.group(1))
  File "/usr/lib/python2.7/site-packages/duplicity/manifest.py", line 390, in from_string
    linelist = s.strip().split("
")
 MemoryError

What I tried : Checked connectivity with remote server (mine on the same network), it's ok. Retried the day after, same.

Manual backup is working perfectly

gsettings file in attachment

Vej (vej) wrote :

Hello!

You might be another victim of a regression discussed in bug #1727653. Although this is not certain.

Could you please try out the workaround given there, which raises some other limits accidentally affected by the introduction of ulimit in the execution line?

If you do, please report here if that worked for you or not and set the Status back to "New".

I will then determine if this is to be handled as a duplicate of bug #1727653 or does need its own solution.

Best

Vej

Changed in deja-dup:
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for Déjà Dup because there has been no activity for 60 days.]

Changed in deja-dup:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers