Giving up after 5 attempts. Error: g-io-error-quark: Error splicing file: Input/output error (0)

Bug #1741458 reported by Marek Wasenczuk on 2018-01-05

This bug report was converted into a question: question #667259: Giving up after 5 attempts. Error: g-io-error-quark: Error splicing file: Input/output error (0).

28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Déjà Dup
Undecided
Unassigned

Bug Description

Giving up after 5 attempts. Error: g-io-error-quark: Error splicing file: Input/output error (0)

mikeyphi (mikeyphi) wrote :

I have also had this error for the past 4 days.

Lawerence Gray (ljg2305) wrote :

I too have been seeing this error recently

I get "g-io-error-quark: Invalid reply received (0)" Haven't the foggiest whether this is the same error or a different one. These error messages are absolutely useless.

OK, root cause of my error was a permissions problem with an sftp server mounted by gvfsd as a file system. YMMV

Vej (vej) wrote :

Hello Marek, mikeyphi and Lawrence!

On what target are you backing up? Is it an sftp server as in #4?

Also add the following informations please, so the developers know what this is about:

1. The distribution of Linux you're using:
    lsb_release -d

2. The version of deja-dup and duplicity:
    (if on Ubuntu or Debian:)
    dpkg-query -W deja-dup duplicity

    (if on Fedora or other RPM-based systems:)
    rpm -q deja-dup duplicity

3. The file /tmp/deja-dup.gsettings after running the following line (you may want to scrub the file of any incriminating file names or details):
    gsettings list-recursively org.gnome.DejaDup > /tmp/deja-dup.gsettings

4. The file /tmp/deja-dup.log after running the appropriate line below and replicating the problem (you may want to scrub the log of any incriminating file names or details):

 * If you're having problems backing up:
    DEJA_DUP_DEBUG=1 deja-dup --backup | tail -n 1000 > /tmp/deja-dup.log

The first one providing this information can set the status to "Confirmed".

Thanks

Vej

Changed in deja-dup:
status: New → Incomplete
Herbert Smith (confussed) wrote :

Giving up after 5 attempts. Error: g-io-error-quark: Error splicing file: Input/output error (0)

Changed in deja-dup:
status: Incomplete → Invalid
Herbert Smith (confussed) wrote :

I am New and don't understand what you are asking? I was trying to bring back my machine from a earlier Bug attack but I can not get my data because of this new bug. Now how do I do that? I really need this data back I am using my 1 TB external hdd which i don't keep plunged in all the time because I need to trust something working right. Now I'm sorry if I have offended some one but how do nI get this data from my backup. Please. How do I meet the status of a valid problem. If I can't trust Ubuntu with my data Who should I turn to? I never had this type of problems with That other operting system that start with a W or do I need to get virus protectors or what. I need this back up data tell me in plain english What I have to do to get it! I am asking pretty please or is there some other way I need to go to to get my Data Back. Thank you for your attention. Here is what I got trying to use my external drive: "Giving up after 5 attempts. Error: g-io-error-quark: Error splicing file: Input/output error (0)". I got this message after I started my backup deja and I mean just as I started the backup program I did not get anything restored. Now, What the do I do to get this marvelous operating system working right again.

Vej (vej) wrote :

Please do not convert other peoples bugs to questions without following the proper documentation when and how to do this:

https://wiki.ubuntu.com/Bugs/Triage?action=show&redirect=Bugs%2FHowToTriage#Converting_a_bug_report_to_a_question

Reopening this bug.

Changed in deja-dup:
status: Invalid → Won't Fix
status: Won't Fix → Incomplete
Fabrice Raymond (fabrius-c) wrote :

Hello,

First, sorry for my English, I'm French speaker.
I have the same problem with this message.

So I respond to Vej (#5) :

Here the result of the command :

lsb_release -d
Description: Ubuntu 16.04.4 LTS

dpkg-query -W deja-dup duplicity
deja-dup 34.2-0ubuntu1.1
duplicity 0.7.06-2ubuntu2

The file /tmp/deja-dup.gsettings
org.gnome.DejaDup last-restore ''
org.gnome.DejaDup periodic true
org.gnome.DejaDup full-backup-period 90
org.gnome.DejaDup backend 'file'
org.gnome.DejaDup last-run '2018-04-19T01:52:02.519206Z'
org.gnome.DejaDup nag-check '2018-04-05T14:55:54.519493Z'
org.gnome.DejaDup prompt-check '2017-07-16T09:38:02.273911Z'
org.gnome.DejaDup root-prompt true
org.gnome.DejaDup include-list ['$HOME']
org.gnome.DejaDup exclude-list ['$TRASH', '$DOWNLOAD']
org.gnome.DejaDup last-backup '2018-04-19T01:52:02.519206Z'
org.gnome.DejaDup periodic-period 7
org.gnome.DejaDup delete-after 182
org.gnome.DejaDup.S3 id ''
org.gnome.DejaDup.S3 bucket ''
org.gnome.DejaDup.S3 folder 'Ordinateur-de-Fabrice'
org.gnome.DejaDup.OpenStack authurl ''
org.gnome.DejaDup.OpenStack tenant ''
org.gnome.DejaDup.OpenStack username ''
org.gnome.DejaDup.OpenStack container 'Ordinateur-de-Fabrice'
org.gnome.DejaDup.GCS id ''
org.gnome.DejaDup.GCS bucket ''
org.gnome.DejaDup.GCS folder 'Ordinateur-de-Fabrice'
org.gnome.DejaDup.GDrive email ''
org.gnome.DejaDup.GDrive folder '/deja-dup/Ordinateur-de-Fabrice'
org.gnome.DejaDup.Rackspace username ''
org.gnome.DejaDup.Rackspace container 'Ordinateur-de-Fabrice'
org.gnome.DejaDup.File path 'file:///home/fabrice/deja-dup'
org.gnome.DejaDup.File short-name 'MY PASSPORT'
org.gnome.DejaDup.File uuid 'E65D-8392'
org.gnome.DejaDup.File icon '. GThemedIcon drive-harddisk-usb drive-harddisk drive'
org.gnome.DejaDup.File relpath b'Backup'
org.gnome.DejaDup.File name 'WD My Passport 07A8: MY PASSPORT'
org.gnome.DejaDup.File type 'volume'

The file /tmp/deja-dup.log (DEJA_DUP_DEBUG=1 deja-dup --backup | tail -n 1000 > /tmp/deja-dup.log)
It's been a half hour I run the command and still nothing happen.
Here a print-screen of my computer: https://framapic.org/2Zip3xQEvUt8/SqFxOOTu0lEP.png
When I got a respond to post, I come back.

Thank you in advance for your help.

Fabrice

Fabrice Raymond (fabrius-c) wrote :

Hello again,

Two hours later, I got the result of the DEJA_DUP_DEBUG=1 deja-dup --backup | tail -n 1000 > /tmp/deja-dup.log
You can have the file here : https://framadrop.org/r/u7FZmahW__#bYDdlqX2T1Hego7pSoqvUmwgnm3sOjlGDrXed9OkKXg=

And I forgot to say I'm using a usb hdd formated in FAT32.

If you need more information, don't hesitate to contact me!

Thank you,
Fabrice

Vej (vej) on 2018-05-11
Changed in deja-dup:
status: Incomplete → Confirmed
Fabrice Raymond (fabrius-c) wrote :

Hello everybody,

Vej, I'm sorry, I just see that I don't have this message : Giving up after 5 attempts. Error: g-io-error-quark: Error splicing file: Input/output error (0)

I've got this one : Giving up after 5 attempts. Error: g-io-error-quark: Error splicing file: File too large (0)

But the result of the command you gave me is still good.
Do you wan't I search here if there is a bug created with this message?

Sorry for the inconvenience,

Fabrice <email address hidden>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers