InvalidBackendURL: missing // - relative paths not supported for scheme gio+invalid: gio+invalid://

Bug #1717230 reported by Jan Vlug on 2017-09-14
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Déjà Dup
Undecided
Unassigned
deja-dup (Fedora)
Fix Released
Undecided
deja-dup (Ubuntu)
Undecided
Unassigned

Bug Description

1. I plug in my external USB HDD.
2. I enter the LUKS password to unlock it.
3. The disk is automatically mounted.
4. Deja-dup shows a popup window with this text: InvalidBackendURL: missing // - relative paths not supported for scheme gio+invalid: gio+invalid://

It might be that I renamed the partions on the disk.
I'm using Fedora 26 fully up-to-date.

lsb_release -d
Description: Fedora release 26 (Twenty Six)

dnf list installed | grep deja-dup
deja-dup.x86_64 35.6-1.fc26 @updates
deja-dup-nautilus.x86_64 35.6-1.fc26 @updates

When I start deja-dup to make an backup to an external USB HDD (which worked fine in the past), this error is displayed:

InvalidBackendURL: missing // - relative paths not supported for scheme gio+invalid: gio+invalid://

The external USB HDD is encrypted. When I first mount the disk, so that it is available, and then start deja-dup from the command line, I get window with this message:

Storage location not available
Waiting for '5.0 TB Encrypted' to become connected...

Note that the name of the mount point is different:
ls /run/media/jan/
'5.0 TB Partition'

In the dropdownlistbox for the Storage location in deja-dup, I only see: '5.0 TB Encrypted', not '5.0 TB Partition'.

Jan Vlug (jan-vlug) wrote :
Jan Vlug (jan-vlug) wrote :
Michael Terry (mterry) wrote :

Yikes, looks like a bad regression in external drive support in 35.x/36.0.

I've fixed in trunk and will release a 36.1 release.

https://git.launchpad.net/deja-dup/commit/?id=3390fd1b0a906b8bd4d859922844b3d57b7f5fdd

Changed in deja-dup:
status: New → Fix Committed
Michael Terry (mterry) on 2017-09-14
Changed in deja-dup:
status: Fix Committed → Fix Released

Fixed upstream.

Shouldn’t this bug remain open to track inclusion of that patch into the Fedora package for deja-dup?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deja-dup - 36.1-0ubuntu1

---------------
deja-dup (36.1-0ubuntu1) artful; urgency=medium

  * New upstream stable bug fix release
    - Fixes backing up to external drives (LP: #1717230)

 -- Michael Terry <email address hidden> Thu, 14 Sep 2017 13:47:48 -0400

Changed in deja-dup (Ubuntu):
status: New → Fix Released

In the meanwhile, I worked around the bug by selecting manually the destination location again. This means that I cannot test whether the bug is fixed.

For now I will reopen the bug.

deja-dup-36.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c27d77c788

deja-dup-36.1-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-51979dace2

deja-dup-36.1-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-51979dace2

deja-dup-36.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-c27d77c788

deja-dup-36.1-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

deja-dup-36.1-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Reto Kaiser (njam) wrote :

I still get this error with deja-dup 36.2 on Arch:

---
➜ ~ deja-dup --version
deja-dup 36.2
➜ ~ duplicity --version
duplicity 0.7.14
---

Michael Terry (mterry) wrote :

@Reto, can you upload /tmp/deja-dup.gsettings after running the following? Thanks
     gsettings list-recursively org.gnome.DejaDup > /tmp/deja-dup.gsettings

Reto Kaiser (njam) wrote :
Simon Warta (webmaster128) wrote :

I am also getting this error in deja-dup 36.2 and duplicity 0.7.12 on Ubuntu 17.10:

> InvalidBackendURL: missing // - relative paths not supported for scheme invalid: invalid://

See my deja-dup.gsettings attached

Changed in deja-dup (Fedora):
importance: Unknown → Undecided
status: Unknown → Fix Released
Ads20000 (ads20000) wrote :

I've opened a new bug here because I think that's standard practice when a bug is fixed and then apparently regresses (otherwise this bug needs to be changed from Fix Released to Confirmed)? Please Reto and Simon could you mark yourself as affected by my bug? :) https://bugs.launchpad.net/ubuntu/+source/deja-dup/+bug/1734499

SteveDude (stevedude-) wrote :

I run weekly backups with Deja-Dup, last week had no issues. This week I received "InvalidBackendURL: missing // - relative paths not supported for scheme invalid: invalid://"

I run Manajaro Linux on Gnome, 64-bit, Manjaro had an update on 2-3-18, Last week's backup was fine (2-10-18), today I cannot get it to run without this error. Thanks

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.