Blank screen after entering server details

Bug #1691865 reported by Mike Wild on 2017-05-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Déjà Dup
Medium
Unassigned

Bug Description

I am trying to backup to a SMB disk on my Time Capsule, however after entering the connection details, I am greeted with a blank screen which takes me back to the connection details screen (see attached screenshots).

I can mount the share manually using sudo mount.cifs //10.0.1.1/Data ~/test -o password=PASSWORD,sec=ntlm,uid=mike, however I've noticed that all graphical utilities (Nautilus / elementary Files, Deja-Dup etc.) struggle. Not a single utility has produced any helpful output that might indicate why they all fail unfortunately.

$ lsb_release -d
Description: elementary OS 0.4.1 Loki

$ dpkg-query -W deja-dup duplicity
deja-dup 34.2-0ubuntu1.1
duplicity 0.7.06-2ubuntu2

$ cat /tmp/deja-dup.gsettings
org.gnome.DejaDup last-restore '2017-01-25T13:26:37.639356Z'
org.gnome.DejaDup periodic false
org.gnome.DejaDup full-backup-period 90
org.gnome.DejaDup backend 'file'
org.gnome.DejaDup last-run '2017-05-16T18:08:07.839582Z'
org.gnome.DejaDup nag-check '2017-04-20T19:12:57.411567Z'
org.gnome.DejaDup prompt-check 'disabled'
org.gnome.DejaDup root-prompt true
org.gnome.DejaDup include-list ['$HOME']
org.gnome.DejaDup exclude-list ['$TRASH', '$DOWNLOAD']
org.gnome.DejaDup last-backup '2017-05-16T18:08:07.839582Z'
org.gnome.DejaDup periodic-period 7
org.gnome.DejaDup delete-after 0
org.gnome.DejaDup.S3 id ''
org.gnome.DejaDup.S3 bucket ''
org.gnome.DejaDup.S3 folder 'z600'
org.gnome.DejaDup.OpenStack authurl ''
org.gnome.DejaDup.OpenStack tenant ''
org.gnome.DejaDup.OpenStack username ''
org.gnome.DejaDup.OpenStack container 'z600'
org.gnome.DejaDup.GCS id ''
org.gnome.DejaDup.GCS bucket ''
org.gnome.DejaDup.GCS folder 'z600'
org.gnome.DejaDup.GDrive email ''
org.gnome.DejaDup.GDrive folder '/deja-dup/z600'
org.gnome.DejaDup.Rackspace username ''
org.gnome.DejaDup.Rackspace container 'z600'
org.gnome.DejaDup.File path 'smb://mike@10.0.1.1/Data'
org.gnome.DejaDup.File short-name ''
org.gnome.DejaDup.File uuid ''
org.gnome.DejaDup.File icon ''
org.gnome.DejaDup.File relpath @ay []
org.gnome.DejaDup.File name ''
org.gnome.DejaDup.File type 'normal'

$ cat /tmp/deja-dup.log
DUPLICITY: INFO 1
DUPLICITY: . Using archive dir: /home/mike/.cache/deja-dup/76aa4c411ba28c24618aae95ef719f4a

DUPLICITY: INFO 1
DUPLICITY: . Using backup name: 76aa4c411ba28c24618aae95ef719f4a

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.azurebackend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.b2backend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.botobackend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.cfbackend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.copycombackend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.dpbxbackend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.gdocsbackend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.giobackend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.hsibackend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.hubicbackend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.imapbackend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.lftpbackend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.localbackend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.megabackend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.multibackend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.ncftpbackend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.onedrivebackend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.par2backend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.pydrivebackend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.rsyncbackend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.ssh_paramiko_backend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.ssh_pexpect_backend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.swiftbackend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.sxbackend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.tahoebackend Succeeded

DUPLICITY: INFO 1
DUPLICITY: . Import of duplicity.backends.webdavbackend Succeeded

DUPLICITY: ERROR 38
DUPLICITY: . Connection failed, please check your password: g-io-error-quark: Failed to mount Windows share: Operation not permitted (0)

Hi Mike, thanks for your report.

The trouble you're having mounting your Windows share as a normal user doesn't appear to be a bug in Déjà-Dup (or any of the other graphical utilities you've tried). So I'm setting this bug's status as "Invalid" (not a bug).

Given that you can mount this share as the super-user using the command line (sudo mount...), it may be a permission issue. You may try using gvfs-mount smb://server/share instead, as a normal user, and the other gvfs-* tools I suppose. Perhaps they will spit out informative output about your issue.

For such a support request I'd recommend one of the StackOverflow websites, probably SuperUser or AskUbuntu. Or, the Answer tracker of the gvfs package on Launchpad (or its Bug tracker if this turns out to be a bug).

Best of luck.

Changed in deja-dup:
status: New → Invalid

PS: your Déjà-Dup configuration looks right, it's gvfs's SMB mounting that doesn't work, as far as I can tell.

Mike Wild (mikewild) wrote :

Hi Nathanaël,

Thank you for the prompt response. It does rather look like gvfs is the common denominator here - I'll do some more troubleshooting and raise an issue with them.

That said, I think this bug is still valid - I don't believe that Deja-Dup is handling whatever gvfs returns properly, resulting in the blank screen.

Regards,
Mike

Mike Wild (mikewild) wrote :

For anyone coming across this same issue, the fix to get gvfs working was to add an entry "client use spnego = no" in the [global] section of the file /etc/samba/smb.conf. Without this line, gvfs can't authenticate properly on password-protected shares.

For further reference, I encountered three additional problems:

1. gvfs does not recognise hostnames, so I had to convert airport-time-capsule.local => 10.0.1.1

2. gvfs seems to convert share names to lowercase, so I had to change the target share from /Data to => /data

3. Deja-Dup wasn't happy about the backup directory that was there already (from the same machine). I had to delete this. It remains to be seen whether I will be able to backup again after this initial backup completes.

Changed in deja-dup:
status: Invalid → Confirmed

> That said, I think this bug is still valid - I don't believe that Deja-Dup
> is handling whatever gvfs returns properly, resulting in the blank screen.

Point taken. I suppose this could be improved, indeed. It's beyond my current abilities though, sorry.

> Deja-Dup wasn't happy about the backup directory that was there already
> (from the same machine). I had to delete this. It remains to be seen
> whether I will be able to backup again after this initial backup
> completes.

Weird. Please keep us posted about that. Also, your two additional problems with gvfs sound like bugs to me, or at least reasonable feature requests.

Vej (vej) on 2017-05-28
Changed in deja-dup:
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers