Backup fails immediately with "Operation failed", unable to find any further messages

Bug #1679871 reported by Gord on 2017-04-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Déjà Dup
Undecided
Unassigned

Bug Description

(created from https://answers.launchpad.net/deja-dup/+question/606428)

I have been using Déjà Dup on two Ubuntu 16.04 LTS systems for quite a long time. The target for the backups is a FTP server on the same network.

This week my ISP replaced my router. After this change, backups continued to work on one of the Ubuntu systems, but on the other the backup fails immediately after I respond to the password prompt with the message "Operation failed". The password is correct, and works from the other Ubuntu system. The FTP server does not log any messages that indicate that a connection was ever received. I can ping the machine with the FTP server. On the Ubuntu system, a subdirectory is created in ~/cache/deja-dup, but nothing is written in it. I have tested with the firewall disabled on the FTP server system, but the result is the same. I have tried running deja-dup --backup from the command line with environment variable DEJA_DUP_DEBUG=1 set, but the result is the same, and no information is displayed. I haven't tried running duplicity directly, because I don't know what command line Deja Dup is sending to duplicity, and I don't want to screw up my existing backups.

I expect that I have missed a change somewhere that is resulting in this failure, but I can't find any log that would help me to identify the problem.

Any suggestions as to how I can obtain more information from Deja Dup so that I can fix my problem?

Thanks!

Settings from the failing system:
gord@CSI09-Ubuntu:~$ gsettings list-recursively org.gnome.DejaDup
org.gnome.DejaDup last-restore ''
org.gnome.DejaDup periodic true
org.gnome.DejaDup full-backup-period 90
org.gnome.DejaDup backend 'file'
org.gnome.DejaDup last-run '2017-03-24T16:46:08.174079Z'
org.gnome.DejaDup nag-check '2016-12-21T19:42:36.134680Z'
org.gnome.DejaDup prompt-check 'disabled'
org.gnome.DejaDup root-prompt true
org.gnome.DejaDup include-list ['$HOME']
org.gnome.DejaDup exclude-list ['$TRASH', '$DOWNLOAD']
org.gnome.DejaDup last-backup '2017-03-24T16:46:08.174079Z'
org.gnome.DejaDup periodic-period 7
org.gnome.DejaDup delete-after 182
org.gnome.DejaDup.S3 id ''
org.gnome.DejaDup.S3 bucket ''
org.gnome.DejaDup.S3 folder 'CSI09-Ubuntu'
org.gnome.DejaDup.OpenStack authurl ''
org.gnome.DejaDup.OpenStack tenant ''
org.gnome.DejaDup.OpenStack username ''
org.gnome.DejaDup.OpenStack container 'CSI09-Ubuntu'
org.gnome.DejaDup.GCS id ''
org.gnome.DejaDup.GCS bucket ''
org.gnome.DejaDup.GCS folder 'CSI09-Ubuntu'
org.gnome.DejaDup.GDrive email ''
org.gnome.DejaDup.GDrive folder '/deja-dup/CSI09-Ubuntu'
org.gnome.DejaDup.Rackspace username ''
org.gnome.DejaDup.Rackspace container 'CSI09-Ubuntu'
org.gnome.DejaDup.File path 'ftp://Acronis@192.168.2.10:21/CSI09/Ubuntu'
org.gnome.DejaDup.File short-name ''
org.gnome.DejaDup.File uuid ''
org.gnome.DejaDup.File icon ''
org.gnome.DejaDup.File relpath @ay []
org.gnome.DejaDup.File name ''
org.gnome.DejaDup.File type 'normal'

Gord (gord-tomlin) wrote :
Gord (gord-tomlin) wrote :
Gord (gord-tomlin) wrote :
Gord (gord-tomlin) wrote :
Gord (gord-tomlin) wrote :

I've added four screenshots to show everything I see when running
   DEJA_DUP_DEBUG=1 deja-dup --backup
from the command line.

Gord (gord-tomlin) wrote :

One additional observation: clicking "remember password" does not result in the password being remembered.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers