deja-dup password request dialog causes timeout

Bug #1197919 reported by Jens on 2013-07-04
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Déjà Dup
High
Unassigned
deja-dup (Ubuntu)
Medium
Unassigned

Bug Description

I have configured deja-dup so that it backups daily to a SMB server share. This works fine when I'm at the computer. When I'm not there, the deja-dup password prompt for the SMB share pops up. Then, if I don't enter the password within a certain time, even with the correct password I get a DBus error message and the backup fails.

deja-dup should prompt for the password and open the connection only after having received a password. Or it should automatically retry when it gets a timeout error without having to prompt again.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: deja-dup 22.0-0ubuntu4
ProcVersionSignature: Ubuntu 3.5.0-34.55~precise1-generic 3.5.7.13
Uname: Linux 3.5.0-34-generic i686
ApportVersion: 2.0.1-0ubuntu17.3
Architecture: i386
Date: Thu Jul 4 19:34:34 2013
InstallationMedia: Ubuntu 12.04.2 LTS "Precise Pangolin" - Release i386 (20130214)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: deja-dup
UpgradeStatus: No upgrade log present (probably fresh install)

Jens (jens-launchpad-net) wrote :
Jens (jens-launchpad-net) wrote :

This bug still exists in the current deja-dup version of Ubuntu trusty 14.04.3. Since this is quite a serious bug (backups not being performed when they should), can this perhaps be looked at? Thank you!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in deja-dup (Ubuntu):
status: New → Confirmed
Vej (vej) on 2017-05-28
tags: added: trusty
Changed in deja-dup (Ubuntu):
importance: Undecided → Medium
Changed in deja-dup:
status: New → Triaged
status: Triaged → Won't Fix
status: Won't Fix → Confirmed
importance: Undecided → High
Michael Terry (mterry) wrote :
Changed in deja-dup:
status: Confirmed → Fix Committed
Michael Terry (mterry) on 2017-08-04
Changed in deja-dup:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deja-dup - 35.3-0ubuntu1

---------------
deja-dup (35.3-0ubuntu1) artful; urgency=medium

  * New upstream release
    - Fixes handling of some unicode filenames
    - Fixes accuracy of checking whether some servers are reachable
      (LP: #982316)
    - Fix server password dialog giving an error if you waited a while
      before logging in (LP: #1197919)
    - Add About dialog (LP: #1703797)
    - Don't start an automatic backup on a metered connection
  * debian/control:
    - Bump Standards-Version to 4.0.0, no changes
    - Bump gtk/glib dependencies

 -- Michael Terry <email address hidden> Fri, 04 Aug 2017 12:39:31 -0400

Changed in deja-dup (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers