~/.cache/deja-dup too big after first backup

Bug #1197046 reported by ragnaroknroll on 2013-07-02
36
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Déjà Dup
Undecided
Unassigned

Bug Description

I just created my first backup of about ~300GB. This seems to have created a ~/.cache/deja-dup folder that is 3GB big. This seems unproportionately large since I don't have too much space on my / partition which is on an SSD. Could anything be done to make the cache size smaller?

1)
Using Linux Mint 15

2)
deja-dup 26.0-0ubuntu1
duplicity 0.6.21-0ubuntu1.1

3)
org.gnome.DejaDup backend 'file'
org.gnome.DejaDup delete-after 0
org.gnome.DejaDup exclude-list ['$TRASH', '$DOWNLOAD']
org.gnome.DejaDup full-backup-period 90
org.gnome.DejaDup include-list [*]
org.gnome.DejaDup last-backup '2013-07-02T14:57:53.318200Z'
org.gnome.DejaDup last-restore ''
org.gnome.DejaDup last-run '2013-07-02T14:57:53.318200Z'
org.gnome.DejaDup nag-check '2013-07-01T07:16:39.322143Z'
org.gnome.DejaDup periodic true
org.gnome.DejaDup periodic-period 7
org.gnome.DejaDup prompt-check '2013-07-01T07:18:10.084368Z'
org.gnome.DejaDup root-prompt true
org.gnome.DejaDup welcomed false
org.gnome.DejaDup.File icon ''
org.gnome.DejaDup.File name ''
org.gnome.DejaDup.File path 'smb://*/*'
org.gnome.DejaDup.File relpath @ay []
org.gnome.DejaDup.File short-name ''
org.gnome.DejaDup.File type 'normal'
org.gnome.DejaDup.File uuid ''
org.gnome.DejaDup.Rackspace container 'reagan-laptop'
org.gnome.DejaDup.Rackspace username ''
org.gnome.DejaDup.S3 bucket ''
org.gnome.DejaDup.S3 folder 'reagan-laptop'
org.gnome.DejaDup.S3 id ''
org.gnome.DejaDup.U1 folder '/deja-dup/reagan-laptop'

carlosv (cvedovatti) wrote :

I experience this problem too. I backup the home folder in the cloud ecrypted. It starts uploading and seems fine. But in the end, it starts creating huge files in the .cache/deja-dup/ that leaves my hard disc with no space and fails the backup.

I tried to delete the .cache but then it restarts again uploading, repeating the same process. and failing again.

I believe it renders useless the app.

Von (daaxix) wrote :

As carlosv states, deja-dup is useless for me, and this is still occuring in Ubuntu 14.04 with all of the latest updates.

This bug should be marked critical, since it renders backups unusable, and hence the default Ubuntu OS cannot backup.

I have about 300GB I'm backing up, and I have 12-13GB of local space available, however I cannot backup because deja-dup fills up my local drive with cache files until there is no more space available. There is plenty of space available on the backup drive.

I have deleted both the deja-dup files /tmp and in my local home .cache directory, and the behavior remains the same.

I tried working around this problem by symbolic linking ~/.cache/deja-dup to a directory on another drive. But sometime during the backup-process this link is removed and a directory is created instead.

This makes the program unusable

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers