Ignore Steam files by default

Bug #1083237 reported by Michael Terry on 2012-11-26
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Déjà Dup
Undecided
Unassigned
deja-dup (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

[Impact]
Steam is coming to Ubuntu (already in beta). Steam games are enormous, synchronized, and off-site. No need to back them up.

Once users start playing Steam games, a user that enabled backups with Deja Dup's default settings will find that all of a sudden, many gigs of data are being backed up.

Now, obviously this is a bit of a whack-a-mole problem. Many apps like Steam don't properly follow the XDG basedir spec and put cached data in ~/.cache so that Deja Dup and similar apps will ignore them. And we don't want to SRU a fix for every single non-compliant app.

But Steam is a big one. It's both very popular and its data is very very large. I think it's worth an exception to avoid the pain and bug reports that will come when many people suddenly add multiple gigs of useless data to their backups.

[Workaround]
A user can simply add ~/Steam to the backup ignore list. But every single user that uses Steam will want to do that. It's a big burden to ask of each user individually.

[Test Case]
Try backing up your home directory with Steam installed. Notice that it will include ~/Steam. With this patch (from upstream), it will ignore ~/Steam instead.

[Regression Potential]
It's a very simple fix. I think regression potential is exceedingly tiny.

[Fix Details]
We add ~/.steam/root to the hidden default ignore list. ~/.steam/root points at ~/Steam (which will also be ignored) unless the user has manually changed it.

Related branches

lp:~mterry/deja-dup/ignore-steam
Michael Terry: Approve on 2012-12-04
Robert Bruce Park (community): Abstain on 2012-11-26
Ken VanDine: Pending requested 2012-11-26
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in deja-dup (Ubuntu):
status: New → Confirmed
Michael Terry (mterry) on 2012-12-04
Changed in deja-dup:
status: New → Fix Committed
Michael Terry (mterry) wrote :
Michael Terry (mterry) wrote :
description: updated
Michael Terry (mterry) wrote :

I've uploaded both debdiffs above to precise-proposed and quantal-proposed respectively. Subscribing ~ubuntu-sru.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deja-dup - 25.1.1-0ubuntu2

---------------
deja-dup (25.1.1-0ubuntu2) raring; urgency=low

  * debian/patches/ignore-steam.patch:
    - Always ignore ~/Steam (via ~/.steam/root). Patch from upstream
      trunk. LP: #1083237
 -- Michael Terry <email address hidden> Wed, 05 Dec 2012 00:10:09 -0500

Changed in deja-dup (Ubuntu):
status: Confirmed → Fix Released
Michael Terry (mterry) on 2012-12-18
Changed in deja-dup:
milestone: none → 25.3
Michael Terry (mterry) on 2012-12-18
Changed in deja-dup:
status: Fix Committed → Fix Released

Hello Michael, or anyone else affected,

Accepted deja-dup into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/deja-dup/22.0-0ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in deja-dup (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello Michael, or anyone else affected,

Accepted deja-dup into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/deja-dup/24.0-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in deja-dup (Ubuntu Quantal):
status: New → Fix Committed
Michael Terry (mterry) wrote :

I can confirm on precise (I ran "G_MESSAGES_DEBUG=all deja-dup --backup" and observed that both ~/.steam/root and ~/.local/share/Steam were excluded).

Michael Terry (mterry) wrote :

And confirmed on quantal.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deja-dup - 22.0-0ubuntu3

---------------
deja-dup (22.0-0ubuntu3) precise-proposed; urgency=low

  * debian/patches/ignore-steam.patch:
    - Always ignore ~/Steam (via ~/.steam/root). Patch from upstream
      trunk. LP: #1083237
 -- Michael Terry <email address hidden> Tue, 04 Dec 2012 23:46:55 -0500

Changed in deja-dup (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deja-dup - 24.0-0ubuntu2

---------------
deja-dup (24.0-0ubuntu2) quantal-proposed; urgency=low

  * debian/patches/ignore-steam.patch:
    - Always ignore ~/Steam (via ~/.steam/root). Patch from upstream
      trunk. LP: #1083237
 -- Michael Terry <email address hidden> Tue, 04 Dec 2012 23:51:54 -0500

Changed in deja-dup (Ubuntu Quantal):
status: Fix Committed → Fix Released
mokrates (mmolle) wrote :

Oh my God you killed my savegame. Almost the only thing I did not have in the cloud is gone, because deja-dup doesn't back up Steam and it doesn't tell me about it! This fix is no fix. It's a bug. This kills savegames of hardcoregamers, who can potentially select to not backup Steam but only the savegames and kills the savegames of normal people who just want to play really small point and clicks like me. This angers me.

mokrates (mmolle) wrote :

How can I back up Steam with deja-dup? I want it off my ignore-list.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers