dee

unity-applications-daemon crashed with SIGSEGV in g_variant_get_type_info()

Bug #938382 reported by Scott Birk on 2012-02-22
84
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Michal Hruby
dee
High
Michal Hruby
unity-lens-applications
Undecided
Unassigned
dee (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
unity-lens-applications (Ubuntu)
Medium
Unassigned

Bug Description

I tried to turn off the "apps available for download" and it closed the dash

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity-lens-applications 5.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic i686
ApportVersion: 1.92-0ubuntu1
Architecture: i386
Date: Tue Feb 21 20:51:38 2012
ExecutablePath: /usr/lib/unity-lens-applications/unity-applications-daemon
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcCmdline: /usr/lib/unity-lens-applications/unity-applications-daemon
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x458cf4: mov (%eax),%eax
 PC (0x00458cf4) ok
 source "(%eax)" (0x000100f8) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: unity-lens-applications
StacktraceTop:
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_variant_get_type () from /lib/i386-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/libdee-1.0.so.4
 ?? () from /usr/lib/libdee-1.0.so.4
 dee_model_set () from /usr/lib/libdee-1.0.so.4
Title: unity-applications-daemon crashed with SIGSEGV in g_variant_get_type()
UpgradeStatus: Upgraded to precise on 2012-02-19 (2 days ago)
UserGroups: adm lpadmin sambashare sudo

Related branches

Scott Birk (scooterbirk) wrote :

StacktraceTop:
 g_variant_get_type_info (value=0x100f8) at /build/buildd/glib2.0-2.31.18/./glib/gvariant-core.c:582
 g_variant_get_type (value=0x100f8) at /build/buildd/glib2.0-2.31.18/./glib/gvariant.c:1994
 dee_sequence_model_set_value_silently (self=0x91f5420, iter=0x926f218, column=7, value=0x100f8) at dee-sequence-model.c:555
 dee_sequence_model_set_row (self=0x91f5420, iter=0x926f218, row_members=0x9176f80) at dee-sequence-model.c:533
 dee_model_set_valist (args=0xbf82a8cc, iter=0x926f218, self=0x91f5420) at dee-model.c:1249

Changed in unity-lens-applications (Ubuntu):
importance: Undecided → Medium
summary: - unity-applications-daemon crashed with SIGSEGV in g_variant_get_type()
+ unity-applications-daemon crashed with SIGSEGV in
+ g_variant_get_type_info()
tags: removed: need-i386-retrace
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-lens-applications (Ubuntu):
status: New → Confirmed
Michal Hruby (mhr3) on 2012-04-11
Changed in dee:
status: New → Fix Committed
milestone: none → 1.0.10
assignee: nobody → Michal Hruby (mhr3)
importance: Undecided → High
Changed in unity:
assignee: nobody → Michal Hruby (mhr3)
importance: Undecided → High
status: New → Fix Committed
milestone: none → 5.10.0
Didier Roche (didrocks) on 2012-04-12
Changed in dee:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-lens-applications:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dee - 1.0.10-0ubuntu1

---------------
dee (1.0.10-0ubuntu1) precise; urgency=low

  * New upstream release.
    - unity-music-daemon crashed with SIGSEGV in find_term_real() from
      dee_tree_index_lookup() from dee_index_lookup() from
      unity_music_lens_rhythmbox_collection_search() (LP: #963991)
    - unity-applications-daemon crashed with SIGSEGV in
      g_variant_get_type_info() (LP: #938382)
    - unity-applications-daemon crashed with SIGSEGV in
      g_variant_type_info_check() (LP: #953978)
  * debian/control:
    - update Standards-Version to latest
 -- Didier Roche <email address hidden> Thu, 12 Apr 2012 11:33:08 +0200

Changed in dee (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 5.10.0-0ubuntu1

---------------
unity-lens-applications (5.10.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Regression: Installed apps not sorted alphabetically (LP: #964325)
    - unity-applications-daemon crashed with SIGSEGV in
      g_variant_get_type_info() (LP: #938382)
    - Apps rank too high with exact matches in Keywords (LP: #960269)
  * debian/control:
    - bump Standards-Version to latest
 -- Didier Roche <email address hidden> Thu, 12 Apr 2012 11:48:26 +0200

Changed in unity-lens-applications (Ubuntu):
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers