dee

'SharedModel' object has no attribute 'append' using Python 3 on 12.04

Bug #1096708 reported by Thomas Mashos on 2013-01-07
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
dee
Undecided
Unassigned
dee (Ubuntu)
Undecided
Łukasz Zemczak
Precise
Undecided
Unassigned

Bug Description

[Test Case]

1. Start python3
2. from gi.repository import Dee
   -> Make sure that SharedModel has the append() function available

[Regression Potential]

No obvious regression potential, in worst case some problems with python 2 introspection.

Original description:

A Unity scope written in Python 3 on 12.04 gets the following error message when attempting to search

'SharedModel' object has no attribute 'append'

The same code works fine on 12.10. Similar code worked fine in 12.04 using Python 2 (before I ported it to Python 3). The code portions in question are the same between the Python 2 and Python 3 versions.

The scope I'm working on is here

https://code.launchpad.net/~mythbuntu/mythbuntu/unity-scope-mythtv

Thomas Mashos (tgm4883) wrote :

Installing both git1.2-dee-1.0 and libdee-1.0-4 from 12.10 resolves the issue. Installing just libdee-1.0-4 from 12.10 didn't resolve the issue, although I didn't test just installing the other package.

Thomas Mashos (tgm4883) wrote :

Confirmed that a fully updated 12.04 install with the following package versions has this issue.

libdee-1.0-4 1.0.10-0ubuntu1
gir1.2-dee-1.0 1.0.10-0ubuntu1

and that installing the following package versions from 12.10 resolves the issue. gir1.2-dee-1.0 cannot be upgraded unless libdee-1.0-4 is upgraded first.

libdee-1.0-4 1.0.14-0ubuntu1
gir1.2-dee-1.0 1.0.14-0ubuntu1

Łukasz Zemczak (sil2100) wrote :

So, indeed the precise dee packages do not have the fix for this issue - but I'll be working on back-porting it to the precise packaging and sending it to the SRU team for release. Please be patient!

Changed in dee (Ubuntu):
assignee: nobody → Łukasz Zemczak (sil2100)
Thomas Mashos (tgm4883) wrote :

Will do. Thanks Łukasz

Changed in dee (Ubuntu):
status: New → In Progress
Changed in dee:
status: New → Fix Committed
description: updated
Didier Roche (didrocks) on 2013-02-06
Changed in dee (Ubuntu):
status: In Progress → Fix Released

Hello Thomas, or anyone else affected,

Accepted dee into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/dee/1.0.10-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in dee (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Timo Jyrinki (timo-jyrinki) wrote :

Seems to be fixed after update, append() appeared after updating the dee from precise-proposed.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dee - 1.0.10-0ubuntu1.1

---------------
dee (1.0.10-0ubuntu1.1) precise-proposed; urgency=low

  * Cherry-pick upstream:
    - 'SharedModel' object has no attribute 'append' using Python 3 on 12.04
      (LP: #1096708) (LP: #905085)
  * debian/control, debian/rules:
    - install the python3 version of the override gobject introspection file,
      as made by Didier Roche
 -- Lukasz 'sil2100' Zemczak <email address hidden> Wed, 30 Jan 2013 16:50:42 +0100

Changed in dee (Ubuntu Precise):
status: Fix Committed → Fix Released
Michal Hruby (mhr3) on 2013-04-10
Changed in dee:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers