Volume button not shown by default

Reported by Mark Finger on 2011-03-10
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Decibel Audio Player
Low
François Ingelrest

Bug Description

As of 1.07 and the current dev repo, the volume button is not being displayed in the interface.

I added

self.wtree.get_widget('btn-volume').show()

to the init function in src/gui/mainWindow.py and it fixed it, however the style properties are messed up when switching from the netbook view.

Adding,

ctrlPanel.child_set_property(slider, 'expand', True)
ctrlPanel.child_set_property(btnVolume, 'expand', False)

to the end of __fromModeNetbook fixes the styling problems.

I'm not sure what's causing this as nothing seems to be directly referring to and hiding the 'btn-volume' widget, fiddling with the GTK properties in res/MainWindow.glade doesn't seem to resolve it either.

Anyway, I've attached a patch that's fixed it for me. It's all the code as above.

Cheers,
Mark.

Mark Finger (markfinger) wrote :
Mike M (hairy-palms-19) wrote :

just saw this after updating decibel (since natty still shipts 1.06 for some reason) , adding those 3 lines fixed it right up.

François Ingelrest (athropos) wrote :

The button is hidden when the system is running PulseAudio, as a result of this ticket:

https://bugs.launchpad.net/decibel-audio-player/+bug/511589

I've added a --volume-button command line flag to force the volume button to be displayed even when PulseAudio is running. This is currently available on the trunk.

Changed in decibel-audio-player:
assignee: nobody → François Ingelrest (athropos)
importance: Undecided → Low
status: New → Fix Committed
François Ingelrest (athropos) wrote :

See v1.08

Changed in decibel-audio-player:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers