The sort order is incorrect when adding a compilation to the playlist from the file explorer

Bug #271856 reported by Anonym25712
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Decibel Audio Player
Undecided
Anonym25712

Bug Description

Even when tracks are correctly tagged, if they come a compilation with different artist, the sort order when adding them to the playlist from the file explorer is incorrect. This does not happen when using the Library module.

Revision history for this message
Anonym25712 (anonym25712) wrote :

Fixed in trunk.

Changed in decibel-audio-player:
assignee: nobody → athropos
status: New → Fix Committed
Revision history for this message
Anonym25712 (anonym25712) wrote :

See v1.00.

Changed in decibel-audio-player:
status: Fix Committed → Fix Released
Revision history for this message
melkart (jfh) wrote :

I am running v1.00 and the files, when added to the playlist, are not sorted in the same way as in the file explorer. Admittedly, the tags of my files contain garbane, but I can't even figure out how they are supposed to be sorted. It's neither by number, nor by title, album name, interpret or duration.

Revision history for this message
Jendrik Seipp (jendrikseipp) wrote :

Reopening the bug, because it still occurs in 1.03.

How to reproduce: Add a directory from file explorer containing a compilation into the playlist -> Tracks are sorted by their artist name.

How to fix: Do not compare tracks by their artist names if they have the same album name.

I have written a simple patch (added 2 lines and indented some). You find it in the linked branch in the file "src/media/track/__init__.py" line 159 revision 10.

Cheers!

Changed in decibel-audio-player:
status: Fix Released → New
Revision history for this message
Anonym25712 (anonym25712) wrote :

I can't reproduce it, for me it works fine: I add a directory containing a compilation album from the file explorer, and tracks are then sorted by track number.

What is the 'performer' tag of these files? (It's generally "Various Artists"). If possible, I'd like to get a few files from a compilation that doesn't work for you.

Changed in decibel-audio-player:
status: New → Incomplete
Revision history for this message
Jendrik Seipp (jendrikseipp) wrote :

You can find one example compilation that doesn't work for me here:
http://www.bootiemashup.com/bestofbootie2009/

When I drag the album into the playlist the tracks are sorted by the artist, not the track number.

Actually the length of the tracknames also asks for the ellipsize option propsed here ;-) :
https://bugs.launchpad.net/decibel-audio-player/+bug/264546

Revision history for this message
Anonym25712 (anonym25712) wrote :

These files don't have a performer tag, that's why they are not correctly sorted.

When adding files to playlist, the sort order is:

artist > album > disc number > track number

If a performer tag is present, then the sort order is

performer > artist > album > disc number > track number

Since your files don't have a performer tag, the first sort order is used and of course everything looks screwed up. You can use Ex Falso to add a performer tag with the value 'Various Artists' for instance.

Changed in decibel-audio-player:
status: Incomplete → Invalid
Revision history for this message
Jendrik Seipp (jendrikseipp) wrote :

Help me out here. I haven't tried it in decibel, but just by looking at your explanation:

When I add "Various Artists" to the performer tag it shouldn't change the sort order, judging by your explanation. Or have you mixed up the second order?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers