Xprint is deprecated, so remove libxp?

Bug #1266078 reported by Graham Inggs on 2014-01-04
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ecore (Debian)
Fix Released
Unknown
ecore (Ubuntu)
Undecided
Unassigned
efl (Debian)
Fix Released
Unknown
efl (Ubuntu)
Undecided
Unassigned
gridengine (Debian)
Fix Released
Unknown
gridengine (Ubuntu)
Undecided
Unassigned
kterm (Debian)
Fix Released
Unknown
kterm (Ubuntu)
Undecided
Unassigned
libxp (Debian)
Fix Released
Unknown
libxp (Ubuntu)
Undecided
Unassigned
matlab-support (Debian)
Fix Released
Unknown
matlab-support (Ubuntu)
Undecided
Unassigned
rox (Debian)
Fix Released
Unknown
rox (Ubuntu)
Undecided
Unassigned
texlive-bin (Debian)
Fix Released
Unknown
texlive-bin (Ubuntu)
Undecided
Unassigned
ubuntu-seeds (Ubuntu)
Undecided
Unassigned
xawtv (Debian)
Fix Released
Unknown
xawtv (Ubuntu)
Undecided
Unassigned
xtel (Debian)
Fix Released
Unknown
xtel (Ubuntu)
Undecided
Unassigned
xutils-dev (Debian)
New
Unknown
xutils-dev (Ubuntu)
Undecided
Unassigned

Bug Description

Copy-and-pasted almost verbatim from Debian bug #657253:

The xprint package is obsolete and and has been removed. A related library is libxp, which provides an API that enables client programs to access and use an Xprint server. Since we've gotten rid of xprint, one could argue it makes sense to get rid of libxp as well.

A number of packages depend on libxp. This situation sometimes arises historically from the time before xprint was considered obsolete, with Build-depends: libxp-dev being set in the past and then forgotten and untouched.

This bug has been filed to put the question of whether or not to keep libxp on the record, and to help keep track of the dependent packages (and the bugs filed against them).

In Ubuntu, libxp6 is seeded in desktop for compatibility with third party applications that expect libxp6 to be available, see bug #21953. In package matlab-support, libxp6 is a dependency as it was required by MATLAB, however this has not been the case since MATLAB R2011b.

Changed in gridengine (Debian):
status: Unknown → Fix Released
Changed in ecore (Debian):
status: Unknown → New
Changed in matlab-support (Debian):
status: Unknown → New
Changed in rox (Debian):
status: Unknown → New
Changed in libxp (Debian):
status: Unknown → New
Changed in xutils-dev (Debian):
status: Unknown → New
Changed in xawtv (Debian):
status: Unknown → New
Changed in xtel (Debian):
status: Unknown → New
Changed in kterm (Debian):
status: Unknown → New
Graham Inggs (ginggs) wrote :

Fix released in gridengine 6.2u5-7.2ubuntu1.

Changed in gridengine (Ubuntu):
status: New → Fix Released
Changed in kterm (Debian):
status: New → Fix Committed
Changed in kterm (Debian):
status: Fix Committed → Fix Released
Graham Inggs (ginggs) wrote :

Fix released in kterm 6.2.0-46.1.

Changed in kterm (Ubuntu):
status: New → Fix Released
Changed in xawtv (Debian):
status: New → Fix Released
Graham Inggs (ginggs) wrote :

Fix released in xawtv 3.103-3.

Changed in xawtv (Ubuntu):
status: New → Fix Released
Changed in rox (Debian):
status: New → Fix Released
Graham Inggs (ginggs) wrote :

Fix released in rox 1:2.11-1.

Changed in rox (Ubuntu):
status: New → Fix Released
Changed in matlab-support (Debian):
status: New → Fix Committed
Changed in xutils-dev (Debian):
status: New → Fix Committed
Changed in texlive-bin (Debian):
status: Unknown → Fix Committed
Changed in xtel (Debian):
status: New → Fix Committed
Changed in efl (Debian):
status: Unknown → New
Changed in texlive-bin (Debian):
status: Fix Committed → Fix Released
Changed in xtel (Debian):
status: Fix Committed → Fix Released
Changed in matlab-support (Debian):
status: Fix Committed → Fix Released
Graham Inggs (ginggs) wrote :

Fix released in xtel 3.3.0-17.1 and matlab-support 0.0.19+nmu1.

Changed in xtel (Ubuntu):
status: New → Fix Released
Changed in matlab-support (Ubuntu):
status: New → Fix Released
Changed in texlive-bin (Ubuntu):
status: New → Fix Released
Graham Inggs (ginggs) wrote :

Fix released in texlive-bin 2014.20140926.35254-2.

Changed in ecore (Debian):
status: New → Fix Committed
Changed in efl (Debian):
status: New → Fix Committed
Graham Inggs (ginggs) on 2015-06-16
Changed in ecore (Ubuntu):
status: New → Invalid
Changed in ecore (Debian):
status: Fix Committed → Fix Released
Changed in efl (Debian):
status: Fix Committed → Fix Released
Graham Inggs (ginggs) wrote :

Fix released in efl 1.8.6-2.2ubuntu1.

Changed in efl (Ubuntu):
status: New → Fix Released
Changed in libxp (Debian):
status: New → Fix Released
Steve Langasek (vorlon) wrote :

libxp has been removed from Debian, and is now removed from Ubuntu as of wily.

Changed in libxp (Ubuntu):
status: New → Fix Released
Changed in xutils-dev (Ubuntu):
status: New → Fix Released
Colin Watson (cjwatson) wrote :

I'm unsubscribing the ubuntu-archive team from this bug, since the remaining non-Ubuntu tasks on this bug were showing up on our to-do list. Feel free to resubscribe us if there's some new concrete action for us to take here.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-seeds (Ubuntu):
status: New → Confirmed
Changed in xutils-dev (Debian):
status: Fix Committed → New
Graham Inggs (ginggs) wrote :

Tested in xenial with xtel and fix #733290 reverted.

gcc -o xtel -g -O2 -DUSE_MOTIF -DUSE_SYSLOG -DDONT_USE_POPUP xtel.o ligne.o bouton.o inet.o imprime.o lecteur.o procedure.o teleinfo.o copyright.o protocoles.o misc.o version.o xm.o -LVideotex -lVideotex -LWidgets -lWidgets -ljpeg -lXm -lXt -lSM -lICE -lXp -lXext -lX11 -lXpm -lXt -lSM -lICE -lXext -lX11
/usr/bin/ld: cannot find -lXp
collect2: error: ld returned 1 exit status
Makefile:1902: recipe for target 'xtel' failed

Changed in xutils-dev (Ubuntu):
status: Fix Released → Confirmed
Timo Aaltonen (tjaalton) wrote :

why would you revert #733290?

Timo Aaltonen (tjaalton) wrote :

sorry, got it now

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.