[nvidia] X.org hangs machine on hardy with "mieqEnequeue: out-of-order valuator event" error

Bug #229704 reported by Cian Davis
10
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.24 (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-nv (Debian)
Fix Released
Unknown

Bug Description

Binary package hint: xserver-xorg-video-nv

X.org hangs after approximately 2 hours. Mostly the screen just hangs. Occasionally, the mouse will come back but nothing will work. Sometimes, the server will restart but drop to low-graphics mode but remains un-usable. TwinView with 2 monitors of same resolution used. (xorg.conf attached)

While you can still SSH to the machine, restarting X/gdm results in a black screen.

Lots of errors in /var/log/Xorg.0.log (attached)
mieqEnequeue: out-of-order valuator event; dropping.
tossed event which came in late

Same problem as http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=462127

Revision history for this message
Cian Davis (davisc) wrote :
Revision history for this message
Cian Davis (davisc) wrote :

2nd post to attach Xorg.conf...

Revision history for this message
lemonade (lemonade) wrote :

I'm having this same issue. After using computer a while, mouse and keyboard begin to hang for a while. After that mouse cursor usually begins to move - but doesn't react clicking. Keyboard seems to be all dead. Befor missed event texts I have in Xorg-log following which might be caused by this issue:

...
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Initialized GPU GART.
(EE) NVIDIA(0): Error recovery failed.
(EE) NVIDIA(0): *** Aborting ***
(II) NVIDIA(0): Initialized GPU GART.
tossed event which came in late
mieqEnequeue: out-of-order valuator event; dropping.
...

Changed in xserver-xorg-video-nv:
status: Unknown → New
Revision history for this message
QJG (wpc0000) wrote :

I'm having this same issue.
Waiting for solving.

Revision history for this message
Alex Salter (e-launchpad-alexsalter-com) wrote :

Hi,

Judging from my Xorg-log I would say I've got the same issue here. It started immediately after upgrading to Ubuntu 8.04 and seems to only occur whilst either visiting web sites containing flash or running World of Warcraft(wine).

I've tried both the amd64 and x86 versions of Ubuntu 8.04 and both suffer from the issue immediately after install.

I'm pretty new to Ubuntu so if theres any logs or anything you need just ask.

Regards
Alex

Revision history for this message
Brian J. Murrell (brian-interlinx) wrote :

Not to be an AOLer, but "me too".

What's strange is that this really only just started happening now even though this machine has been running stably for years, and even stable since upgraded to Hardy when it came out. Now all of a sudden X is hanging and I see in the Xorg.0.log:

(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(EE) NVIDIA(0): Error recovery failed.
(EE) NVIDIA(0): *** Aborting ***
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(EE) NVIDIA(0): Error recovery failed.
(EE) NVIDIA(0): *** Aborting ***
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(EE) NVIDIA(0): Error recovery failed.
(EE) NVIDIA(0): *** Aborting ***
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Initialized GART.
(EE) NVIDIA(0): Error recovery failed.
(EE) NVIDIA(0): *** Aborting ***

Revision history for this message
Bryce Harrington (bryce) wrote :

Hi davisc,

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with the latest development release of Ubuntu? (ISOs are available from cdimage.ubuntu.com)

If it remains an issue, could you also attach a new /var/log/Xorg.0.log?
Thanks in advance.

The output of lspci -vvnn would also be worth having.

Changed in linux-restricted-modules-2.6.24:
status: New → Incomplete
Revision history for this message
lemonade (lemonade) wrote :

I'm not having this issue any more with Ubuntu 8.10 and latest Nvidia drivers. So I guess it's fixed now.

Revision history for this message
Cian Davis (davisc) wrote :

I'm still having the problem on Ubuntu 8.10.

[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Bryce Harrington (bryce)
Changed in linux-restricted-modules-2.6.24 (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Debo~ Dutta (debo) wrote :

I have the same problem on both Ubuntu 8.10 and 9.04 on x86_64 ... upgraded to 180.xx due to VDPAU :(

(II) XINPUT: Adding extended input device "Logitech USB-PS/2 Optical Mouse" (type: MOUSE)
(**) Logitech USB-PS/2 Optical Mouse: YAxisMapping: buttons 4 and 5
(**) Logitech USB-PS/2 Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Initialized GPU GART.
....... several lines ....

machine freezes, needs hard reset.

Bryce Harrington (bryce)
tags: added: hardy
Changed in xserver-xorg-video-nv (Debian):
status: New → Fix Released
Revision history for this message
Bryce Harrington (bryce) wrote :

[Expired]

Changed in linux-restricted-modules-2.6.24 (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.