(Jaunty) Wicd No Longer Allows Me To Connect

Bug #361461 reported by Jeremy LaCroix on 2009-04-15
This bug affects 16 people
Affects Status Importance Assigned to Milestone
wicd (Debian)
wicd (Ubuntu)
Nominated for Karmic by superlex

Bug Description

Binary package hint: wicd

I am using Kubuntu Jaunty 64-bit with all updates. My wireless network is set up with a WEP shared key, which is required for my Nintendo DS unfortunately.

Due to bug #339313 I am unable to connect with Kubuntu's network manager plasmoid that ships by default. As a temporary work around, I am currently using wicd. For several weeks, it's been working fine. However, late last week some updates came in (sorry I don't remember what they were) and since then, wicd won't connect either. My laptop doesn't require proprietary software for the wireless card, because it works out of the box, or at least it did. No problems in Intrepid either.

Basically I try to connect with wicd, and it just tries indefinitely. Sometimes it will fail out, but I haven't noticed a pattern and I don't get any error messages. My routers wireless lights react to my laptop while I try to connect. My Vista partition on the same machine connects fine, as do other Intrepid laptops on the same network.

My network card is as follows:
02:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)

I will be attaching files that I hope will be of assistance.

I bought a new router and I am still having this problem.

Andreas Beder (andreas-beder) wrote :

i got the same problem
wlan0: deauthenticating by local choice (reason=3)
02:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
Xubuntu 9.04 amd(64)

For me this is working after upgrading to the latest version of WICD through the WICD repository.

c0t0d0s2 (c0t0d0s2) wrote :

The same problem on IBM ThinkPad T61
Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron]

reinstalling network-manager helped

mehturt (mehturt) wrote :

I have a similar problem with my Dell D630 (using iwl3945) and my other pc with Asus Wl-167g. I am able to connect to my WPA2 network randomly.

Jorge Gustavo (jgr) wrote :

Same "wlan0: disassociating by local choice (reason=3)" here, but without wicd.

Using NetworkManager, sometimes I can stay connected for a while, sometimes I don't.
It only happens with the local university wireless (eduroam), which uses WPA&WPA2.

No problem, on other networks with WEP security.

iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27k
iwlagn: Copyright(c) 2003-2009 Intel Corporation
iwlagn 0000:06:00.0: Detected Intel Wireless WiFi Link 4965AGN REV=0x4

lsmod | grep wla
iwlagn 109468 0
iwlcore 113212 1 iwlagn
mac80211 181108 2 iwlagn,iwlcore
cfg80211 93052 3 iwlagn,iwlcore,mac80211

Bob Wanamaker (rlw-nycap) wrote :

I see this using the b43 module, an IBM NetVista PC, Linksys WMP54GS, Jaunty, with WPA

dpkg -l network-manager*
ii network-manager 0.7.1.git.5.272c6a626-0ubuntu1~nm1~jaunty
ii network-manager-gnome 0.7.1.git.5.272c6a626-0ubuntu1~nm1~jaunty

lspci | grep 4318
02:0c.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

[397797.951896] wlan0: deauthenticated (Reason: 2)
[397798.948034] wlan0: direct probe to AP dfafa6b8 try 1
[397798.950080] wlan0 direct probe responded
[397798.950086] wlan0: authenticate with AP dfafa6b8
[397798.951687] wlan0: authenticated
[397798.951690] wlan0: associate with AP dfafa6b8
[397798.954403] wlan0: RX ReassocResp from d26b303e (capab=0x431 status=0 aid=1)
[397798.954407] wlan0: associated
[397806.193073] wlan0: disassociating by local choice (reason=3) # At this point I close the browser (firefox) and in NetworkManager choose wlan0 again - it quickly re-associates.
[397810.692468] wlan0: authenticate with AP dfafa6b8
[397810.694760] wlan0: authenticated
[397810.694766] wlan0: associate with AP dfafa6b8
[397810.696999] wlan0: RX ReassocResp from de0e803e (capab=0x431 status=0 aid=1)
[397810.697004] wlan0: associated

It will stay connected for a while - b43 is much better than ndiswrapper with a windoze driver.

superlex (e-lex) wrote :

Ubuntu Karmic (9.10) using kde-network-manager

lspci | grep Network
06:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)

disassociating by local choice (reason=3

blubbi (torsten-steiner) wrote :

same here

thinkpad t500

Network controller: Intel Corporation Wireless WiFi Link 5300

Ubfan (ubfan1) wrote :

I just saw the "disassociation by local choice (reason 3)" on Karmic & Jaunty USB based systems which previously worked fine. I'm using the b43 Broadcom open driver and the opensource Broadcom firmware. I think this is a hardware problem, since iwlist scan will show the two available aps with strengths around -75db and quality of both in 30s where one shoud be qual = 78/100, strength= -59db and other is 2/100, -89 Db. The laptop having problems has been failing, and this looks like the latest failure symptom. Your probems may be as simple as a bad antenna connection.
Good Luck

Ubfan (ubfan1) wrote :

Another possibility is that your access point has run out of ip address leases. I upped the number from 3 to 10 and things started working again.

Hi all.
I can stay connect to the AP with WPA-PSK AES, but connection don't start at boot.
I have to restart network manually for make it work.
When I look my dmesg i see that:

-------------------[dmesg | grep '30\.']-------------------

wlan0: direct probe to AP 00:26:5a:9d:f0:76 (try 1)
wlan0: direct probe responded
wlan0: authenticate with AP 00:26:5a:9d:f0:76 (try 1)
wlan0: authenticated
wlan0: associate with AP 00:26:5a:9d:f0:76 (try 1)
wlan0: RX AssocResp from 00:26:5a:9d:f0:76 (capab=0xc31 status=0 aid=1)
wlan0: associated
wlan0: deauthenticating from 00:26:5a:9d:f0:76 by local choice (reason=3)


it repeat thousand or more times.
But after restart networking, NO PROBLEM!


auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet dhcp
up wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf -B

Chatty (mail-chatty) wrote :

with WPA2 connection works
with deauth, reason 3

Igor Vatavuk (igor-vatavuk) wrote :

Hi, did you try changing the channel in your router's settings?
Try that and see if it helps, it helped me with a similar issue.
You don't need to change configuration of your PCs, they will pick up the change themselves.

newbie (mahesh-isin) wrote :

Igor's solution is the one that worked for me. My channel was set to Automatic, 11. I logged in to my router and changed it to Manual, 10. Then deleted the existing connection from Network Manager and found and reconnected to my router. And I guess I will live happily everafter. Thanks guys, thanks Igor!

Alexander Luksep (a-luksep) wrote :

This is probably not a bug with wicd since I'm having an identical issue with network-manager in (x)ubuntu 10.10 rc.

There is nothing wrong with the wireless network here in the university (we use eduroam), it works flawlessly on the same hardware under Windows (XP/7) as well as on my android phone.

I'd rather guess this has something to do with timeouts beeing set too short and triggering prematurely.
I did for example find this:
[ 1723.492120] No probe response from AP 00:25:84:49:db:64 after 500ms, disconnecting.
Which, imho, seems a bit short in a crowded wireless environment.

While writing this I believe a lot of users has left the building (it's now 16:30 local time) and consequently, the connection seems to be pretty stable now compared to an hour ago, but I will get a chance to verify this assumption tomorrow.

Changed in wicd (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers