Debian GNU/Linux

wacomcpl missing from package

Reported by Florian Hackenberger on 2008-04-12
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
wacom-tools (Debian)
New
Unknown
wacom-tools (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: wacom-tools

The wacomcpl tools is missing from the package. Without this tool it is currently impossible to calibrate wacom tablets. This is quite unfortunate as for example the X61t screen is inaccurate without calibration.

Please include this tool in your package.

Related branches

On Mon, Jun 20, 2005 at 02:27:31PM -0500, John Goerzen wrote:
> The source distribution includes wacomcpl which, among other things, can
> calibrate the stylus on a table PC. It would be nice to see this
> included in wacom-tools (or a separate binary package, at your
> discretion).

Is there anything this can do that can't be done with xsetwacom (which
is in the package) ?

Work is underway on a couple of fronts for a gui interface that doesn't
involve getting all covered in tcl. It is planned for the package to
supply such a thing, but for the moment there are a number of higher
priority (and lower level) issues that need to be fixed to give that
a stable base, so it may be a little while still.

 Ron

On Tue, Jun 21, 2005 at 05:09:53PM +0930, Ron wrote:
> On Mon, Jun 20, 2005 at 02:27:31PM -0500, John Goerzen wrote:
> > The source distribution includes wacomcpl which, among other things, can
> > calibrate the stylus on a table PC. It would be nice to see this
> > included in wacom-tools (or a separate binary package, at your
> > discretion).
>
> Is there anything this can do that can't be done with xsetwacom (which
> is in the package) ?

Yes, it can be used to calibrate the stylus on a tablet PC. xsetwacom
doesn't have that feature. (It displays "targets" on the screen to
select with the stylus, and generates appropriate calls to xsetwacom
based on the stylus offset from them.) A very important and useful
feature :-)

> Work is underway on a couple of fronts for a gui interface that doesn't
> involve getting all covered in tcl. It is planned for the package to

It's pretty easy in this case, just depend on tk8.4 and that should be
it.

-- John

Changing the stylus/eraser/etc. pressure sensitivity is a pretty common
task. I think I speak for all math-illiterate users out there when I say
that it's much easier to adjust an ugly Tk slider than to input 4
integers parameters for a bezier curve (using xsetwacom set
PressureCurve...).

Please include/package wacomcpl. Thanks :)

It seems that the i386 package in the archive really has the
aforementioned bug. I downloaded it again from a different mirror to be
sure:

dreamscape:~$ wget -q
http://ftp.us.debian.org/debian/pool/main/w/wacom-tools/xserver-xorg-input-wacom_0.7.4.1-3_i386.deb
dreamscape:~$ dpkg -c xserver-xorg-input-wacom_0.7.4.1-3_i386.deb | grep
/lib/udev/check_driver
-rw-r--r-- root/root 499 2006-05-18 08:51 ./lib/udev/check_driver

Woops, wrong bug number. Should have gone to #384873

Vincent Crevot a écrit :
> It seems that the i386 package in the archive really has the
> aforementioned bug. I downloaded it again from a different mirror to be
> sure:
>
> dreamscape:~$ wget -q
> http://ftp.us.debian.org/debian/pool/main/w/wacom-tools/xserver-xorg-input-wacom_0.7.4.1-3_i386.deb
> dreamscape:~$ dpkg -c xserver-xorg-input-wacom_0.7.4.1-3_i386.deb | grep
> /lib/udev/check_driver
> -rw-r--r-- root/root 499 2006-05-18 08:51 ./lib/udev/check_driver
>
>

Binary package hint: wacom-tools

The wacomcpl tools is missing from the package. Without this tool it is currently impossible to calibrate wacom tablets. This is quite unfortunate as for example the X61t screen is inaccurate without calibration.

Please include this tool in your package.

Justin Dugger (jldugger) on 2008-06-21
Changed in wacom-tools:
status: New → Confirmed
Changed in wacom-tools:
status: Unknown → New

Reported in Ubuntu here:
https://bugs.edge.launchpad.net/debian/+source/wacom-tools/+bug/216347

Are there any plans to fix this bug by say October? I understand that
long run goals include less ugly GUI, but there's ample reason to
include a simple fix in the short term.

Justin Dugger

Christophe Olinger (olingerc) wrote :

I also would love to have this.

kirys (kirys) wrote :

Is there any plan to add wacomcpl to the package or as a separated package?

Michael S Costello (fraterm) wrote :

One workaround for installing the wacomcpl (that seems to work) is the ubuntu forum howto posting here: http://ubuntuforums.org/showthread.php?t=765915 though this is titled as an enabling means to using a bamboo fun, it will install differing versions of wacomcpl as well as wacdump wacomcpl-exec xidump and xsetwacom in /usr/local/bin.

I'd much rather have a nice non tcl/tk package as well, but it doesn't seem to be a high priority at the moment for such a tidy package to be done in the near future.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wacom-tools - 1:0.8.1.4-0ubuntu2

---------------
wacom-tools (1:0.8.1.4-0ubuntu2) intrepid; urgency=low

  * debian/rules: Don't use the fdi file, since with input-hotplug it's not
    possible to fully utilize the device, and properly configuring it is
    more awkward. Install it in /usr/share/doc/xserver-xorg-input-wacom
    instead so people can use it if they want.
  * Include wacomcpl so the stylus can be calibrated. (LP: #216347)
    - debian/rules: --enable-libwacomxi
    - debian/control: Add tcl-dev, tk-dev to Build-Depends, and tcl, tk to
      wacom-tools Depends.

 -- Timo Aaltonen <email address hidden> Fri, 10 Oct 2008 13:45:33 +0300

Changed in wacom-tools:
status: Confirmed → Fix Released
Jeff (jeffz42) wrote :

will this fix be included in hardy?

Loïc Martin (loic-martin3) wrote :

wacomcpl in Intrepid doesn't work (reports no Device) when wacom tablets are enabled using hal (sudo cp /usr/share/doc/xserver-xorg-input-wacom/10-wacom.fdi /usr/share/hal/fdi/policy/20thirdparty/10-wacom.fdi).

I've personally disliked wacomcpl for a long long time.

    1. Ugly Tcl interface
    2. It tries to be too smart and edits my ~/.xinitrc, and *ALWAYS*
       botches it.
    3. When "xsetwacom list dev" returns no devices, it borks.

Most of wacomcpl functionality can be done by RTFM + xsetwacom, so it's
not usually an issue. However, as pointed out here, stylus calibration
could use GUI to set the parameters.

So I wrote one :). I'm attaching a Gtk+perl script that helps
calibrating the stylus. If it doesn't get a list of devices from
'xsetwacom list dev', then it looks in the environment variables
'WACOM_*'.

It also doesn't touch your ~/.xinitrc. It only saves the calibration
parameters to ~/.calibrate.X (where X=1,2,3,4 depending on the tablet
rotation). It's up to the user to source (or not to source) these files
on startup. I personally automate by running

    WACOM_STYLUS=<name of your stylus device>
    tablet_rotation=$(xsetwacom get "$WACOM_STYLUS" Rotate)
    [[ -f ~/.calibrate.$tablet_rotation ]] && \
 source ~/.calibrate.$tablet_rotation

on startup, and every time the screen is rotated.

GI

--
'Snackmosphere' -- The 95% air inside a bag of chips.

On Sun, Jan 10, 2010 at 06:24:22PM -0500, GI wrote:

> I'm attaching a Gtk+perl script that helps
> calibrating the stylus. If it doesn't get a list of devices from
> 'xsetwacom list dev', then it looks in the environment variables
> 'WACOM_*'.
>
> It also doesn't touch your ~/.xinitrc. It only saves the calibration
> parameters to ~/.calibrate.X (where X=1,2,3,4 depending on the tablet
> rotation). It's up to the user to source (or not to source) these files
> on startup. I personally automate by running
>
> WACOM_STYLUS=<name of your stylus device>
> tablet_rotation=$(xsetwacom get "$WACOM_STYLUS" Rotate)
> [[ -f ~/.calibrate.$tablet_rotation ]] && \
> source ~/.calibrate.$tablet_rotation
>
> on startup, and every time the screen is rotated.

The previous calibrate script broke with an upgrade to
xserver-xorg-input-wacom 0.10.3+20100109-1. Here's a modified version
that works. Some changes:

    1. Calibration parameters are now saved to ~/.calibrate.X where X is
       the output of "xsetwacom get stylus Rotate". In old versions this
       used to be a number between 1 & 4. In new versions it seems to be
       one of NONE, CW, CCW, HALF.

    2. Resetting calibration broke with the upgrade. This is because the
       script used "xsetwacom getdefault" to find the tablet width /
       height. Looks like getdefault is not supported with the latest
       version of xsetwacom. Instead, I use the xyDefault property to
       reset parameters, and find the tablet width/height.

GI

--
100 THINGS I'D DO IF I EVER BECAME AN EVIL OVERLORD
69. All midwives will be banned from the realm. All babies will be
delivered at state-approved hospitals. Orphans will be placed in
foster-homes, not abandoned in the woods to be raised by creatures of
the wild.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.