Debian GNU/Linux

unixcw sends incorrect characters

Reported by N7DR on 2010-01-23
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unixcw (Debian)
Fix Committed
Unknown
unixcw (Ubuntu)
Undecided
Iulian Udrea

Bug Description

Binary package hint: unixcw

The unixcw program sends incorrect characters at the default speed (12 wpm).

Starting the program simply with the command "cw" (i.e., with no parameters), the program generates CW sounds, but the sounds do not match the characters typed on the keyboard, and in fact mostly do not match *any* letter or number.

For example, typing "T" generates a sound that sounds rather like an "R". Typing "h" creates a kind of "N" with a very long dash.

ProblemType: Bug
Architecture: amd64
Date: Sat Jan 23 12:48:29 2010
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: fglrx
Package: unixcw 2.3-11
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-18.55-generic
SourcePackage: unixcw
Uname: Linux 2.6.31-18-generic x86_64

N7DR (doc-evans) wrote :
Changed in unixcw (Ubuntu):
assignee: nobody → Kamal Mostafa (kamalmostafa)
status: New → Confirmed
Changed in unixcw (Ubuntu):
status: Confirmed → In Progress
Kamal Mostafa (kamalmostafa) wrote :

This bug in 'cwlib' is caused by the invalid use of a mixer ioctl on the soundcard audio device. For most audio devices, the invalid ioctl is harmless, but for some audio devices it prevents cwlib from properly switching the volume on and off (which is how it generates Morse code).

I have fixed the bug in the attached branch, and created PPA update packages for Karmic and Lucid, available here:

    https://launchpad.net/~kamalmostafa/+archive/unixcw-fixes

(Note also LP: #513942 and LP: #513957 -- audio devices affected by this bug are likely to be affected by those as well).

Changed in unixcw (Ubuntu):
assignee: Kamal Mostafa (kamalmostafa) → nobody
status: In Progress → Confirmed
Changed in unixcw (Debian):
status: Unknown → New
Iulian Udrea (iulian) on 2010-01-31
Changed in unixcw (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Iulian Udrea (iulian)
Iulian Udrea (iulian) on 2010-01-31
Changed in unixcw (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unixcw - 2.3-13ubuntu1

---------------
unixcw (2.3-13ubuntu1) lucid; urgency=low

  * Fix invalid ioctl which breaks CW output on some devices (LP: #511676).
    - src/cwlib/cwlib.c: do not try to use mixer volume ioctl on audio device.
  * Restore audio device volume on exit (LP: #513576)
    - src/cw/cw.c, src/cwcp/cwcp.c: call cw_complete_reset() at exit.
 -- Kamal Mostafa <email address hidden> Wed, 27 Jan 2010 19:40:14 -0800

Changed in unixcw (Ubuntu):
status: Fix Committed → Fix Released
Changed in unixcw (Debian):
status: New → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.