Repeated subscription request from same user

Bug #480605 reported by Tom Haddon on 2009-11-11
256
This bug affects 48 people
Affects Status Importance Assigned to Milestone
Empathy
Invalid
Undecided
Unassigned
Telepathy Haze
Confirmed
High
telepathy-haze (Debian)
Confirmed
Unknown
telepathy-haze (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: empathy

Every time I startup empathy, or my Internet connection is restarted I get a "subscription request" from a user. I say "No" but again, every time I reconnect I get the same request.

ProblemType: Bug
Architecture: i386
Date: Wed Nov 11 10:21:28 2009
DistroRelease: Ubuntu 9.10
Package: empathy 2.28.1.1-0ubuntu1
ProcEnviron:
 LANGUAGE=en_GB.UTF-8
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: empathy
Uname: Linux 2.6.31-14-generic i686

Tom Haddon (mthaddon) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in empathy (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Guillaume Desmottes (cassidy) wrote :

Using which kind of account do you receive this message (Jabber, MSN,...) ?

On Mon, 2009-12-21 at 15:49 +0000, Guillaume Desmottes wrote:
> Using which kind of account do you receive this message (Jabber,
> MSN,...) ?

This is from a Yahoo account.

Thanks for sending this upstream.

Changed in empathy (Ubuntu):
status: New → Triaged
Omer Akram (om26er) wrote :

Is this still an issue for any one?

Changed in empathy (Ubuntu):
status: Triaged → Incomplete
Rob Candee (rob-candee) wrote :

This is no longer an issue for me; I am using Empathy 2.29.93.

Thanks,

Rob Candee

Omer Akram (om26er) wrote :

Marking this bug fixed as per last comment

Changed in empathy (Ubuntu):
status: Incomplete → Fix Released
bhagwad (bhagwad) wrote :

I'm still affected by this bug. My empathy version is 2.30.0.1 :(

cyphermaster (bernard-brandl) wrote :

Always the same bug too. My version is 2.30.01.

Omer Akram (om26er) wrote :

Those who are affected can they please confirm if it only happens with yahoo?

Changed in empathy (Ubuntu):
status: Fix Released → Incomplete
bhagwad (bhagwad) wrote :

Till now it's only happening with Yahoo! contacts for me. Is it significant? I think Yahoo has always had more spam than other networks...

My test case.
My friend is ubuntu windows yahoo client he adds me as his contact I cancel his request. I quit empathy and stat it again and I get the request from my friend to add me. Then again I quit it and start it again the same problem. But now if my friend goes offline then I wont get any request. Another test case that is still to check is that what if the next time he comes online I might again be given a subscription request :(

Omer Akram (om26er) wrote :

Talked to cassidy and according to him its a tp-haze bug so I have opened a telepathy haze bug report.

Changed in empathy:
importance: Unknown → Undecided
status: Unknown → New
status: New → Invalid
affects: empathy (Ubuntu) → telepathy-haze (Ubuntu)
Changed in telepathy-haze (Ubuntu):
status: Incomplete → Triaged

*** Bug 27984 has been marked as a duplicate of this bug. ***

bhagwad (bhagwad) wrote :

Any update on this issue?

as a workaround, until the bug is sorted, it's worthwhile remembering that yahoo's webmessenger interface is accessible from many browsers - possible to report spammers too :-)

Omer Akram (om26er) on 2010-06-16
Changed in telepathy-haze (Ubuntu):
importance: Low → Medium
Stephen Gornick (sgornick) wrote :

FYI, until this is resolved, those with this issue have a couple of methods for working around the bug, as described here:
  http://ubuntuforums.org/showthread.php?t=1509005

Karsten W. Rohrbach (byteborg) wrote :

Quoting from my comment in #594436, this might have some significant security impact.

Users tend to accept contact requests from unstrusted third parties which might lead unwanted diclosure of private information.

Workaround: login here and deny with option to block and report as spam: http://webmessenger.yahoo.com/

bhagwad (bhagwad) wrote :

Thanks for the workaround.

sam tygier (samtygier) wrote :

still an issue in 2.31.3 in maverick

Created an attachment (id=37179)
Decline Subscription Workaround

I originally posted this bug here:https://bugzilla.gnome.org/show_bug.cgi?id=624478

The code seems to be based on weather or not the status of the requesting party is visible in the request dialog.

If the status is not visible the request will be shown again at the next service restart.

To get the status of the requester visible, select one of your groups. After the status is visible it doesn't appear to matter weather a group is selected or not. When you decline the request in this state with the requesters on-line status visible the decline request works correctly.

noah (nmfralich) wrote :

I also (and primarily) have this issue with ICQ. Though I don't know if it's a bug per se, it should be an option for spam requests.

I get this issue with Yahoo, though I am not getting requests through any other services so I don't know if it is Yahoo only. The same thing is happening on my Nokia N900 running empathy on Maemo. No matter how many times I reject the request, it keeps popping up on both platforms until I log into Yahoo messenger (as in comment #18) and reject the request. I don't think the requester is spamming me (i.e. I know they are spamming in that they are strangers who want to sell me porn and vitamin supplements, but I don't think they are repeatedly requesting over and over); I think that the single request is simply not rejected properly from the empathy client.

I am running Lucid, with empathy version 2.30.2.

Samic (i-samic) wrote :

I have the same problem!!
please help and upgrade this ... program!!
please add a block feature

Philip Kahn (tigerhawkvok) wrote :

Verified -- affects my box, too. (Ubuntu 10.04 NBR)

Changed in telepathy-haze:
importance: Unknown → High
status: Unknown → Confirmed
MaskedDriver (maskeddriver) wrote :

Verified -- Ubuntu 10.10 amd64 Desktop; Empathy 2.32.0
Only affects Yahoo! Instant Messenger connections.
Quite an annoying bug, though the web-client login deny/block/spam workaround is effective.

(In reply to comment #4)
> To get the status of the requester visible, select one of your groups. After
> the status is visible it doesn't appear to matter weather a group is selected
> or not. When you decline the request in this state with the requesters on-line
> status visible the decline request works correctly.

By "select one of your groups", do you mean "add the contact to a group" as the screenshot suggests?

If that's the case, then I think this is a bug in the Yahoo prpl, but it might be possible to work around it in telepathy-haze by implementing "decline the request" by adding the contact to some dummy group, declining the request, and deleting the contact. (Ugh. But if it works...)

There's a thread on the mailing list about why this happens: http://lists.freedesktop.org/archives/telepathy/2010-October/004965.html

daqron (daqron) wrote :

Another verification. Ubuntu 10.04 64-bit. Empathy 2.30.2. Only Yahoo, so far, and successfully worked-around via web messenger suggestion provided above.

This seems to reflect the broader issue of Empathy lacking any capacity to block unwanted/spam contacts, a bug that has been known for several years now and remains unfixed (https://bugzilla.gnome.org/show_bug.cgi). It stands to reason that a "block list" or proper integration with the blocking features that all IM services provide, such as is present in Pidgin and other clients, would likely render this issue moot.

Cheers,
Jeremy

Omer Akram (om26er) on 2010-11-13
Changed in telepathy-haze (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Changed in telepathy-haze (Debian):
status: Unknown → Confirmed
RDD (rdd37misc) wrote :

+1 verification on Ubuntu 10.04, 64-bit - Empathy 2.30.2. Only observed with Yahoo account.

Renato Miceli (renatomiceli) wrote :

Same happens here, only on my Yahoo! account.
Spec: Empathy 2.32.0.1 on Ubuntu 10.10 64-bit.

Ryan Sinn (ryan-sinn) wrote :

Still happens ... Empathy 2.32.1 on Ubuntu 10.10 64-bit

I have the opposite problem in 2.30.3 (Ubuntu 10.4 LTS) I a contact that I would like to accept. But everytime I log in it ask me for confirmation again.

Confirmed here as well.
Arch Linux (x86_64)
empathy 2.32.2
telepathy-haze 0.4.0-1

Have perma-blocked through web interface as suggested (thank you), will not be able to confirm again unless I get added by yet *another* blasted yahoo bot.

Shane H (shane.h) wrote :

I am having the same problem still on:

Empathy 2.32.1 for Ubuntu 10.10 64-bit AMD.

Yahoo workaround does the job though! :D

Changed in telepathy-haze:
importance: High → Unknown
Changed in telepathy-haze:
importance: Unknown → High
Nate Moore (putermd) wrote :

This bug affects me as well.
The behavior is not exhibited in other tools that are based on the purple series of libraries.

Itpro (itpro1667) wrote :

This bug is affecting me too. Ubuntu 10.04 32-bit AMD.

I can't even get the workaround to work :( has yahoo changed something that doesn't allow this to work anymore?

Itpro (itpro1667) wrote :

my mistake, i was able to get workaround to work. I hope a more permanent fix is worked out soon, thanks for all the hard work to everyone who makes this open software world work :)

ElQanah Gutiérrez (elqanah) wrote :

Still an issue for me, always has been. Using Ubuntu 11.04 with empathy 2.34.0 It's only happening in the yahoo account.

Same problem here with Ubuntu 11.04 and Empathy 2.34.0. Seems to occur only with my Yahoo! account.

Mihai Capotă (mihaic) wrote :

Still happening in Ubuntu 12.04.

Ulisse (ulipo) wrote :

I can confirm it still happens on Ubuntu 12.04 with Empathy 3.4.1

I can confirm it still happens on Ubuntu 12.04 with Empathy 3.4.1
reffering the downstream 2 omments 43 and 46

Luke O'Connell (luke-us) wrote :

Still happening on 12.04 with 3.4.2

TQ (tjgq) wrote :

This happens to me on 12.10, Empathy version 3.6.0.3.

In my case it's not a Yahoo account, but a Windows Live one. Subscription requests seem to always come from different addresses, but it's difficult to be sure since they are cryptic. I'm getting a few requests per hour on average.

There should be a way to block this, because it completely defeats the purpose of the messaging menu. I keep opening it when it flashes blue, because I'm never sure if it's something important, or just another annoying contact request.

Edwin Lee (leeed2001) wrote :

Same for me on 12.10...persistent requests!! Perhaps this person just realllllly wants to talk to me :-D.

Dakota Schneider (dakota-5) wrote :

Still an issue here, latest normal release of Empathy on Ubuntu 12.10 32-bit, have to decline requists to chat from spammers every time I log in, from the same accounts. For example, I had to block user "antoginizingalma " on Yahoo! IM untold numbers of times.

Interestingly, I've recently started having problems with the Launcher badges for Empathy not updating, so it always shows "5" even when I've quit Empahy or read all messages.

Majal (majalmirasol) wrote :

It's 2014 and still the same issue here. :-) Ubuntu 12.04.4, Empathy 3.4.2.3, and not Yahoo for me, but GOOGLE chat! So, after five (5) years, any fix yet? Hmmm...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.