Debian GNU/Linux

syslinux should depend on mtools

Reported by Marco Trevisan (Treviño) on 2006-12-14
28
Affects Status Importance Assigned to Milestone
syslinux (Debian)
Fix Released
Unknown
syslinux (Ubuntu)
Wishlist
Martin Pitt

Bug Description

Running syslinux I have this output:

 syslinux -s /dev/sda1
 sh: mcopy: command not found

Installing mtools fixed it ;)

Related branches

Jonh Wendell (wendell) wrote :

Hi. If you install it from aptitude, it automatically installs mtools, which is a recommended package.

You can tell to synaptic to do this, like aptitude:
Go to menu Settings->Preferences, mark 'Consider recommended packages as dependencies'.

Changed in syslinux:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
noisymime (josh-noisymime) wrote :

I agree that mtools should be listed as a dependency rather than simply recommended. The mcopy program will be required by syslinux in 99% of cases and therefore should be a depends.

Jonh, this option is not turned on by default so hence in most cases syslinux will fail to operate after installing. This cannot be a desirable outcome? Additionally, most people would surely be installing this with apt-get and rather than aptitude and hence the problem is there for them too.

Changed in syslinux:
status: Unknown → Unconfirmed
Dan Lenski (lenski) wrote :

The mtools dependence of syslinux is kind of silly ... Since only root can mount filesystems, but mtools can operate on any msdos filesystem with the appropriate permissions, the author decided to simply use mtools to copy the bootloader (LDLINUX.SYS) onto the disk.

The latest version of syslinux, 3.35, can be built so as not to depend on mtools... in this version, the msdos filesystem is mounted in the usual manner and then the bootloader is copied on the usual Linux way.

Version 3.35 also makes syslinux more like isolinux in that the configuration files can be in a subdirectory. Hopefully there will be a 3.35 package for Ubuntu soon!!

Clive Darra (osde8info) wrote :

why is this only on the wishlist ? this is a bug !

i am trying to use edubuntu 6.06 to create bootable USB sticks ! how am i to know mcopy is part of mtools !

Paul Weaver (iso-isorox) wrote :

Just been hit by this myself with ubuntu 6.10 desktop. The first thing I tried was apt-get install mcopy, which didn't work, I then looked on google and found this page.

The two ways forward I can see are
1) Change syslinux to not use mcopy
2) Make mtools a *dependency* of syslinux

I have no idea how to do either, but I agree that I consider this a bug.

Gregg (gclaeys) wrote :

I can only agree with the others,...

As long as the syslinux in the repository *NEED* mtools, it should be a dependency.

It is no big deal for people who know how to look around. But for the others...

Changed in syslinux:
assignee: nobody → mrcheatr
status: Confirmed → In Progress
Nathan Handler (nhandler) wrote :

This patch changes mtools from being a recommended package to being a dependency.

Changed in syslinux:
assignee: mrcheatr → nobody
status: In Progress → Confirmed
Emmet Hikory (persia) wrote :

I've unsubscribed ubuntu-universe-sponsors, as syslinux is in main. To request a sponsored upload in main, please subscribe ubuntu-main-sponsors. Thank you.

Daniel Holbach (dholbach) wrote :

Martin: can you take a look at that?

Changed in syslinux:
assignee: nobody → pitti
Martin Pitt (pitti) wrote :

Uploaded, thank you!

Changed in syslinux:
status: Confirmed → Fix Committed
Nathan Handler (nhandler) wrote :

syslinux (1:3.36-4ubuntu2) gutsy; urgency=low

  * mtools changed from recommended package to dependency (LP: #75765)

 -- Nathan Handler <email address hidden> Fri, 20 Jul 2007 15:37:24 +0200

Changed in syslinux:
status: Fix Committed → Fix Released
Changed in syslinux:
status: New → Fix Released
Ky6uk (ky6uk) wrote :

Ubuntu 9.10. Bug is affected me.

Changed in syslinux (Ubuntu):
status: Fix Released → Incomplete
Martin Pitt (pitti) wrote :

sysutils still recommends mtools, so all is fine.

Changed in syslinux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.