Debian GNU/Linux

Comment 112 for bug 423252

According to Andreas Metzler
http://lists.debian.org/debian-legal/2011/02/msg00006.html
{{ GnuTLS upstream has added support for different crypto backends in
2.11.x and has chosen nettle as prefered backend (2.10.x is using
libgcrypt). }}

I have started to experiment with using a gnutls26 package with nettle
instead of libgcrypt11 on Ubuntu 12.04.

I have yet to adjust the gnutls26 package dependencies, at this point
I just cheat and install nettle-dev manually:

sudo apt-get install nettle-dev

Then I

apt-get source gnutls26

to fetch the source for gnutls26-2.12.14

chop out
--with-libgcrypt
from debian/rules

bump the package version in debian/changelog to 2.12.14-5ubuntu2.1

and rebuild with

debuild -i -uc -us -b

then I put a checkpoint on the VM and install the package:

dpkg -i libgnutls26_2.12.14-5ubuntu2.1_amd64.deb

but then sudo works on my LDAP+SSL client.