Cannot read cd: sound-juicer and gvfs problem (workaround included)

Bug #627008 reported by mokabar on 2010-08-30
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Sound Juicer
sound-juicer (Debian)
sound-juicer (Fedora)
Won't Fix
sound-juicer (Ubuntu)

Bug Description

Binary package hint: sound-juicer

on maverick, sound-juicer 2.31.6 displays this dialog, when trying to rip a cd:

Could not read the CD

Sound Juicer could not read the track listing on this CD.
Reason: Cannot access CD: The specified location is not mounted

k3b could rip the cd without a problem

I also have this problem after upgrading from 10.04 to 10.10 on x86_64 (it worked fine in 10.04 with every disc I had used then). Using K3B works. The CD which caused trouble for me is Dionysus' "Keep the Spirit" - which is a mixed-mode audio/data CD. When I tried inserting another mixed-mode CD it worked. These are the only two discs I've tried using since the upgrade, and I don't particularly feel like trying every CD to see if it works or not. I don't know off-hand anything that would make the Dionysus disc different, other than I believe it has CD-TEXT on it. Kaffeine is able to play the CD, KsCD crashes with "CDROMREADRAW: Bad file descriptor" - maybe it's not just a sound-juicer problem. Using Totem I can play the WAV files that the file browser depicts being on the CD, and I can use Rhythmbox to play it as well.

djfake (djfake) wrote :

I have this problem as well; Since upgrading to Ubuntu 10.10, Sound Juicer 2.31.6 doesn't retrieve track listings for most CDs. Rhythmbox does however correctly report track listing. Any ideas?

Tommy_CZ (t-kijas) wrote :

I have this problem too, Ubuntu 10.10, using gstreamer as default phonon, no matters what audio CD, juicer cannot read it, K3B can. (But I want to use juicer because K3B doesn't support ripping to aac).

I think one can mark this as confirmed...

Tong Sun (suntong001) wrote :

I have this problem too, Ubuntu maverick 10.10, on x86_64, tested on both my CD and DVD.
all other cd rippers work well on my CD and DVD drive.

Can't believe that "Sound Juicer is Ubuntu's default CD-ripping application" ( and yet it doesn't work. sigh...

Dave Gilbert (ubuntu-treblig) wrote :

Hmm, sound-juicer has worked fine for me on Maverick and Natty; but it's now broken in the same way as being reported here on Oneiric. goobox seems happy with it; the dmesg seems to contain:

[30939.576045] sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[30939.576071] sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current]
[30939.576097] sr 1:0:0:0: [sr0] Add. Sense: Illegal mode for this track
[30939.576121] sr 1:0:0:0: [sr0] CDB: Read(10): 28 00 00 00 00 10 00 00 02 00
[30939.576245] end_request: I/O error, dev sr0, sector 64

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sound-juicer (Ubuntu):
status: New → Confirmed
Matthew Caron (matt-mattcaron) wrote :

I have this problem is Oneiric as well. The surprising thing is that when you run it with --brasero-media-debug, brasero reports seeing the tracks on the disc, etc. However, it still doesn't work.

Matthew Caron (matt-mattcaron) wrote :

This has something to do with gvfs. I've tracked the specific failure to the following call:

  info = g_file_query_info (file, "xattr::*",
         G_FILE_QUERY_INFO_NONE, NULL, &my_error);

in the source code. info comes back as NULL, and the error message is "The specified location is not mounted".

I should note that I'm running thus under XFce. I'll try it under GNOME and see if that makes a difference.

However, I do note that gvfs is running under XFce.

Matthew Caron (matt-mattcaron) wrote :

Nope, neither Unity nor Gnome3 had any difference - this looks to be broken across the board.

Matthew Caron (matt-mattcaron) wrote :

Workaround - if I manually do:

gvfs-mount cdda://sr0

It seems to work just fine.

Eloy Paris (peloy-chapus) wrote :

It's unfortunate that this problem with what seems to be Ubuntu's default CD ripping application has existed since 10.10. Fortunately, after reading I found out about the very awesome abcde CD ripping solution. Using that now and as long as it is maintained (it seems to be well maintained as of November 2011) I don't think I'll have a need for other CD ripping software.

Matthew Caron's gfvs-mount workaround does not work for me on a machine running 10.10, by the way.

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 902573 , so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Evan Carroll (evancarroll) wrote :

This bug is certainly not a dupe of #797473. This bug affects me, and you can test if you're vulnerable to this flaw by trying

$ gvfs-mount cdda://sr0

per Matthew Caron (matt-mattcaron) on 2011-11-19. #797473 has to MusicBrainz and multi-cd albums.

summary: - cannot read cd
+ Cannot read cd: sound-juicer and gvfs problem (workaround included)
tags: added: gvfs
Changed in sound-juicer:
importance: Unknown → Medium
status: Unknown → New
Avery (avery) wrote :

I have the same-error from sound-juicer. It only occurs in the past month or two, and only on certain CDs. Other CDs work fine. I found ABCDE as an alternative ripper and it also works fine.

I have the same error from sound-juicer on 11.10. Using the workaround ($ gvfs-mount cdda://sr0) resulted in a new error:

Could not read the CD:
Sound Juicer could not read the track listing on this CD.
Reason: Cannot access CD: Error while getting peer-to-peer dbus connection: The name :1.656 was not provided by any .service files

I'm seeing the same problem on about 1 in 4 CDs on Xubuntu 12.04. I don't think this is a Sound Juicer problem, though: the disc lso doesn't appear in Rhythmbox, and it's a repeatable thing for a given CD. However I just discovered (after some weeks of frustration -- d'oh) that double clicking the audio CD icon on the desktop will mount it, and shows the tracks as wav files: maybe this implies something about problems with some particular form of CD filesystem?

My suggestion in #16 worked for one CD, but now I'm getting the same "peer-to-peer dbus connection" / .service file error message as in comment #15 :/

Matthew Caron (matt-mattcaron) wrote :

This looks to be fixed in precise (sound-juicer 3.4.0). I've currently ripped half a dozen CD's with proper change notification happening on each.

prohacx (prohacx) wrote :

Same issue here, Xubuntu 12.04. I found this to work when I run into this issue opening soundjuicer: go to your desktop, right click on the CD icon and select "mount device". Then in Soundjuicer you can go to file - re-read disc to get the disc contents and rip it.

prohacx (prohacx) wrote :

on my comment above: you may have to close and reopen soundjuicer before you will see the CD listing

Daniel Barrett (dbarrett-m) wrote :

The solution from comment #10 worked for me in 13.10.

$ gvfs-mount cdda://sr0

I ran it while the CD was in the drive and sound-juicer was not running. Then I ran sound-juicer and it found the disc.

Changed in sound-juicer:
status: New → Invalid
D Mays (dmays) wrote :

I am experiencing this on Xubuntu 14.04. The gvfs-mount workaround did not change the behavior.

James Dunmore (james-dunmore) wrote :

gvfs-mount cdda://sr0 worked for me on xubuntu 14.04


Changed in sound-juicer (Debian):
status: Unknown → New
Ariella (ariella) wrote :

Confirmed that you have to manually mount an audio CD after insertion (double click it on desktop) before Sound Juicer will be able to see it. It expects media to already be mounted. Xubuntu 14.10. I wonder if there's a pref somewhere to automount optical media.

gvfs-mount cdda://sr0

worked for me too in Xubuntu 15.04

Changing because Bug #606523 was marked as duplicate of #602855 .

Changed in sound-juicer:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in sound-juicer:
importance: Unknown → Medium
status: Unknown → Confirmed

The workaround 'gvfs-mount cdda://sr0' worked for me too (on Debian jessie with Xfce). But first I had to install the package 'gvfs-backends' in order to make the workaround work.

Changed in sound-juicer (Fedora):
importance: Unknown → High
status: Unknown → Won't Fix
Damian Yerrick (tepples) wrote :

As of 18.04, the command that works for me is
gio mount cdda://sr0

Scott (ubuntuser1) wrote :

I might have also encountered this bug in lubuntu 18.10 i386; see for a description of the error:

    Could not read the CD

    Sound Juicer could not read the track listing on this CD. Reason: Cannot access CD: The name :1.36 was not provided by any .service files

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.