Setserial's autosave doesn't work

Bug #46994 reported by fubarbundy on 2006-05-27
6
Affects Status Importance Assigned to Milestone
setserial (Debian)
Fix Released
Unknown
setserial (Ubuntu)
Medium
Unassigned

Bug Description

To reproduce: run dpkg-reconfigure setserial and change it to autosave once or autosave always. Run setserial /dev/ttyS0 to show the current state of your serial port (change device node as appropriate). This should usually show its UART status as 16550A. Now run setserial /dev/ttyS0 uart none and reboot.

Result: setserial /dev/ttyS0 still shows uart 16550A

Expected result: setserial /dev/ttyS0 should show uart none as it has been configured to always autosave the last configuration of the serial port and restore it on startup.

fubarbundy (launchpad-mailtic) wrote :

To reproduce: run dpkg-reconfigure setserial and change it to autosave once or autosave always. Run setserial /dev/ttyS0 to show the current state of your serial port (change device node as appropriate). This should usually show its UART status as 16550A. Now run setserial /dev/ttyS0 uart none and reboot.

Result: setserial /dev/ttyS0 still shows uart 16550A

Expected result: setserial /dev/ttyS0 should show uart none as it has been configured to always autosave the last configuration of the serial port and restore it on startup.

fubarbundy (launchpad-mailtic) wrote :

This has been untouched in Debian since June last year!

Andrew Frank (frank-geoinfo) wrote :

i encountered the problem - in ubuntu 6.10 - still not fixed.

Basilio Kublik (sourcercito) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Thanks in advance.

Changed in setserial:
status: New → Incomplete
Changed in setserial:
assignee: nobody → craig-decafbad

Hello,

I'm currently tracking a bug in Ubuntu on the Ubuntu Launchpad. It seems
setserial is not currently affecting any of the serial ports on the
machine. Is this bug going to be addressed in the future, or is there a
more preferred method for changing the settings for serial ports?

Thanks!
--
-------------------------------------------------------------------
  Craig Maloney (<email address hidden>) http://decafbad.net
    Work Hard. Rock Hard. Eat Hard. Sleep Hard. Grow Big.
    Wear Glasses If You Need 'Em. -- The Webb Wilder Credo

Craig Maloney (craig-decafbad) wrote :

Sent a note to Debian upstream to see if setserial is even a supported method for setting serial ports.

Craig Maloney (craig-decafbad) wrote :

Forgot to mark this as confirmed.

Changed in setserial:
status: Incomplete → Confirmed
Changed in setserial:
assignee: craig-decafbad → nobody

Thank you for posting this bug.

Is this an issue in Maverick?

Changed in setserial (Ubuntu):
status: Confirmed → Incomplete
Clint Byrum (clint-fewbar) wrote :

No response for almost 18 months. Closing as Invalid.

Changed in setserial (Ubuntu):
status: Incomplete → Invalid
Changed in setserial (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.