Debian GNU/Linux

Failed to execute child process "su-to-root" (No such file or directory)

Reported by William Woelke on 2008-08-21
10
Affects Status Importance Assigned to Milestone
sbackup (Debian)
New
Unknown
sbackup (Ubuntu)
Medium
Scott Kitterman

Bug Description

When attempting to run "Simple Backup Restore" (sbackup), I receive the following error:

Failed to execute child process "su-to-root" (No such file or directory)

I am running Intrepid Ibex (x86) with the latest updates.

Related branches

Thanks for reporting the bug.
As a workaround: The program "su-to-root" is in the package "menu", so installing it via the package manager or with "sudo apt-get install menu" should fix the issue.

The problem is that the package sbackup does not depend on menu, although it should.

Changed in sbackup:
status: Unknown → New

This trivial patch should fix the issue

Changed in sbackup:
assignee: nobody → kitterman
importance: Undecided → Medium
status: Confirmed → In Progress
Scott Kitterman (kitterman) wrote :

Uploaded. Thank you. It may still make Intrepid. Ack from motu-release.

Changed in sbackup:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sbackup - 0.10.5ubuntu2

---------------
sbackup (0.10.5ubuntu2) intrepid; urgency=low

  * Replace depends on gksu and sudo with menu for su-to-root (LP: #260203)
    - Thanks to Marcel Stimberg for the fix

 -- Scott Kitterman <email address hidden> Sat, 25 Oct 2008 23:58:15 -0400

Changed in sbackup:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.