please build bindings for Python3

Bug #1440381 reported by Matthias Klose on 2015-04-04
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ldb (Ubuntu)
Critical
Andreas Hasenack
samba (Debian)
New
Unknown
samba (Ubuntu)
Critical
Andreas Hasenack
talloc (Ubuntu)
Critical
Andreas Hasenack
tdb (Ubuntu)
Critical
Unassigned

Bug Description

There is still the goal to remove Python2 from the desktop images, and to use Python3 only. please build bindings for Python3

Related branches

CVE References

Changed in samba (Debian):
status: Unknown → New
Jelmer Vernooij (jelmer) on 2015-04-30
Changed in samba (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
flux242 (flux242) wrote :

as it is stated in the http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=781913 it would be enough to move the libsamba-net out of the samba-libs into a separate package libsamba-net. Then samba-libs would not dependent on python at all. In turn gvfs-backends would be free of python too which would make it possible to have python2 free desktop starting with the 16.04 lts.
The dependency to that new libsamba-net package should be added in the samba package.

Scott Palmer (skewty) wrote :

It's been over 6 months and two 16.04 releases have come and gone.. Has there been any progress on this? Does the status just need to be updated? Thanks for all the effort that is going into making Python3 a priority and 1st class citizen in Ubuntu. We switched from RHEL to Ubuntu Server because of this goal.

Matthias Klose (doko) on 2017-11-30
tags: added: py2-demotion py2-removal
Dimitri John Ledkov (xnox) wrote :

Hm python3-ldb used to be there in xenial, but not anymore? What has happened to that?

Changed in ldb (Ubuntu):
importance: Undecided → Critical
milestone: none → ubuntu-18.10
Changed in samba (Ubuntu):
importance: Wishlist → Critical
milestone: none → ubuntu-18.10
Changed in talloc (Ubuntu):
importance: Undecided → Critical
milestone: none → ubuntu-18.10
Changed in tdb (Ubuntu):
importance: Undecided → Critical
milestone: none → ubuntu-18.10
status: New → Fix Released
Jelmer Vernooij (jelmer) wrote :

python3-ldb appears to have come from an ubuntu-specific patch that got dropped at some point.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ldb (Ubuntu):
status: New → Confirmed
Changed in talloc (Ubuntu):
status: New → Confirmed
Matthias Klose (doko) wrote :

samba 4.10 (currently a release candidate) has the Python3 support

tags: added: rls-dd-incoming
Changed in ldb (Ubuntu):
assignee: nobody → Andreas Hasenack (ahasenack)
Changed in samba (Ubuntu):
assignee: nobody → Andreas Hasenack (ahasenack)
Changed in talloc (Ubuntu):
assignee: nobody → Andreas Hasenack (ahasenack)
Changed in tdb (Ubuntu):
assignee: nobody → Andreas Hasenack (ahasenack)
assignee: Andreas Hasenack (ahasenack) → nobody
Changed in talloc (Ubuntu):
status: Confirmed → In Progress
Changed in samba (Ubuntu):
status: Triaged → In Progress
Changed in ldb (Ubuntu):
status: Confirmed → In Progress
Andreas Hasenack (ahasenack) wrote :

FFe bug for samba and its dependencies: https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1818518

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package talloc - 2.1.16-0ubuntu1

---------------
talloc (2.1.16-0ubuntu1) disco; urgency=medium

  * New upstream version: 2.1.16 (LP: #1818522):
    - d/rules: cleanup more directories and pyc files waf is leaving behind
    - d/rules: fix globbing for talloc static library creation
    - d/libtalloc2.symbols: updated symbols for 2.1.16
    - d/control, d/rules, d/python3-talloc{,-dev}.install: new python3 packages
      (LP: #1440381)
    - d/s/lintian-overrides: change old PY2 variable override to the PY3
      one we are using.
    - d/python3-talloc.symbols.{common,amd64,armhf,arm64,s390x,ppc64el,
      i386}: use per-arch symbols file
    - d/rules: check python3-talloc symbols
    - d/rules: remove change to keep python2 from desktop images, no longer
      needed
    - d/control, d/python-talloc*, d/rules: remove python2 packages

 -- Andreas Hasenack <email address hidden> Sat, 09 Mar 2019 16:40:52 +0000

Changed in talloc (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ldb - 2:1.5.4-0ubuntu1

---------------
ldb (2:1.5.4-0ubuntu1) disco; urgency=medium

  * New upstream version: 1.5.4 (LP: #1818525):
    - d/libldb1.symbols: update for this version
    - d/p/00_Enable-make-test-even-without-lmdb.patch: refreshed
    - Removed patches, applied upstream:
      + d/p/03_EBADE
      + d/p/CVE-2019-3824-*.patch
    - d/control: bump build-deps:
      + require talloc >= 2.1.16
      + require tdb >= 1.3.18
      + require tevent >= 0.9.39
    - d/libldb1.install: added libldb-tdb-{err-map,int}.so
  * d/rules: use Makefile targets instead of direct WAF calls
  * Add python3 packages (LP: #1440381):
    - d/control: add python3 packages
    - d/rules: clean extra paths in the clean target
    - d/python3-ldb*.install: install files for the new python3 packages.
    - d/control, d/python3-ldb-dev.install, d/rules: use dh-exec and
      install the python header file in a version-dependent include dir.
    - d/python3-ldb.symbols.*: add per-architecture symbols files
    - d/rules: dh_makeshlibs for python3-ldb
    - d/rules: exclude "ldb." from symbols check/generation, as to match
      the python3 extension name.
    - d/rules: fix tevent globbing used in its removal
  * d/control, d/python-ldb*, d/rules: drop python2 packages and support

 -- Andreas Hasenack <email address hidden> Fri, 08 Mar 2019 16:41:11 +0000

Changed in ldb (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package samba - 2:4.10.0~rc4+dfsg-0ubuntu1

---------------
samba (2:4.10.0~rc4+dfsg-0ubuntu1) disco; urgency=medium

  * New upstream version 4.10.0rc4 (LP: #1818518):
    - Removed patches already applied upstream:
      + d/p/nsswitch-Add-try_authtok-option-to-pam_winbind.patch
      + d/p/s3-auth-ignore-create_builtin_guests-failing-without.patch
    - d/p/add-so-version-to-private-libraries: refreshed to remove fuzz
    - d/control: Updated build dependencies:
      + tdb >= 1.3.17
      + talloc >= 2.1.15
      + tevent >= 0.9.38
      + ldb >= 1.5.3
    - d/samba-common.docs: README is now README.md
    - d/libsmbclient.symbols: update symbols for this version
    - d/libwbclient0.symbols: update symbols for this version
    - d/ctdb.install: new binary ctdb_local_daemons
    - d/samba-dev.install: use globbing for the header files with
      exceptions for wbclient.h and libsmbclient.h, which belong in
     other packages.
    - d/rules: fix globbing used to move the dckeytab python module to the
      samba package, and add a comment explaining why this is being done.
  * Switch to python3:
    - d/rules: calculate the ldb version using python3, and drop the
      "really" bit since the real 1.5.x series is being used now.
    - d/rules: make sure python3 is used for the build
    - d/rules: adjust globbing to remove the python3 version of tevent.so
    - d/rules: drop PYVERS, unused
    - d/control: adjust dependencies (build and runtime) for python3
    - d/python3-samba.install, d/control: new python3-samba package
      (LP: #1440381)
    - d/control, d/python-samba.install: get rid of python-samba, which is py2
    - d/python3-samba.lintian-overrides: use the same overrides we had for
      python-samba, now deleted.
    - d/samba-dev.install, d/samba-libs.install: update file list
    - d/t/control, d/t/python-smoke: use python3
    - d/control: use ${python3:Depends} now instead of the python 2
      counterpart for samba and samba-common-bin.
  * d/control: drop suggests for python-gpgme, it's no longer available.

 -- Andreas Hasenack <email address hidden> Sat, 09 Mar 2019 12:45:25 +0000

Changed in samba (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.