pip freeze includes "pkg-resources==0.0.0"

Bug #1635463 reported by Craig R. Wright on 2016-10-21
212
This bug affects 44 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
python-pip (Debian)
New
Unknown
python-pip (Ubuntu)
Medium
Unassigned

Bug Description

First reported against pip at: https://github.com/pypa/pip/issues/4022

According to https://github.com/pypa/pip/issues/4022#issuecomment-254926808:
"this is a bug caused by ubuntu - they should fix it, they lied about metadata"

Pip version:
8.1.2

Python version:
Python 2.7.12

Operating System:
Linux ubuntu 4.4.0-43-generic #63-Ubuntu SMP Wed Oct 12 13:48:03 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Description:

pip freeze, run from a freshly created virtualenv, always includes

pkg-resources==0.0.0

When not extracted from the output when written to requirements.txt, it causes build failures on deployment when creating virtualenvs from that requirements file.

What I've run:

$ pip freeze
ago==0.0.6
bcrypt==2.0.0
beautifulsoup4==4.3.2
blinker==1.3
cffi==1.5.2
ecdsa==0.11
email==6.0.0a1
Flask==0.10.1
flatland==0.8
funcsigs==1.0.2
gunicorn==19.1.0
itsdangerous==0.24
Jinja2==2.8
MarkupSafe==0.23
mock==2.0.0
newrelic==2.4.0.4
nose2==0.6.5
pbr==1.10.0
pika==0.10.0
pkg-resources==0.0.0
pycparser==2.14
PyMySQL==0.7.9
python-dateutil==2.1
pytz==2014.4
redis==2.10.5
requests==2.11.1
six==1.10.0
SQLAlchemy==1.1.2
textile==2.3.3
Werkzeug==0.11.8

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: python-pip 8.1.1-2ubuntu0.2
ProcVersionSignature: Ubuntu 4.4.0-43.63-generic 4.4.21
Uname: Linux 4.4.0-43-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
Date: Thu Oct 20 18:24:27 2016
InstallationDate: Installed on 2016-09-27 (23 days ago)
InstallationMedia: Ubuntu-Server 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: python-pip
UpgradeStatus: No upgrade log present (probably fresh install)

Craig R. Wright (craig-wright) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python-pip (Ubuntu):
status: New → Confirmed
Changed in python-pip (Ubuntu):
importance: Undecided → Medium
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Medium
Edwin Khoo (edwinksl) wrote :

Question on Ask Ubuntu about this bug: http://askubuntu.com/q/854249/15003.

graingert (tagrain) wrote :
graingert (tagrain) on 2017-01-17
Changed in hundredpapercuts:
status: Confirmed → Invalid
status: Invalid → Confirmed
Mark (ms7821) wrote :

Also breaks pipenv https://github.com/pypa/pipenv/issues/1425, and I can't think of a workaround.

Mark (ms7821) wrote :
Changed in python-pip (Debian):
status: Unknown → New

This should be higher priority, as it is breaking a significant number of virtualenvs.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.