perl needs to be multiarch

Bug #1017603 reported by Brian J. Murrell on 2012-06-25
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
perl (Debian)
Confirmed
Unknown
perl (Ubuntu)
Wishlist
Unassigned
Precise
Wishlist
Unassigned
Quantal
Wishlist
Unassigned
Raring
Wishlist
Unassigned
Saucy
Wishlist
Unassigned
Trusty
Wishlist
Unassigned

Bug Description

Perl really is the poster-child package for multiarch (i.e. foreign) support isn't it?

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: perl 5.14.2-6ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Mon Jun 25 13:05:16 2012
PackageArchitecture: i386
ProcEnviron:
 TERM=screen
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: perl
UpgradeStatus: No upgrade log present (probably fresh install)

Colin Watson (cjwatson) wrote :

The Linaro guys have been working on this; I suspect it'll land in 13.04.

Changed in perl (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Colin Watson (cjwatson) wrote :

This is very intrusive and we won't be doing it for 12.10 at this point. I also don't think it's sensible for 12.04 (although some rather less intrusive multiarch SRUs have been going in).

Changed in perl (Ubuntu Quantal):
status: Triaged → Won't Fix
Changed in perl (Ubuntu Precise):
status: New → Won't Fix
importance: Undecided → Wishlist
Colin Watson (cjwatson) wrote :

(But of course 13.04 will be fine if the patches are ready by then.)

Colin Watson (cjwatson) wrote :

Hasn't happened for 13.04 and now too late; bumping to S.

Changed in perl (Ubuntu Raring):
status: Triaged → Won't Fix
Colin Watson (cjwatson) wrote :

This is actually going to happen for 14.04; I've been talking with the Debian Perl maintainers about it. However the work they've been doing on this was on top of Perl 5.18, and that transition was too much to take on for 13.10 (it routinely takes person-weeks of time at least, and only became viable at feature freeze). Sorry this has been delayed several times, but I actually am pretty confident we'll get it this time round!

Changed in perl (Ubuntu Saucy):
status: Triaged → Won't Fix
tags: added: rls-t-notfixing
Vlad Orlov (monsta) wrote :

Didn't happen.

$ sudo aptitude install perl-base:i386
The following NEW packages will be installed:
  perl-base:i386{b}
0 packages upgraded, 1 newly installed, 0 to remove and 300 not upgraded.
Need to get 1133 kB of archives. After unpacking 4895 kB will be used.
The following packages have unmet dependencies:
 perl-base : Conflicts: perl-base:i386 but 5.18.2-2ubuntu1 is to be installed.
 perl-base:i386 : Conflicts: perl-base but 5.18.2-2ubuntu1 is installed.
Unable to resolve dependencies! Giving up...
The following NEW packages will be installed:
  perl-base:i386{b}
0 packages upgraded, 1 newly installed, 0 to remove and 300 not upgraded.
Need to get 1133 kB of archives. After unpacking 4895 kB will be used.
aptitude failed to find a solution to these dependencies. You can solve them yourself by hand or type 'n' to quit.
The following packages have unmet dependencies:
 perl-base : Conflicts: perl-base:i386 but 5.18.2-2ubuntu1 is to be installed.
 perl-base:i386 : Conflicts: perl-base but 5.18.2-2ubuntu1 is installed.
Resolve these dependencies by hand? [N/+/-/_/:/?] n
Abort.

System: Xubuntu 14.04.

So...?

Download full text (9.4 KiB)

I have the same problem, it didn't work on Ubuntu 14.04 64-bit neither Linuxmint Cinnamon 17 64-bit. I've searched and wrote the following in the Terminal.

---
sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386
sudo apt-get install libqt3support4-perl:i386
---

The result is

---
yousef@Linux4Ever ~ $ sudo dpkg --add-architecture i386
[sudo] password for yousef:
yousef@Linux4Ever ~ $ sudo apt-get update
Ign http://archive.ubuntu.com trusty InRelease
Ign http://archive.canonical.com trusty InRelease
Hit http://repo.steampowered.com precise InRelease
Ign http://archive.ubuntu.com trusty-updates InRelease
Hit http://archive.canonical.com trusty Release.gpg
Ign http://security.ubuntu.com trusty-security InRelease
Ign http://extra.linuxmint.com qiana InRelease
Hit http://archive.ubuntu.com trusty Release.gpg
Hit http://archive.canonical.com trusty Release
Ign http://packages.linuxmint.com qiana InRelease
Hit http://security.ubuntu.com trusty-security Release.gpg
Get:1 http://archive.ubuntu.com trusty-updates Release.gpg [933 B]
Hit http://archive.canonical.com trusty/partner amd64 Packages
Get:2 http://extra.linuxmint.com qiana Release.gpg [198 B]
Hit http://archive.ubuntu.com trusty Release
Get:3 http://packages.linuxmint.com qiana Release.gpg [198 B]
Hit http://archive.canonical.com trusty/partner i386 Packages
Hit http://security.ubuntu.com trusty-security Release
Get:4 http://archive.ubuntu.com trusty-updates Release [58.5 kB]
Get:5 http://extra.linuxmint.com qiana Release [3,144 B]
Hit http://repo.steampowered.com precise/steam Sources
Hit http://security.ubuntu.com trusty-security/main amd64 Packages
Get:6 http://packages.linuxmint.com qiana Release [18.6 kB]
Hit http://security.ubuntu.com trusty-security/restricted amd64 Packages
Get:7 http://extra.linuxmint.com qiana/main amd64 Packages [7,904 B]
Hit http://security.ubuntu.com trusty-security/universe amd64 Packages
Get:8 http://extra.linuxmint.com qiana/main i386 Packages [8,421 B]
Hit http://repo.steampowered.com precise/steam amd64 Packages
Get:9 http://packages.linuxmint.com qiana/main amd64 Packages [30.3 kB]
Hit http://archive.ubuntu.com trusty/main amd64 Packages
Hit http://security.ubuntu.com trusty-security/multiverse amd64 Packages
Hit http://archive.ubuntu.com trusty/restricted amd64 Packages
Hit http://security.ubuntu.com trusty-security/main i386 Packages
Hit http://archive.ubuntu.com trusty/universe amd64 Packages
Get:10 http://packages.linuxmint.com...

Read more...

Changed in perl (Ubuntu Trusty):
status: Triaged → Confirmed
Changed in perl (Debian):
status: Unknown → New

The following link helped me install some 32 bit libqt3 packages I needed

https://<email address hidden>/msg07565.html

Colin Watson (cjwatson) wrote :

We now have the Debian work for this in utopic:

perl (5.20.0-1) experimental; urgency=low

  * New upstream release.
  * Move @INC to multiarch enabled paths. (See #748380)
    + provide perlapi-5.20.0-exp1 for now (and set $Config{debian_abi}
      accordingly), because @INC might still change.
    + break libalien-wxwidgets-perl, libjcode-perl, and libanyevent-perl,
      which use /usr/lib/perl5 without a dependency on perlapi-* or the
      current perl version.
  * debian/rules: clean: no need to remove DB_File .bak files anymore.
  * Include the ABI version in the vendorarch directory.
    (See https://lists.debian.org/debian-perl/2014/05/msg00139.html)
    + solves the problem with dual life modules in perl-base (Closes: #743690)
    + libscalar-list-utils-perl can be made installable again (Closes: #725899)
    + no need for the ABI skew induced Build-Conflicts anymore
  * Make perl Multi-Arch:allowed and perl-modules Multi-Arch:foreign.
    (See https://lists.debian.org/debian-devel/2014/05/msg00058.html)
    (Closes: #717881)

 -- Niko Tyni <email address hidden> Sat, 31 May 2014 14:17:12 +0300

I expect it will take us a while to work out the general parameters of how to use this effectively, but the basic support is now there and evolving the rest will be much easier now.

(Note that the test proposed in comment #8 does not make sense. perl-base's main function is to install /usr/bin/perl, and you can only have one of those.)

Changed in perl (Ubuntu Trusty):
status: Confirmed → Won't Fix
Changed in perl (Ubuntu):
status: Triaged → Fix Released
Vlad Orlov (monsta) wrote :

So no backports to Trusty's perl 5.18?

Colin Watson (cjwatson) wrote :

No, sorry. It's an infeasibly large change.

Changed in perl (Debian):
status: New → Confirmed
Vlad Orlov (monsta) wrote :

BTW, note that according to the linked Debian bug report, perl-base is still not Multi-Arch.
So... isn't it too early to mark this bug as fixed?

Vlad Orlov (monsta) wrote :

Well, perl-base is still not multiarch-friendly in Xenial. Same in Debian Testing (no surprise).

Are you still sure it's ok to mark this bug report as fixed?

Vlad Orlov (monsta) wrote :

I've repeated the procedure from comment #9, and it seems like it's still a problem in Xenial.
See the attachment.

GGrandes (ggrandes) wrote :

I have same problem in Ubuntu Bionic

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.