Debian GNU/Linux

paprefs cannot configure pulseaudio network settings

Reported by Tim on 2011-08-18
338
This bug affects 73 people
Affects Status Importance Assigned to Milestone
PulseAudio
Fix Released
Unknown
paprefs (Debian)
Fix Released
Unknown
paprefs (Fedora)
Unknown
Unknown
paprefs (Ubuntu)
Critical
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

When I load up paprefs, all the networking options are greyed out and unable to be selected.

the only one option in paprefs that shows up as selectable is the virtual output device in the last tab.

I have tried manually editing default.pa and pulseaudio networking works fine.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: paprefs 0.9.9-2ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-8.11-generic 3.0.1
Uname: Linux 3.0.0-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Fri Aug 19 07:33:05 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110803.1)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: paprefs
UpgradeStatus: Upgraded to oneiric on 2011-08-13 (5 days ago)

Tim (darkxst) wrote :
Changed in paprefs (Ubuntu):
status: New → Confirmed
MFeif (matt-feifarek) wrote :

Same situation here.

I noticed that the only keys in gconf for pulseaudio relate to module combine (which as you noted, is the only checkbox available in paprefs)... perhaps this is a clue?

MFeif (matt-feifarek) wrote :

Two other clues:

1. Running pulseaudio -C and doing "list-modules" shows that module-native-protocol-tcp is not installed.

2. Also in pulseaudio -C, "list-clients" does NOT show paprefs when paprefs is running.

Julian Alarcon (alarconj) wrote :

Still broken on Ubuntu Oneiric... Seems weird, because the other distros and upstream already fix it.

pablomme (pablomme) wrote :

@Julian: the bugs you link to are very old. However they do contain clues as to what is happening and how to work around the bug (and it appears this is a recurrent problem with paprefs).

To bypass the bug, simply do:

sudo ln -s /usr/lib/pulse-0.99 /usr/lib/pulse-0.99.3

which is (according to strace) where paprefs was trying to locate the loadable modules. And according to the other bug reports, the fix is to rebuild paprefs along with the current pulseaudio, even though it does not directly link against it [!]. The Ubuntu packaging should change the dependencies accordingly so that this does not happen again.

Changed in pulseaudio:
status: Unknown → Fix Released
Changed in paprefs (Debian):
status: Unknown → Fix Released
Julian Alarcon (alarconj) wrote :

It's fixed in Ubuntu with lastest updates of PulseAudio

Bbut will be good to have the last version of papfres (the last version of PulseAudio (1.0) is already in Oneiric):

"Version 0.9.10 released; minor tidyups, should no longer require recompiling with each new PA version."

So, this problem will never come out again.

Changed in paprefs (Ubuntu):
status: Confirmed → Fix Released
Nobuto MURATA (nobuto) wrote :

It seems not fixed on current Oneiric, I'm afraid.
To run paprefs without gray-out, I have to do the trick `sudo ln -s /usr/lib/pulse-1.0 /usr/lib/pulse-1.0.0`.

Nobuto MURATA (nobuto) wrote :

Attached strace log says:

access("/usr/lib/pulse-1.0.0/modules/module-esound-protocol-tcp.so", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/pulse-1.0.0/modules/module-native-protocol-tcp.so", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/pulse-1.0.0/modules/module-zeroconf-publish.so", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/pulse-1.0.0/modules/module-zeroconf-discover.so", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/pulse-1.0.0/modules/module-raop-discover.so", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/pulse-1.0.0/modules/module-rtp-recv.so", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/pulse-1.0.0/modules/module-rtp-send.so", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/pulse-1.0.0/modules/module-rygel-media-server.so", F_OK) = -1 ENOENT (No such file or directory)

Nobuto MURATA (nobuto) wrote :

the strace log was recorded with:
paprefs 0.9.9-2ubuntu1
pulseaudio 1:1.0-0ubuntu3

Paul Kishimoto (khaeru) wrote :

Agreed this is *not* fixed with the package versions in #9.

The workaround in #7 also works for me.

Tim (darkxst) wrote :

yes as per Paul's comment, still not fixed in current Oneiric.

E.T. Anderson (firebringer11) wrote :

+1 not fixed. I did the workaround.

Chris Hardee (shazzner) wrote :

Work around did it for me, what a stupid bug.

lunarok (lunarok) wrote :

Same for me, the problem is still present in Oneiric. Bug is not solved.

Boris Erdmann (boris-erdmann) wrote :

the problem is still present in Oneiric because contrary to what is stated above 0.9.10 of paprefs is not released in ubuntu.

mankyd (mankyd) wrote :
cuc (cuc+) wrote :

bug still present! #7 fixes this bug

David Bell (evad) wrote :

This bug is affecting me too on the latest package in oneiric, comment #7 fixes it as others have said.

crispy (efisker) wrote :

#7 fixes this problem for me also. However, I had to restart to make pulseaudio service discoverable by avahi-discover

fireprog (daandeweerdt) wrote :

Bug still not fixed indeed! #7 did the trick

Alex Stapleton (alexs-prol) wrote :

Also broken for me in 11.10.

According to strace paprefs is looking for modules in

/usr/lib/pulse-1.0.0

when it should be looking in

/usr/lib/pulse-1.0

Creating a symlink fixes it for now.

sudo ln -s /usr/lib/pulse-1.0/ /usr/lib/pulse-1.0.0

Jeremy Schneider (ardentperf) wrote :

Broken for me, on 11.10 -- #7 fixed it without restarting anything in my case

Cory Dolphin (wcdolphin) wrote :

Broken for m in , on 11.10 -- #7 fixed it without restarting anything in my case

Version and package information below (11.10 and newest pulseaudio in the ubuntu repo):

dpkg -l | grep 'pulseaudio'
ii pulseaudio 1:1.0-0ubuntu3.1 PulseAudio sound server
ii pulseaudio-esound-compat 1:1.0-0ubuntu3.1 PulseAudio ESD compatibility layer
ii pulseaudio-module-bluetooth 1:1.0-0ubuntu3.1 Bluetooth module for PulseAudio sound server
ii pulseaudio-module-gconf 1:1.0-0ubuntu3.1 GConf module for PulseAudio sound server
ii pulseaudio-module-x11 1:1.0-0ubuntu3.1 X11 module for PulseAudio sound server
ii pulseaudio-module-zeroconf 1:1.0-0ubuntu3.1 Zeroconf module for PulseAudio sound server
ii pulseaudio-utils 1:1.0-0ubuntu3.1 Command line tools for the PulseAudio sound server

uname -a:
Linux Cory-Linuxlaptop 3.0.0-13-generic #22-Ubuntu SMP Wed Nov 2 13:27:26 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

DavidW617 (davidw617) wrote :

Still broken in Ubuntu 12.04 with pulseaudio 1.1

The updated workaround for Ubuntu 12.04 is: `sudo ln -s /usr/lib/pulse-1.1 /usr/lib/pulse-1.1.0`

Jorge O. Castro (jorge) wrote :

I've moved this back to confirmed as I can replicate this. Bug triagers, if you see a bug that is marked as Fix Released but isn't then no one is going to be looking at it, feel free to move it back to Confirmed, especially with such overwhelming responses that it isn't fixed.

For those of you who don't have bug privileges, you can always ask someone to look at a bug to set the right status by sending a mail to this list, thanks!

https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugsquad

Changed in paprefs (Ubuntu):
status: Fix Released → Confirmed
Jorge O. Castro (jorge) on 2012-01-01
tags: added: bitesize
Changed in paprefs (Ubuntu):
importance: Undecided → Critical
Julian Alarcon (alarconj) wrote :

This problem is still in ubuntu 12.04 Precise. But I already tried many symbolic version but none worked. Do you know which one works?

DDC (coquet) wrote :

I just did a fresh install of Lubuntu 11.10 and then installed praprefs. The fix that works in this case is

ln -s /usr/lib/pulse-1.0 /usr/lib/pulse-1.0.0

Leo Iannacone (l3on) on 2012-01-16
Changed in paprefs (Ubuntu):
assignee: nobody → Leo Iannacone (l3on)
Leo Iannacone (l3on) wrote :

There is a new bug in Debian on the current version of paprefs (0.9.9-2).

Changed in paprefs (Debian):
status: Fix Released → Unknown
Leo Iannacone (l3on) wrote :

Fix pulseaudio recognition without requiring a rebuild each
 time pulseaudio gets an update.

 Changed File: src/paprefs.cc
  Based on: 4fcee37cb92c689b43a0d8fc1d8e6b2764834cbf Mon Sep 17 00:00:00 2001
  From: Colin Guthrie
  Date: Sun, 6 Nov 2011 14:31:27 +0000
  Subject: [PATCH] Do not require a recompile for each new PA version in order to detect the modules.

 Changed Files: configure*
  In Ubuntu and Debian the command:
    `pkg-config libpulse --variable libdir'
  returns the path: /usr/lib/i386-linux-gnu
  But libpulse modules are located in /usr/lib.
  So, it's better use:
    `pkg-config libpulse --variable exec_prefix'/lib
  to right get the location prefix of modules.

  Version 0.9.10 also affected.

Leo Iannacone (l3on) wrote :
Leo Iannacone (l3on) wrote :
Leo Iannacone (l3on) wrote :

paprefs (0.9.9-2ubuntu2) precise; urgency=low

  * New patch 0005-fix-PA-version.patch, fixes to rebuild
    paprefs each time pulseaudio gets an update
    (LP: #829051) (closes: 649565)

 -- Leo Iannacone <email address hidden> Mon, 16 Jan 2012 20:19:38 +0100

Changed in paprefs (Ubuntu):
assignee: Leo Iannacone (l3on) → nobody
Changed in paprefs (Debian):
status: Unknown → New
Leo Iannacone (l3on) wrote :

The patch updated has some problem with non-standard system.

I'll work on it again.

Unsubscribe sponsors for now.

Changed in paprefs (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Leo Iannacone (l3on)
Leo Iannacone (l3on) on 2012-01-21
Changed in paprefs (Ubuntu):
assignee: Leo Iannacone (l3on) → nobody
status: In Progress → Confirmed
DDC (coquet) wrote :

I have two 11.10 machines that "sudo ln -s /usr/lib/pulse-1.0/ /usr/lib/pulse-1.0.0" seems to fix the probem for. However the option "Make discoverable PulseAudio network sound devices available locally" doesn't seem to work.

avahi-discover shows that the network sinks are discovered, but the devices do not show up in pacmd list-sinks .

pacmd list-modules:

    index: 8
        name: <module-zeroconf-discover>
        argument: <>
        used: -1
        load once: yes
        properties:
                module.author = "Lennart Poettering"
                module.description = "mDNS/DNS-SD Service Discovery"
                module.version = "1.0"

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package paprefs - 0.9.10-0ubuntu1

---------------
paprefs (0.9.10-0ubuntu1) precise; urgency=low

  * New upstream release.
  * Created debian source format 3.0 (quilt)
  * debian/control:
    + dropped cdbs, quilt, autotools-dev as build-dep
    + bumped standards version to 3.9.2
  * debian/rules: updated to use dh $@
  * debian/patches:
    + dropped all old patches, now in upstream
    + imported new two patches from upstream, make paprefs
      able to load pulseaudio dynamically (LP: #829051, closes: #649565)
  * debian/compat: up to 8
 -- Leo Iannacone <email address hidden> Mon, 23 Jan 2012 11:26:03 +0100

Changed in paprefs (Ubuntu):
status: Confirmed → Fix Released
Julian Alarcon (alarconj) wrote :

I confirm it's fixed in Precise, I don't know if this is fixed in Oneirc.

Hello Tim, or anyone else affected,

Accepted paprefs into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in paprefs (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Tim (darkxst) wrote :

I can confirm its fixed in oneiric.

Julian Alarcon (alarconj) wrote :

Do any one know if Natty is also affected?

To my knowledge, it has only affected Oneiric. I've been using this manager for a long time and this is the first time I've had it not work out of the box.

Martin Pitt (pitti) on 2012-01-25
tags: added: verification-done
removed: verification-needed
Florian Demmer (fdemmer) wrote :

this is still affecting oneiric (at least x64!). just did a fresh install on two system, both needed the fix from #7.

did you enable the

oneiric-proposed

repository?

On 27/01/12 08:29, Florian Demmer wrote:
> this is still affecting oneiric (at least x64!). just did a fresh
> install on two system, both needed the fix from #7.
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package paprefs - 0.9.9-2ubuntu1.1

---------------
paprefs (0.9.9-2ubuntu1.1) oneiric-proposed; urgency=low

  * Fix pulseaudio recognition without requiring a rebuild each
    time pulseaudio gets an update (LP: #829051).
 -- Leo Iannacone <email address hidden> Sat, 21 Jan 2012 13:00:21 +0100

Changed in paprefs (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in paprefs (Debian):
status: New → Fix Released
Vegard Torvund (vegardmeng) wrote :

Getting this bug in 12.04

tried to create a symlink to both '/usr/lib/pulse-1.0.0' and '/usr/lib/pulse-1.1.0'

none of them works

ii gstreamer0.10-pulseaudio 0.10.31-1ubuntu1 GStreamer plugin for PulseAudio
ii pulseaudio 1:1.1-0ubuntu15.1 PulseAudio sound server
ii pulseaudio-module-bluetooth 1:1.1-0ubuntu15.1 Bluetooth module for PulseAudio sound server
ii pulseaudio-module-gconf 1:1.1-0ubuntu15.1 GConf module for PulseAudio sound server
ii pulseaudio-module-x11 1:1.1-0ubuntu15.1 X11 module for PulseAudio sound server
ii pulseaudio-module-zeroconf 1:1.1-0ubuntu15.1 Zeroconf module for PulseAudio sound server
ii pulseaudio-utils 1:1.1-0ubuntu15.1 Command line tools for the PulseAudio sound server

pablomme (pablomme) wrote :

@vergardmeng: The following command should create the correct link for all versions of pulseaudio:

sudo ln -s $(find /usr/lib -maxdepth 1 -name "pulse-*" -type d -not -type l) $(strings $(type -P paprefs) | grep /usr/lib/pulse | sed "s%/modules%%")

Vegard Torvund (vegardmeng) wrote :

It still doesn't work.

An echo of your command (except the ls bit) gives:
"/usr/lib/pulse-1.1 /usr/lib/pulse-1.1"
so I guess there should be no need for a symlink in my case.

Reading the bug description carefully I found out that my case differs from this bug in a way too, I am able to do changes to the
" Make discoverable PulseAudio network sound devices available locally" checkbox
but not the
"Make discoverable Apple AirTunes sound devices available locally" checkbox is grayed out

could this be because im missing a module or something?

Anyway thanks for your quick reply.

-V

Tim (darkxst) wrote :

you need 'pulseaudio-module-raop' to make that option available.

Vegard Torvund (vegardmeng) wrote :

That worked!

sorry for bumping this bug

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.