new appointment window choice shows only sunday

Bug #257964 reported by Swastik Harish on 2008-08-14
6
Affects Status Importance Assigned to Milestone
orage (Debian)
Fix Committed
Undecided
Unassigned
orage (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: orage

in the new appointment window, the start and end buttons show change in date number but not in day of week.

Steps to reproduce:
run from terminal: "LANG=en_IN orage" (remove quote marks)
File->New

Orage 4.5.12.2-svn
Xfce 4.4.2
Ubuntu 8.04
2.6.24-19
AMD64

Related branches

Swastik Harish (swastikharish) wrote :
Juha Kautto (kautto-juha) wrote :

The format of those buttons depend on locale.
What is your locale?

What does command
locale
show in your system?

What does command
date +%x
show in your system?

My locale is India

swastik@eco:~$ locale
LANG=en_IN
LC_CTYPE="en_IN"
LC_NUMERIC="en_IN"
LC_TIME="en_IN"
LC_COLLATE="en_IN"
LC_MONETARY="en_IN"
LC_MESSAGES="en_IN"
LC_PAPER="en_IN"
LC_NAME="en_IN"
LC_ADDRESS="en_IN"
LC_TELEPHONE="en_IN"
LC_MEASUREMENT="en_IN"
LC_IDENTIFICATION="en_IN"
LC_ALL=
swastik@eco:~$ date +%x
Friday 15 August 2008

Thanks.

On Fri, Aug 15, 2008 at 3:22 AM, Juha Kautto <email address hidden>wrote:

> The format of those buttons depend on locale.
> What is your locale?
>
> What does command
> locale
> show in your system?
>
> What does command
> date +%x
> show in your system?
>
> --
> new appointment window choice shows only sunday
> https://bugs.launchpad.net/bugs/257964
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "orage" source package in Ubuntu: New
>
> Bug description:
> Binary package hint: orage
>
> in the new appointment window, the start and end buttons show change in
> date number but not in day of week.
>
>
>
>
> Orage 4.5.12.2-svn
> Xfce 4.4.2
> Ubuntu 8.04
> 2.6.24-19
> AMD64
>

Juha Kautto (kautto-juha) wrote :

I could not find this language pack. Any ideas which packages I should install to be able to see that myself?

Can you compile c/gtk files from source if I create a test program for you?

(Hard to understand how this is possible as the whole button string is generated with "strftime %x" command.)

Swastik Harish (swastikharish) wrote :

The language pack could be en-base. package manager says that. (how can i
find out for sure?). locale is india. I have seen problems that many
programs have in recognizing this locale, but it usually overrides or works
in some way.
I am not a linux guy. In fact I'm not even a computer guy. But I have grown
familiar with the CLI and have installed from source once or twice before.
If you could add a brief instruction to a test program I will definitely try
it.
Alternative is that I've just got orage 4.5 and could try it.
Regards.

On Sat, Aug 16, 2008 at 12:13 PM, Juha Kautto <email address hidden>wrote:

> I could not find this language pack. Any ideas which packages I should
> install to be able to see that myself?
>
> Can you compile c/gtk files from source if I create a test program for
> you?
>
> (Hard to understand how this is possible as the whole button string is
> generated with "strftime %x" command.)
>
> --
> new appointment window choice shows only sunday
> https://bugs.launchpad.net/bugs/257964
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "orage" source package in Ubuntu: New
>
> Bug description:
> Binary package hint: orage
>
> in the new appointment window, the start and end buttons show change in
> date number but not in day of week.
>
>
>
>
> Orage 4.5.12.2-svn
> Xfce 4.4.2
> Ubuntu 8.04
> 2.6.24-19
> AMD64
>

Juha Kautto (kautto-juha) wrote :

I can reproduce this now. (I managed to set my locale to en_IN and see the problem.)
Fix in progress.

Juha Kautto (kautto-juha) wrote :

This is now fixed in Xfce svn Orage version 4.5.14.3 (svn revision 27526).
But I do not know how and when this fix appears in Ubuntu (or debian).

Unfortunately there is no real workaround for this problem,
so Orage does not work with en_IN locale before this fix.

Swastik Harish (swastikharish) wrote :

I tried to configure orage 4.5.13.6-svn and it exits with
checking for libxfcegui4-1.0 >= 4.4.0... not found
*** The required package libxfcegui4-1.0 was not found on your system.
*** Please install libxfcegui4-1.0 (atleast version 4.4.0) or adjust
*** the PKG_CONFIG_PATH environment variable if you
*** installed the package in a nonstandard prefix so that
*** pkg-config is able to find it.
for sure i have libxfcegui4.4, but no amount of exporting environment
variables helped configure to find it.
i don't understand.

On Thu, Aug 21, 2008 at 12:02 AM, Juha Kautto <email address hidden>wrote:

> This is now fixed in Xfce svn Orage version 4.5.14.3 (svn revision 27526).
> But I do not know how and when this fix appears in Ubuntu (or debian).
>
> Unfortunately there is no real workaround for this problem,
> so Orage does not work with en_IN locale before this fix.
>
> --
> new appointment window choice shows only sunday
> https://bugs.launchpad.net/bugs/257964
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "orage" source package in Ubuntu: New
>
> Bug description:
> Binary package hint: orage
>
> in the new appointment window, the start and end buttons show change in
> date number but not in day of week.
>
>
>
>
> Orage 4.5.12.2-svn
> Xfce 4.4.2
> Ubuntu 8.04
> 2.6.24-19
> AMD64
>

Juha Kautto (kautto-juha) wrote :

This is not anymore related to the original BUG.
This is now install program, which should not be discussed here.

After saying that...
Try:
pkg-config --modversion libxfcegui4-1.0
It should say 4.4.2 or similar

pkg-config searches file called
libxfcegui4-1.0.pc

This file should be where PKG_CONFIG_PATH point to
(or in the default places)

do:
locate libxfcegui4-1.0.pc

and adjust PKG_CONFIG_PATH

But this discussion is really not in the scope of this BUG report.

Swastik Harish (swastikharish) wrote :

I understand. Thank you.

On Fri, Aug 22, 2008 at 12:09 AM, Juha Kautto <email address hidden>wrote:

> This is not anymore related to the original BUG.
> This is now install program, which should not be discussed here.
>
> After saying that...
> Try:
> pkg-config --modversion libxfcegui4-1.0
> It should say 4.4.2 or similar
>
> pkg-config searches file called
> libxfcegui4-1.0.pc
>
> This file should be where PKG_CONFIG_PATH point to
> (or in the default places)
>
> do:
> locate libxfcegui4-1.0.pc
>
> and adjust PKG_CONFIG_PATH
>
> But this discussion is really not in the scope of this BUG report.
>
> --
> new appointment window choice shows only sunday
> https://bugs.launchpad.net/bugs/257964
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "orage" source package in Ubuntu: New
>
> Bug description:
> Binary package hint: orage
>
> in the new appointment window, the start and end buttons show change in
> date number but not in day of week.
>
>
>
>
> Orage 4.5.12.2-svn
> Xfce 4.4.2
> Ubuntu 8.04
> 2.6.24-19
> AMD64
>

Confirmed as an issue, triaged

Changed in orage:
importance: Undecided → Wishlist
status: New → Triaged
description: updated

An in-progress patch has been committed to Debian Xfce SVN.

Changed in orage:
status: New → Fix Committed

This is now fixed in Debian, pending upload by Corsac (the fix has been confirmed). Once uploaded to Debian, a merge will bring it to Uubuntu. Since both Ubuntu and Debian have the same versions of orage, and the upload to Debian is a bug-fix only change, I believe that is the correct course of action. If not, I'm willing to simply create an Ubuntu only upload.

I think the change is too invasive for Intrepid. We'll fix in Jaunty :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package orage - 4.5.14.0-1ubuntu2

---------------
orage (4.5.14.0-1ubuntu2) jaunty; urgency=low

  * debian/patches/01_fix-l10n-en_IN.patch
    - Corrects an internationalization issue in en_IN local
      where the start/end buttons show the date number, but
      not the day of the week properly (LP: #257964)

 -- Michael Casadevall <email address hidden> Wed, 17 Dec 2008 22:35:54 -0500

Changed in orage:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments