Debian GNU/Linux

Cannot write to NFS files

Reported by Swirly on 2006-04-21
54
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OpenOffice
Confirmed
Unknown
libreoffice (Ubuntu)
Undecided
Unassigned
openoffice.org (Debian)
Fix Released
Unknown
openoffice.org (Ubuntu)
Undecided
Unassigned

Bug Description

SOLUTION:
1. Use NFSv4 if possible
2. Install nfs-common package if not installed

==

Opening a file within an NFS mounted
filesystem causes OpenOffice to show the file in read-only mode, and
remove the margins and various other editing widgets from the
application window. Any attempt to save a document to an NFS mount
results in an error dialog that contains the text:-

Error saving the document Filename.odt:
General Error.
General input/output error.

This makes the application extremely awkward to use in an office type
environment, and is a huge step backwards in functionality from the
OpenOffice.org 1.1.4 package it replaced for me.

This bug is know in debian as bug #335742.

It was closed by un upstream release.

In breezy, there is no way to work around the bug wich make ooo unusable in breezy in an office environment with NFS.

A partial solution would be to release a backport for openoffice.org2 from dapper, as the version in dapper works.

Gabriel Patiño (gepatino) wrote :

I'm having exactly the same issue in Dapper.

You say it works in dapper... should I install/configure something?

In Dapper, it can be solved by using the option 'nolock' while mounting the nfs share.

I don't know the implications of disabling locking in nfs... if someone knows, I'd be glad to hear about it. Private mail me if needed.

This problem has just appeared for me.

It was fine with dapper but after upgrading to edgy I can only open files from an NFS share as read only.

hads@snowman:~$ dpkg -l | grep openoffice
ii openoffice.org 2.0.4~rc2-1ubuntu6 OpenOffice.org Office suite version 2.0
ii openoffice.org-base 2.0.4~rc2-1ubuntu6 OpenOffice.org office suite - database
ii openoffice.org-calc 2.0.4~rc2-1ubuntu6 OpenOffice.org office suite - spreadsheet
ii openoffice.org-common 2.0.4~rc2-1ubuntu6 OpenOffice.org office suite architecture ind
ii openoffice.org-core 2.0.4~rc2-1ubuntu6 OpenOffice.org office suite architecture dep
ii openoffice.org-draw 2.0.4~rc2-1ubuntu6 OpenOffice.org office suite - drawing
ii openoffice.org-help-en-us 2.0.4~rc2-1ubuntu4 English_american help for OpenOffice.org
ii openoffice.org-impress 2.0.4~rc2-1ubuntu6 OpenOffice.org office suite - presentation
ii openoffice.org-java-common 2.0.4~rc2-1ubuntu6 OpenOffice.org office suite Java support arc
ii openoffice.org-kde 2.0.4~rc2-1ubuntu6 KDE Integration for OpenOffice.org (Widgets,
ii openoffice.org-l10n-common 2.0.4~rc2-1ubuntu4 common files for OpenOffice.org language and
ii openoffice.org-l10n-en-gb 2.0.4~rc2-1ubuntu4 English_british language package for OpenOff
ii openoffice.org-l10n-en-za 2.0.4~rc2-1ubuntu4 English_southafrican language package for Op
ii openoffice.org-math 2.0.4~rc2-1ubuntu6 OpenOffice.org office suite - equation edito
ii openoffice.org-thesaurus-en-us 2.0.3-2ubuntu1 English Thesaurus for OpenOffice.org
ii openoffice.org-writer 2.0.4~rc2-1ubuntu6 OpenOffice.org office suite - word processor

hads (hads) wrote :

Please excuse the duplicate post.

I remembered this from OO 1 and went looking on the OO site. Commenting out the line;

export SAL_ENABLE_FILE_LOCKING

in /usr/lib/openoffice/program/soffice fixes the problem for me.

Larry (larry-salibra) wrote :

Commenting out export SAL_ENABLE_FILE_LOCKING
 also solved this problem for me.

# file locking now enabled by default
SAL_ENABLE_FILE_LOCKING=1
#export SAL_ENABLE_FILE_LOCKING

Changing SAL_ENABLE_FILE_LOCKING=1 to SAL_ENABLE_FILE_LOCKING=0 without commenting out the export line does not correct the problem.

This problem did not exist for me under dapper but appeared after installing edgy.

hads (hads) wrote :

By the by, I've been playing with NFSv4 of late and OO works fine over that with file locking enabled.

Arne Hanssen (kingel) wrote :

 Commenting out the line;

export SAL_ENABLE_FILE_LOCKING

works for me also, but I discovered that if I open/create an empty/new file first, then I can open existing files as expected. Testing edgy RC.

Marc Schiffbauer (mschiff) wrote :

This is indeed a regression compared to dapper.

Would be great if you could fix this before release so people having NFS-Homes can work with OOo on Edgy..

Cheers
-Marc

Marc Schiffbauer schrieb:
> This is indeed a regression compared to dapper.
>
> Would be great if you could fix this before release so people having
> NFS-Homes can work with OOo on Edgy..

Is statd running on the client machine? what nfs-server is used?

upstream sees the enabling of file locking as a feature. current
approaches are:

- use NFSv4 on both the server and the client

- disable file locking (currently enabled in /usr/bin/soffice)

Had the same problem on Edgy eft RC, found out by some googling that the error was caused by OpenOffice not being able to lock the file (OpenOffice could have said so!).

Open Office needs statd on the client machine to lock files. I solved the problem by installing nfs-common. Shouldn't that be installed by default? The documentation says "Use this package on any machine that uses NFS, either as client or server. Programs included: lockd, statd, showmount, nfsstat, gssd and idmapd."

Toby

Torbjørn Sund schrieb:
> Had the same problem on Edgy eft RC, found out by some googling that the
> error was caused by OpenOffice not being able to lock the file
> (OpenOffice could have said so!).
>
> Open Office needs statd on the client machine to lock files. I solved
> the problem by installing nfs-common. Shouldn't that be installed by
> default?

don't think so, how would you use NFS without nfs-common?

Mark Shuttleworth (sabdfl) wrote :

Torbjørn Sund wrote:
> Open Office needs statd on the client machine to lock files. I solved
> the problem by installing nfs-common. Shouldn't that be installed by
> default? The documentation says "Use this package on any machine that
> uses NFS, either as client or server. Programs included: lockd, statd,
> showmount, nfsstat, gssd and idmapd."
>

If installing this would not open up any ports or cause any daemons to
run by default, then we should consider it.

Mark

Changed in openoffice:
status: Unknown → Confirmed

I can confirm this on ubuntu edgy (on both the nfs server and client).

Launching openoffice on a NFS-mounted home directory took forever. Installing nfs-common solved this problem (and many other performance-related problems).

BUT even with nfs-common, openoffice has some remaining problems, like crash on exit and random errors while saving. I am running it through "ssh -X" for now but other might not have/want openoffice on their nfs-server!

sheila (sheila-yao2000) wrote :

I have exactly the same error!

I have 2 USB flash drives mounted with various files and one storage system mapped from my local network as 10.10.xxx.x as backup system.

I can open files from those mounted flash drives or storage system, but I can't save the files to them.

I can only save files to local drive. So I have to do a copy to the mounted file systems after I saved it.

Sheila

sheila (sheila-yao2000) wrote :

My ubuntu is edgy 6.10 which I installed 3/11/07 with all the latest packages.

Sheila

Changed in openoffice.org:
status: Unknown → Unconfirmed
Matthew Wire (devel-mrwire) wrote :

This bug is still present with Ubuntu Feisty. It is solved by installing nfs-common package.

MrArne (ola-sundvall) wrote :

I Agree partially on the last post; Yes it is still present in Feisty, but - no - I have nfs-common installed, and the problem is there for sure. Will now test the commenting of export line in /usr/lib/openoffice/program/soffice as described above.

/ola

MrArne (ola-sundvall) wrote :

And Yes - now I can write straight into my odt-sheets on the file server! I'm so happy... it took me some time though to find this little source of wisdom - thanks all!

/ola

Russell Phillips (ignissport) wrote :

I've come across this problem, and mounting NFS shares with 'nolock' worked for me. It also (indavertently) fixed similar problems I was having when sharing my ~/.mozilla-thunderbird directory over NFS (for roaming mail).

Chris Cheney (ccheney) on 2007-10-21
Changed in openoffice.org:
importance: Medium → Wishlist
description: updated
Changed in openoffice.org:
status: New → Confirmed
Changed in openoffice.org:
status: New → Fix Released
Chris Cheney (ccheney) on 2008-06-14
Changed in openoffice.org:
status: Confirmed → Triaged

Is this bug still present in hardy and/or intrepid?

Rolf Leggewie (r0lf) on 2008-09-26
Changed in openoffice.org:
status: Triaged → Incomplete
Neil Munro (neilmunro) wrote :

Marked as confirmed since it's a known bug and it's in upstream debian and openoffice, however debian closed the bug from lack of activity it seems, it seems this particular bug is several years old now and was first reported in 2005.

Changed in openoffice.org:
status: Incomplete → Confirmed
Chris Cheney (ccheney) wrote :

Do you still have this problem with openoffice.org 1:2.4.1-9ubuntu2 in Ubuntu 8.10?

I can not reproduce this problem on Intrepid with nfs-common and nfs-kernel-server. I installed nfs-kernel-server on my desktop amd64 machine and just nfs-common on my laptop. Connected my laptop to my desktop and wrote files to the desktop without any problems.

Changed in openoffice.org:
importance: Wishlist → Undecided
status: Confirmed → Incomplete

Chris Cheney wrote:
> Do you still have this problem with openoffice.org 1:2.4.1-9ubuntu2 in
> Ubuntu 8.10?
>
> I can not reproduce this problem on Intrepid with nfs-common and nfs-
> kernel-server. I installed nfs-kernel-server on my desktop amd64 machine
> and just nfs-common on my laptop. Connected my laptop to my desktop and
> wrote files to the desktop without any problems.
>
> ** Changed in: openoffice.org (Ubuntu)
> Importance: Wishlist => Undecided
> Status: Confirmed => Incomplete
>
No it seems to be gone.

Thanks,

Chris Cheney (ccheney) on 2008-10-19
Changed in openoffice.org:
status: Incomplete → Fix Released

I've just upgraded from ooo 3.1 to 3.2 on Karmik and this problem appeared. With 3.1 everything worked fine. I'm using a Synology cs-407e as my nfs file server. I've renamed my .openoffice user profile but no change. Did anyone experienced the same issue?

fabio (ubuntu-manera) wrote :

Update: removed OOO 3.2, reinstalled 3.1, the problem is still here: I can't write to NFS share.

fabio (ubuntu-manera) on 2010-02-28
Changed in openoffice.org (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Eelbuntu (eelcoaartsen) wrote :

I recently upgraded to Ubuntu 10.04 lts, OOO 3.2, and now I get these problems. Files on my nfs are locked for editing. Tried some of the old solutions, but it all failed. Anybody with the same issue and a solution?

Steffen Rusitschka (rusi) wrote :

Same here with maverick using autofs

KennoVO (kenno-xs4all) wrote :

This is nothing short of appalling:
- Issue still present in LibreOffice on Precise (LTS)
- It's been 7 (seven) years
- Currently, the workaround is to edit a file that gets overwritten with every update: http://ubuntuforums.org/showthread.php?t=1645957&p=11891452#post11891452

The attached patch yields control over these essential flags back to /etc/libreoffice/soffice.sh , which is part of libreoffice-common but is ignored by /usr/lib/libreoffice/program/soffice (in the same package). It would be trivial for the package maintainer to apply this fix, with no loss of functionality whatsoever. People who are on NSFv3 simply would have to edit a flag in /etc/libreoffice/soffice.sh one time; since it's in /etc , later updates should leave it alone. Nothing changes for anyone else.

summary: - [Upstream] [hardy] OpenOffice cannot write to NFS files
+ Cannot write to NFS files

The attachment "libreoffice.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Thomas Hotz (thotz) wrote :

This bug contains a patch. So I mark it as confirmed, and hopefully someone can look trough the patch.

Also further I'm NOT able to set a priority, please do so. Thank you!

Changed in libreoffice (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.