Import saved VPN connection has been Recently Broken

Bug #1294899 reported by Lonnie Lee Best on 2014-03-19
606
This bug affects 180 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Debian)
Fix Released
Unknown
network-manager-applet (Ubuntu)
High
Unassigned
Trusty
High
Unassigned
Utopic
High
Unassigned

Bug Description

SRU Request:

[Impact]
Attempting to import a saved VPN connection file results in a segault. This is regression in Ubuntu 14.04 that worked correctly in previous versions.

[Test Case]
1- install network-manager-openvpn and network-manager-openvpn-gnome
2- from the network-manager indicator, click on Edit Connections
3- Click on Add
4- Select Import a saved VPN configuration, and open the file in comment #28

Expected results: a window should appear with the imported information
Current results: network-manager's connection editor segfaults

[Regression potential]
This SRU simply adds a couple of missing sections to the 11-user-connections.patch patch that went missing. If the fix is broken, either the vpn files won't import, or creating a new vpn connection could break completely.

Original description:
I believe recent changes have broken network-manager-openvpn feature that allows you to "Import saved VPN connection".

I've tested this feature with bundles that I've definitely imported successfully in the past.

Now, not only does it not import, but it gives absolutely no feedback at all; the window just disappears as though I didn't just ask it to import a VPN.conf file. The folder (I'm importing the .conf file from) includes all the necessary supporting files. I'm very sure this is not a user error on my part. I've done this several times in the past and I'm certain that the files (that are currently being ignored without dialog feedback) are exactly the same as they were when I was able to import successfully a few weeks ago.

I've tested this on multiple machines that have Ubuntu 14.04 installed and fully updated.

And, even if the files were indeed corrupted (which I'm certain they are not), the fact that the UI just disappears, instead of showing an error, is a bug within itself.

Also, I'd like to point out, that I was able to set up this VPN bundle manually. The point of this bug is to report that the ability to import via .conf files (so that you don't have to set things manually) has recently became nonfunctional.

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-openvpn (Ubuntu):
status: New → Confirmed
MoKraD (mokrad) wrote :

I see your bug after my Bug description #1296936 but the problem seems to me the same.

Here's a link to MoKraD's description to this problem:
https://bugs.launchpad.net/ubuntu/+source/network-manager-openvpn/+bug/1296936

It renders essential functionality of the package (or a dependent one) broken.

Changed in network-manager-openvpn (Ubuntu):
importance: Undecided → High

I've confirmed this bug on multiple computers. It is the worst bug I'm dealing with right now on the 14.04 beta. I had to figure out how to manually configure openVPN by reading its config file. It took a lot of combinations before I got it to work. This import-feature is a huge help, when it is working. It makes it to where you don't have to have much knowledge or skill to set it up.

Even advanced user will appreciate the speed and eliminated-steps it provides. Even now that I know how to do it manually, I'd rather be able to import like before.

This was very recently broken. I've successfully imported openVPN bundles in 14.04 multiple times since I began using it in January.

mydjey (mydjey) wrote :

This bug recently appear on 14.04. One month ago, on the same 14.04, the menu "Import saved VPN connection" worked fine and correctly import a ovpn file.

For connect a VPN manually, connected you to the gateway with NetworkManager, then cd to the .ovpn file directory and enter :
sudo openvpn your-ovpn-file.ovpn

John Ross (johnross-johnross) wrote :

Confirmed in fresh install of 14.04 release code. No network manager OVPN import function as in prior releases.

how was this not fixed during the pre-relase testing, this is really bad, one core feature that i really need.
hope this can get fixed soon, i really need my vpn connection.

the connecting through the terminal doesn't work withouth some workarounds with my vpn configuration...

john vincent (john-vincent) wrote :

It's incredible there is no solution right now. I'm having the same problems with .ovpn files that were working qith ubuntu12..04 !

How to reproduce:

I wanted to mention that there are websites that provide free openvpn bundles that might be useful for someone who wants to simply reproduce this bug. Someone who doesn't have a bundle to import, could get a free one online for testing purposes:
http://lmgtfy.com/?q=free+openvpn+bundles

To test this, I suspect you'd first have to install this:
sudo apt-get install network-manager-openvpn

Likely, that command alone will also trigger the installation of necessary dependency packages.

You may have to reboot after this (not sure). But then you'd go to the network manager indicator and then to:
VPN Connections > Configure VPN > Add > Import a saved vpn configuration

After this, you can test importing a free openvpn bundle you found online.

Mark Rich (sir-marky) wrote :

This is affecting me too. On a fresh installation of 14.04 I find it impossible to import VPN configuration files without network manager disappearing before me.

Mauro Gaspari (ilvipero) wrote :

Issue confirmed on a fresh install of 14.04 AMD64. Tried importing 5 different profiles.
Importing the same 5 profiles works fine on Ubuntu 13.10 AMD64.
Launching openvpn from command line works fine on ubuntu 14.04 AMD64.

tail -f /var/log/syslog output samples (while attempting to import openvpn profiles:
kernel: [ 3599.259837] nm-connection-e[1631]: segfault at 2793990 ip 0000000002793990 sp 00007fffe660d7e8 error 15
kernel: [ 4046.455991] nm-connection-e[14282]: segfault at 237d400 ip 000000000237d400 sp 00007fffbdb8c108 error 15
kernel: [ 4684.185320] nm-connection-e[29795]: segfault at 193f470 ip 000000000193f470 sp 00007ffffcf5e2e8 error 15

jromer (jr1) wrote :

This is affecting me too. On a upgrade from 12.04 to 14.04. Reverted back to 12.04. Can't use until fixed.

Mark Rich (sir-marky) wrote :

Importing a file results in this error at /var/log/syslog

Apr 22 19:06:20 markys-home-pc kernel: [13141.686135] nm-connection-e[29699]: segfault at ffffffffffffffff ip 0000000000433630 sp 00007fff1e1c9db0 error 5 in nm-connection-editor[400000+50000]

deliarmin (deliarmin) wrote :

can confirm the bug too:

Apr 23 08:21:23 ard-thinkpad kernel: [11049.697680] traps: nm-connection-e[13461] trap int3 ip:7f6b2679cc13 sp:7fff07154490 error:0

Changed in network-manager-openvpn (Debian):
status: Unknown → New
Michael (zweetsmoel) wrote :

Confirm bug since upgrade to 14.04, tried with several openvpn config files known to be working.
Several reports on my vpn service provider's forum mentioning exact same error
Please asign bug.

Here are some details of the crash that occurs:

Title:
nm-connection-editor crashed with SIGSEGV in g_closure_invoke()

ExecutablePath:
/usr/bin/nm-connection-editor

Package:
network-manager-gnome 0.9.8.8-0ubuntu4

SourcePackage:
network-manager-applet

SegvReason:
executing writable VMA [heap]

Signal:
11

To manually run OpenVPN and use .ovpn files, just run:

sudo openvpn (path)/example.ovpn

The only catch is that you have to modify your .ovpn file to use absolute paths.

I can confirum network-manager-openvpn does not work, but connecting manually does.

Bart Verwilst (verwilst) wrote :

It's not just importing configurations, trying to manually add a new one also crashes when you try to select the certificate. This makes openvpn totally unusable for 14.04 through network-manager.

Anthony (anthony-guillemette) wrote :

Add same problem, while importing an existing configuration or when adding manually on certificate selection.

Nand0 (ferdinandpc) wrote :

I have the same problem, and if I try to setup manually, when add the p12 certified, the process up to 100% cpu.

Spiral (escheit) wrote :

Same issue here, I get crash when I manually enter the config in network manager also, but I can connect via terminal comand.

Charles B Gibby (klemorali) wrote :

I have been experiencing this issue as well. I can manually configure OpenVPN via the /etc/openvpn/ directory without issue.

I can reproduce this on my machine as well.
A workaround description could be very useful :p

robled (robled) wrote :

To work-around this issue and still use Network Manager instead of the OpenVPN CLI, follow these steps:

1. Locate an installation of an older version of Ubuntu prior to 14.04 (set up a VM if necessary)
2. Import your saved VPN connection on that system
3. Find the imported Network Manager configuration file in this directory:

/etc/NetworkManager/system-connections

4. Copy that file to the same directory on the 14.04 system. Make sure to set permissions to root:root 600, and edit the paths to your certs/key files to taste. You may need to log off or restart to get Network Manager to pick up the new config.

Erik Ackermann (domohawk) wrote :

#25 workaround, while necessary was not sufficient for me.

Another problem I have (maybe others too?) is clicking the NetworkManager icon shows that eth0 "device is not managed". The default Ethernet>Wired Connection 1 present on 13.10 and before is missing. Trying to add it back in didn't work either, but finally setting "managed=true" in /etc/NetworkManger/NetworkManager.conf and `service restart network-manager` got it working to start already configured VPN profiles.

As for getting around the other bug of getting the vpn profiles configured, you can follow post #25, or just configure them by hand, or do what I did and revert network-manager to its ubuntu 13.10 version. You will have to download each deb from launchpad/ubuntu package site, or you could add the saucy repo and force install the correct versions.

dpgk -i --force-downgrade libnm-gtk0_0.9.8.0-1ubuntu5_amd64.deb network-manager_0.9.8.0-0ubuntu22_amd64.deb network-manager-openvpn_0.9.8.2-1ubuntu2_amd64.deb modemmanager_0.6.0.0.really-0ubuntu7_amd64.deb network-manager-gnome_0.9.8.0-1ubuntu5_amd64.deb network-manager-openvpn-gnome_0.9.8.2-1ubuntu2_amd64.deb

service restart network-manager

And don't forget to lock these package versions in synaptic or they will update/break on your next upgrade.

Marc Deslauriers (mdeslaur) wrote :

It seems this is caused by the Debian 11-user-connections.patch patch in network-manager-applet. Still investigating...

no longer affects: network-manager
no longer affects: network-manager-applet
Changed in openvpn:
status: New → Invalid
Marc Deslauriers (mdeslaur) wrote :

Here's a sample .ovpn file I found with a google search that reproduces the issue.

Mark Rich (sir-marky) wrote :

So how does one import the .ovpn and certificate files manually as suggested in #26?
I have copied the files to /etc/openvpn and what next?

Some helpful advice beyond the comment to do this may be useful for those of us who do not know how please.

Changed in network-manager-openvpn (Ubuntu):
status: Confirmed → Invalid
Changed in network-manager-openvpn (Ubuntu Trusty):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.8.8-0ubuntu5

---------------
network-manager-applet (0.9.8.8-0ubuntu5) utopic; urgency=medium

  * debian/patches/11-user-connections.patch: Unbreak importing VPN
    connections. (LP: #1294899)
  * debian/patches/git_use_paths_in_vpn_name_files_4867951.patch: use the paths
    specified in vpn .name files.
 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 16 May 2014 16:33:43 -0400

Changed in network-manager-applet (Ubuntu Utopic):
status: New → Fix Released
Changed in network-manager-applet (Ubuntu Trusty):
status: New → Confirmed
assignee: nobody → Marc Deslauriers (mdeslaur)
description: updated
Changed in network-manager-applet (Ubuntu Trusty):
status: Confirmed → In Progress

Hello Lonnie, or anyone else affected,

Accepted network-manager-applet into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/network-manager-applet/0.9.8.8-0ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in network-manager-applet (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Mauro Gaspari (ilvipero) wrote :

tested package version: network-manager-gnome 0.9.8.8-0ubuntu4.1

I am now able to succesfully import openvpn profiles. I tested 5 profiles, all imported correctly. Also confirmed openvpn can be connected and disconnected from network-manager without issues.

Thanks. please advise if more testing is needed.

Erik Ackermann (domohawk) wrote :

I also was able to import a few ovpn profiles sucessfully using the upgraded -proposed versions.

The first 2 times after I clicked "Save" the connection-editor window froze, showing a 100% cpu spin for `/usr/bin/nm-connection-editor --show --type vpn`, requiring it to be killed. However I have been unable to reproduce. After killing it did appear to have added the profile successfully.

A minor nit, after Deleting a profile via the editor that profile will remain in the applet dropdown, until network-manager is reloaded, or that profile is selected in which case it silently fails and removes the entry.

I am also unable to get any vpn to actually connect/work without changing managed=true in /etc/NetworkManager/NetworkManager.conf. Loading 13.10 it successfully adds a default managed connection "Wired Connection 1" for eth0, even while managed=false is set (the default)

dgoosens (dgoosens) wrote :

@kitterman
that did the trick for me !
thanks a lot

I was experiencing this crash when importing a cisco (vpnc) based VPN. Tested with the new package, and this has resolved the issue for me too.

I tested it out and still not working for me. Ubuntu 14.04LTS.

On 05/19/2014 03:48 AM, Dave Ball wrote:
> I was experiencing this crash when importing a cisco (vpnc) based VPN.
> Tested with the new package, and this has resolved the issue for me too.
>

jackbravo (jackbravo) wrote :

This solves the issue for me two. I tryied importing an openvpn and openconnect networks. Both work fine after the upgrade and failed before.

tags: added: verification-done
removed: verification-needed
laulau (olaulau) wrote :

worked for me, ubuntu 14.04 amd64
didn't noticed that package to upgrade is network-manager-gnome, wheras source package is network-manager-applet ... a little bit confusing.
thanks for the fix.

Download full text (3.5 KiB)

Will this update be released to the 14.04 repositories anytime soon?

Carlos Tavares Jr. sent from my S4
On May 19, 2014 5:05 PM, "laulau" <email address hidden> wrote:

> worked for me, ubuntu 14.04 amd64
> didn't noticed that package to upgrade is network-manager-gnome, wheras
> source package is network-manager-applet ... a little bit confusing.
> thanks for the fix.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1295439).
> https://bugs.launchpad.net/bugs/1294899
>
> Title:
> Import saved VPN connection has been Recently Broken
>
> Status in The OpenVPN Virtual Private Network:
> Invalid
> Status in “network-manager-applet” package in Ubuntu:
> Fix Released
> Status in “network-manager-openvpn” package in Ubuntu:
> Invalid
> Status in “network-manager-applet” source package in Trusty:
> Fix Committed
> Status in “network-manager-openvpn” source package in Trusty:
> Invalid
> Status in “network-manager-applet” source package in Utopic:
> Fix Released
> Status in “network-manager-openvpn” source package in Utopic:
> Invalid
> Status in “network-manager-openvpn” package in Debian:
> New
>
> Bug description:
> SRU Request:
>
> [Impact]
> Attempting to import a saved VPN connection file results in a segault.
> This is regression in Ubuntu 14.04 that worked correctly in previous
> versions.
>
> [Test Case]
> 1- install network-manager-openvpn and network-manager-openvpn-gnome
> 2- from the network-manager indicator, click on Edit Connections
> 3- Click on Add
> 4- Select Import a saved VPN configuration, and open the file in comment
> #28
>
> Expected results: a window should appear with the imported information
> Current results: network-manager's connection editor segfaults
>
> [Regression potential]
> This SRU simply adds a couple of missing sections to the
> 11-user-connections.patch patch that went missing. If the fix is broken,
> either the vpn files won't import, or creating a new vpn connection could
> break completely.
>
>
> Original description:
> I believe recent changes have broken network-manager-openvpn feature
> that allows you to "Import saved VPN connection".
>
> I've tested this feature with bundles that I've definitely imported
> successfully in the past.
>
> Now, not only does it not import, but it gives absolutely no feedback
> at all; the window just disappears as though I didn't just ask it to
> import a VPN.conf file. The folder (I'm importing the .conf file from)
> includes all the necessary supporting files. I'm very sure this is not
> a user error on my part. I've done this several times in the past and
> I'm certain that the files (that are currently being ignored without
> dialog feedback) are exactly the same as they were when I was able to
> import successfully a few weeks ago.
>
> I've tested this on multiple machines that have Ubuntu 14.04 installed
> and fully updated.
>
> And, even if the files were indeed corrupted (which I'm certain they
> are not), the fact that the UI just disappears, instead of showing an
> error, is a bug within itself.
>
> Also, I'd like to point out, ...

Read more...

laulau (olaulau) wrote :

it's already in trusty-propoed repo, think it will it updates repo soon if tests are good.

Download full text (3.3 KiB)

Sounds good. I'll wait for the update.

Carlos Tavares Jr. sent from my S4
On May 19, 2014 5:25 PM, "laulau" <email address hidden> wrote:

> it's already in trusty-propoed repo, think it will it updates repo soon
> if tests are good.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1295439).
> https://bugs.launchpad.net/bugs/1294899
>
> Title:
> Import saved VPN connection has been Recently Broken
>
> Status in The OpenVPN Virtual Private Network:
> Invalid
> Status in “network-manager-applet” package in Ubuntu:
> Fix Released
> Status in “network-manager-openvpn” package in Ubuntu:
> Invalid
> Status in “network-manager-applet” source package in Trusty:
> Fix Committed
> Status in “network-manager-openvpn” source package in Trusty:
> Invalid
> Status in “network-manager-applet” source package in Utopic:
> Fix Released
> Status in “network-manager-openvpn” source package in Utopic:
> Invalid
> Status in “network-manager-openvpn” package in Debian:
> New
>
> Bug description:
> SRU Request:
>
> [Impact]
> Attempting to import a saved VPN connection file results in a segault.
> This is regression in Ubuntu 14.04 that worked correctly in previous
> versions.
>
> [Test Case]
> 1- install network-manager-openvpn and network-manager-openvpn-gnome
> 2- from the network-manager indicator, click on Edit Connections
> 3- Click on Add
> 4- Select Import a saved VPN configuration, and open the file in comment
> #28
>
> Expected results: a window should appear with the imported information
> Current results: network-manager's connection editor segfaults
>
> [Regression potential]
> This SRU simply adds a couple of missing sections to the
> 11-user-connections.patch patch that went missing. If the fix is broken,
> either the vpn files won't import, or creating a new vpn connection could
> break completely.
>
>
> Original description:
> I believe recent changes have broken network-manager-openvpn feature
> that allows you to "Import saved VPN connection".
>
> I've tested this feature with bundles that I've definitely imported
> successfully in the past.
>
> Now, not only does it not import, but it gives absolutely no feedback
> at all; the window just disappears as though I didn't just ask it to
> import a VPN.conf file. The folder (I'm importing the .conf file from)
> includes all the necessary supporting files. I'm very sure this is not
> a user error on my part. I've done this several times in the past and
> I'm certain that the files (that are currently being ignored without
> dialog feedback) are exactly the same as they were when I was able to
> import successfully a few weeks ago.
>
> I've tested this on multiple machines that have Ubuntu 14.04 installed
> and fully updated.
>
> And, even if the files were indeed corrupted (which I'm certain they
> are not), the fact that the UI just disappears, instead of showing an
> error, is a bug within itself.
>
> Also, I'd like to point out, that I was able to set up this VPN bundle
> manually. The point of this bug is to report that the ability to
> import via .conf files ...

Read more...

Anthony G (9-ant) wrote :

the proposed 4.1 update to network-manager-gnome ubuntu fixed my issues.
-Imported ovpn file using network manager - success
-Used applet to connect vpn - success
-Applet icon animated during connection - success
-Tested connectivity - success
-Used applet to disconnect vpn - success

Tests run on Ubuntu 14.04 (AMD64+Mac)

Jonathan MIlls (jonmills-b) wrote :

My experience was mixed:

My testing method:
- Ubuntu 14.04 LTS fully updated with apt-get
- enabled 'trusty proposed' repo in synaptic
- from synaptic installed (updated) network-manager-gnome + whatever
dependencies it decided to choose for itself
- reboot (just because)

Results:
- first attempt to import my config.ovpn file succeeded, but
   - it didn't save my password on first try
   - the connection name didn't show up in nm-applet
   - second try it saved my password;
   - then the connection name did show up in nm-applet
- selecting the VPN connection name from the VPN menu in nm-applet
results in nothing happening. No connection is actually made. The
"flashy connecting" icon doesn't appear where the nm-applet icon lives
in the panel.

So basically, I can import a VPN connection, and I can't use it.

On 05/19/2014 08:09 PM, Anthony G wrote:
> the proposed 4.1 update to network-manager-gnome ubuntu fixed my issues.
> -Imported ovpn file using network manager - success
> -Used applet to connect vpn - success
> -Applet icon animated during connection - success
> -Tested connectivity - success
> -Used applet to disconnect vpn - success
>
> Tests run on Ubuntu 14.04 (AMD64+Mac)
>

--
Jonathan Mills
Systems Administrator
Renaissance Computing Institute
UNC-Chapel Hill

The proposed update also worked for me. I just tested moments ago. I was
able to import my configuration and connect to my openvpn. Thanks for
the fix!

On 05/19/2014 08:09 PM, Anthony G wrote:
> the proposed 4.1 update to network-manager-gnome ubuntu fixed my issues.
> -Imported ovpn file using network manager - success
> -Used applet to connect vpn - success
> -Applet icon animated during connection - success
> -Tested connectivity - success
> -Used applet to disconnect vpn - success
>
> Tests run on Ubuntu 14.04 (AMD64+Mac)
>

Max (maxter) wrote :

the proposed update also worked for me. all went fine,import, start stop, restart.
Thanks.

Max (maxter) wrote :

sorry i forgot to mention the version i tested: network-manager-gnome version 0.9.8.8-0ubuntu4.1.
i'm using amd64 architecture.

Duncan Lock (dunc) wrote :

The trusty-proposed update fixed it for me.

onufle (onufle) wrote :

Thanks for the fix, network-manager-gnome version 0.9.8.8-0ubuntu4.1. worked for me (ubuntu 14.04 / amd64)

Changed in network-manager-applet (Ubuntu Trusty):
status: Fix Committed → Confirmed
assignee: Marc Deslauriers (mdeslaur) → nobody
Prometheus Works (sureal55) wrote :

The proposed update worked for me just fine.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.8.8-0ubuntu4.1

---------------
network-manager-applet (0.9.8.8-0ubuntu4.1) trusty; urgency=medium

  * debian/patches/11-user-connections.patch: updated to fix importing VPN
    connections. (LP: #1294899)
 -- Marc Deslauriers <email address hidden> Fri, 16 May 2014 17:14:58 -0400

Changed in network-manager-applet (Ubuntu Trusty):
status: Confirmed → Fix Released

The verification of the Stable Release Update for network-manager-applet has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

I can't find network-manager-gnome on the proposed repository :

sudo apt-get install network-manager-gnome/trusty-propose

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Release 'trusty-proposed' for 'network-manager-gnome' was not found

Any thought ?
Thanks

Woops, my mistake :) Did't see the release yet :)

Avery (docaltmed) wrote :

Nope. Fully updated, still cannot import .ovpn.

The only difference is that now the VPN won't work through the command line either.

Wonder how far is the fix?
I could use the same stuff from command line with "openvpn <conffile>".
But import is still broken.

Manual add in Network Manager works.
For example here are some instructions
https://airvpn.org/topic/11432-using-airvpn-with-ubuntu-network-manager/

Marc Deslauriers (mdeslaur) wrote :

This bug has been fixed already. If you are still having issues, please file a new bug along with steps on how to reproduce.

jedihe (jedihe) wrote :

Found a manual fix for my specific case; it may be useful for others, so let's share it.

I'm running network-manager-gnome 0.9.8.8-0ubuntu4.3 and I was having the same issue while importing a connection from an .ovpn file (no message, no error, nothing at all). After I checked the file contents, I found a short message instructing to switch on a commented line for the tls-remote parameter if running openvpn 2.3+ (which Trusty Tahr does); once I did that (also disabling the original one), I was able to import the connection and the VPN was working correctly when I enabled it.

Line for old OpenVPN version reads like:
tls-remote "/C=xx/L=SOMETHING_HERE<email address hidden>"

Line for new OpenVPN (2.3+) reads like:
tls-remote "C=xx, L=SOMETHING HERE, O=COMPANY NAME, CN=ANOTHER-VALUE-HERE, <email address hidden>"

Please note my .ovpn file didn't include embedded certificates or keys, they were provided as separate files from the very beginning.

Hope it helps.

candtalan (aeclist) wrote :

I use a vpn a lot and currently on Ububntu 12.04 LTS. This bug has stopped me in my tracks from going to Ubuntu 14.04
Best wishes for a good fix

vpn import works under 14.04!

i'm using ubuntu gnome 14.04, importing directly over the network manager fails with an error. instead of trying it over the network manager, i start network connections over the HUD and there i can import a openvpn configuration.

i'm guessing this is way it's marked as fixed.

I can confirm the same behavior on Ubuntu GNOME 14.10.

Importing a VPN configuration with the "new" configuration tool does not work. However, using the "network connections" app works correctly, as stated by vaiopro.

Evan Carroll (evancarroll) wrote :

This is still not working for me and others. When I try to import, all of the certs are empty and the option to "Save" is grayed out.

Evan Carroll (evancarroll) wrote :

I assume I could follow the steps here: https://www.expressvpn.com/tutorials/expressvpn_linux and break apart the ovpn file to the separate cert/keys, but this importer should really do this.

candtalan (aeclist) wrote :

I am using Ubuntu 12.04 (fully updated). Recently, something has broken the existing (was working ok!)
Import VPN and
Disconnect VPN (both now greyed out)
options in network manager menu available at the top of the display.
I confirm this is in Ubuntu 12.04 LTS, not a more recent release.

I am continuing using VPN, based on openvpn I believe, which I have previously imported, this continues to be displayed, and work. However the menu option to 'Disconnect VPN' no longer is offered (greyed out).
I have a second intallation of Ubuntu 12.04 on the machine (multi boot) and it also shows the same problem.

I note that previously, above, on 2014-09-08 I said I would have liked to start using the later LTS being Ubuntu 14.04, however, the bug in Network Manager(?) prevented me, because I use VPN a lot.

If more information is neede please let me know?
tia

Yo (yleduc) on 2015-04-13
Changed in network-manager-openvpn (Ubuntu):
status: Invalid → Confirmed
Ben (7-ben-a) wrote :

Is someone still working on this? I use Lubuntu 14.04. LTS and cannot import an openvpn.ovpn file using the network manager. It says it cannot read the "PPTP-configuration". Ist there any other way to generate a openvpn-connection than importing a setup-file?

I've been using it just fine on Xubuntu 14.04.x for quite a while now.
Make sure you've installed network-manager-openvpn and associated
packages and try again.

On 08/17/2015 09:00 AM, Ben wrote:
> Is someone still working on this? I use Lubuntu 14.04. LTS and cannot
> import an openvpn.ovpn file using the network manager. It says it cannot
> read the "PPTP-configuration". Ist there any other way to generate a
> openvpn-connection than importing a setup-file?
>

Changed in network-manager-openvpn (Debian):
status: New → Confirmed
Changed in network-manager-openvpn (Debian):
status: Confirmed → Fix Released

Actually, it works fine 16.04, here's what changed:

In versions of Ubuntu prior to 16.04, you could install openVPN like this:
sudo apt-get install network-manager-openvpn

In Ubuntu 16.04, you install it like this:
sudo apt-get install network-manager-openvpn-gnome

In versions of Ubuntu prior to 16.04, you could install vpnc like this:
sudo apt-get install network-manager-vpnc

In Ubuntu 16.04, you install it like this:
sudo apt-get install network-manager-vpnc-gnome

John Ross (johnross-johnross) wrote :

I can confirm that OpenVPN import function does not work on any of the numerous systems that I have upgraded from Xubuntu 14.04 to 16.04.

I note that I have all of the required packages installed and that the .ovpn file I'm using have worked in the past under 14.04. In case it matters, the .ovpn files NOT use inline certs which is apparently the cause of another related OVPN bug.

In summary then, when attempting to import a .ovpn file, I get the following error message:

Cannot import VPN connection
The file 'xxxx.ovpn' could not be read or does not contain recognized VPN connection information
Error: the plugin does not support import capability

With some trial and error I was able to manually configure the settings using the ovpn file as a guide. This is very time consuming and exercise and it would be much better if the import function was repaired.

Erik Ackermann (domohawk) wrote :

John,

What VPN provider are you using? I am having no problems in 16.04 using ovpn files provided by PrivateInternetAccess. Perhaps this is a compatibility problem with the format of your provider's files.

Can you check if you can successfully import a vpn config from this file? https://www.privateinternetaccess.com/openvpn/openvpn.zip

John Ross (johnross-johnross) wrote :

Erik,

I'm using StrongVPN. I've used the same .ovpn now for several years and it used to work fine.

I tried opening US West.ovpn from your .zip and it came in fine. I could not actually test the configuration of course since I didn't have username and password. I suppose this points to a compatibility issue?

After successful import of your file, I went to StrongVPN and got a newer .ovpn file. It uses inline certs instead of separate cert files.

Sadly, when I try to import it I get this error message:

Cannot import VPN connection
The file 'xxxx.ovpn' could not be read or does not contain recognized VPN connection information
Error: Key file contains line 'remote 72.18.194.140 500 udp' which is not a key-value pair, group, or comment.

Perhaps this will give someone a clue as to the issue here. Thanks for your help!

affects: network-manager-openvpn (Debian) → network-manager-applet (Debian)
affects: openvpn → ubuntu-translations
no longer affects: ubuntu-translations
no longer affects: network-manager-openvpn (Ubuntu)
no longer affects: network-manager-openvpn (Ubuntu Trusty)
no longer affects: network-manager-openvpn (Ubuntu Utopic)
Mathew Hodson (mathew-hodson) wrote :

I am closing this bug because the original issue was fixed.

If you are having trouble with missing menu options, please take a look at comment #67 in this bug and also look at bug #1212573

If you are having other issues please report a new bug.

Mathew Hodson (mathew-hodson) wrote :

John Ross,

It seems the issue you are having is bug #606365 which is being unable to import a config with an inlined cert.

John Ross (johnross-johnross) wrote :

No, I don't think that is the only issue. I'm trying to import OpenVPN files provided by StrongVPN.

One of them is an older VPN file that does not have inlined certs. This one used to work with no problems in Xubuntu 14.04. Since upgrading to Xubuntu 16.04 I get an error when trying to import it. I don't think this one is related to bug #606365.

I also downloaded a newer OpenVPN file from StrongVPN that has inlined certs. This one also causes an error when I attempt to import it under Xubuntu 16.04. This one may be related to bug #606365 but there may be some other issues too?

Since neither of the OpenVPN files can be imported I had to configure the VPN by manually reading the OpenVPN files and transcribing the settings into the network manager.

Changed in network-manager-applet (Ubuntu):
importance: Undecided → High
Changed in network-manager-applet (Ubuntu Trusty):
importance: Undecided → High
Changed in network-manager-applet (Ubuntu Utopic):
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.