desktop launcher properties window disappears

Bug #224642 reported by alzibub on 2008-04-30
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Unknown
Medium
Nautilus
Unknown
Medium
linux (Ubuntu)
Low
Andy Whitcroft
Nominated for Hardy by Andy Whitcroft
Nominated for Intrepid by Andy Whitcroft
Jaunty
Low
Andy Whitcroft
nautilus (Debian)
New
Unknown

Bug Description

To reproduce:
 * create a desktop launcher called test with command /bin/true
 * right click on the launcher and choose "properties"
 * select the "launcher" tab

After about a second the properties window should then disappear.

The launcher still works, and a workaround is to edit ~/Desktop/test.desktop directly using any text editor.

More details (from my shell):

alexz@galois:~/Desktop$ ls -l test.desktop
-rw-r--r-- 1 alexz xendev 192 2008-04-30 12:24 test.desktop
alexz@galois:~/Desktop$ cat test.desktop
[Desktop Entry]
Version=1.0
Encoding=UTF-8
Name=test
Type=Application
Terminal=false
Name[en_GB]=test
Exec=/bin/true
Comment[en_GB]=do nothing much
Comment=do nothing much
GenericName[en_GB]=
alexz@galois:~/Desktop$ cat /etc/issue
Ubuntu 8.04 \n \l

alzibub (alex-zeffertt) on 2008-04-30
description: updated
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, your crash report is either missing or challenging to deal with as a ".crash" file. Please follow these instuctions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

If you are using Ubuntu with the Gnome desktop environment - launch nautilus and navigate to your /var/crash directory and double click on the crash report you wish to submit.

I'm closing this bug report since the process outlined above will automatically open a new bug report which can then dealt with more efficiently. Thanks in advance for your cooperation and understanding.

Changed in meta-gnome2:
status: New → Invalid
alzibub (alex-zeffertt) wrote :

Hi Pedro,

I've tried to follow the instructions above, but there are no files in the /var/crash directory.

I'm not experiencing this problem on my machine at home, only at work. I wonder if it's got something to do with the fact my home directory is NFS mounted.

Pedro Villavicencio (pedro) wrote :

Hello, you need to enable apport first in /etc/default/apport then restart and trigger the crash. thanks.

alzibub (alex-zeffertt) wrote :

Hi Pedro,

I enabled apport (see below), rebooted, and reproduced the problem. But /var/crash is still empty.

Regards,

Alex.

alexz@galois:~$ cat /etc/default/apport
# set this to 0 to disable apport, or to 1 to enable it
enabled=1

# set maximum core dump file size (default: 209715200 bytes == 200 MB)
maxsize=209715200

Pedro Villavicencio (pedro) wrote :

Maybe is not crashing, just closing. Can you attach your ~/.xsession-errors file after trigger the bug? thanks.

Changed in meta-gnome2:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Invalid → Incomplete
alzibub (alex-zeffertt) wrote :

Np. See attached. Regards.

sirianni (eric-sirianni) wrote :

Any update on this? I have the same exact problem. *My home directory is also NFS mounted.*

I've also disabled Network Manager (due to issues with NIS startup) - not sure if this is relevant...

I don't see anything relevant in .xsession-errors.

John Pearson (admin-gtagalenco) wrote :

Here's a "me too".

/home is NFSv3 mounted and there's nothing obviously wrong with the Launcher, but the Properties dialog closes after selecting the "Launcher" tab. No sign of distress or any actual crash, it just closes.

Happens on Hardy 8.04 with both old (6.06) and newly-created launchers.

John Pearson.

Eric Chlebek (chlebek) wrote :

Marked confirmed as I can reproduce this bug and have added the method to do so.

Changed in nautilus:
status: Incomplete → Confirmed
Eric Chlebek (chlebek) wrote :

To reproduce:

Mount /home with NFS.
Create a launcher on the desktop.
Edit the launcher, and click on the "Launcher" tab. The dialog box closes.
This only happens when /home is mounted from NFS.

Sebastien Bacher (seb128) wrote :

could you get a stacktrace since you have the nfs configuration to trigger the bug?

Changed in nautilus:
status: Confirmed → Incomplete
Eric Chlebek (chlebek) wrote :

Here is the strace output. I attached to the running nautilus process and then triggered the bug. Unfortunately there is quite a lot of junk output in the file.

Sebastien Bacher (seb128) wrote :

the strace logs don't give useful informations usually, could you use gdb as described on http://wiki.ubuntu.com/DebuggingProgramCrash to get a stacktrace?

Eric Chlebek (chlebek) wrote :

I'm not sure how to get the stack trace via gdb. If I say something like "gdb nautilus" then nautilus executes and forks, causing a detach, leaving gdb without anything meaningful. If I say something like "gdb --pid=1234" to attach to my running nautilus, then nautilus hangs until I quit gdb. I have installed nautilus-dbg as indicated by the debugging guide. Any suggestions? Thanks for your help.

Sebastien Bacher (seb128) wrote :

you need to type "continue" on the gdb prompt after attaching it to a running software

Sebastien Bacher (seb128) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in nautilus:
status: Incomplete → Invalid
Ricardo (ricardo-duarte) wrote :

Same problem here.
If the home account is mounter with NFS, the properties window of laucher just closes when I choose tab "Launcher".
No errors are shown on both .xsession and /var/crash.

I have been triying to retrieve the info you request from gdb, but there is a problem. The page at the ubuntu wiki explains how to debug an app that crashes. But, in this case, Nautilus doesn't crash. It is only the properties window that disappears when you click on the "Launcher" tab.

So gdb stands waiting for the program to crash, indefinitely. The only solution is to press Ctrl+c, but it doesn't provide any info about the bug.

Anyway, I attach the output of the program.

BTW, I have only this problem on NFS mounted dirs.

I've had exactly the same problem on my system at work. Ubuntu 8.04, with nfs mounted home directory (red hat EL5 nfs server) and nis served by solaris 9 host.

I don't know if these problems are related or not, but I often have to "touch" the .Xauthority file to allow X client apps to display if they've been launched from other hosts.

Virtual box (2.0.4) also aborts (seemingly at random) and I wonder whether its something to do with filesystem notification event issues with NFS.

Andy Ruddock (andy-ruddock) wrote :

NFS mounted home here as well, exhibits same problem.
See attached gdb-nauilus.txt

There's no crash, the window just closes after approximately 1 second.

Hi, This bug was closed as invalid because no GDB stack trace had been provided for the crash; but there is no crash per se, so a stack trace is not really appropriate.

Further investigation reveals that everything works fine with user-space NFS but not with the kernel-based NFS server, which suggests it's a locking issue of some kind (as unfs3 does not support locking).

Please let me know if there's anything you need which we can actually provide.

John Pearson.

Changed in nautilus:
status: Invalid → Incomplete
Sebastien Bacher (seb128) wrote :

John, your nfs case seems to be different from the bug described there, and writting "crashes" in the title if the software doesn't crash is misleading and lead to such confusions

Sebastien Bacher (seb128) wrote :

the nfs issues could be that the dialog tries to stat a file on the server which block or something but the description and comments are just confusing since they seem to list different issues from different users, would be much easier to open new clean bugs than commenting on similar closed bugs

Changed in nautilus:
status: Unknown → New
status: Unknown → New
Changed in nautilus (Ubuntu):
status: Incomplete → Triaged
Timo Aaltonen (tjaalton) wrote :

Confirmed that the bug is in the kernel NFS code, and a patch is attached to the upstream bug. I'll propose it to the kernel team.

Changed in nautilus (Ubuntu):
assignee: desktop-bugs → nobody
Andy Whitcroft (apw) on 2009-03-20
Changed in linux:
assignee: nobody → apw
status: Triaged → In Progress
Andy Whitcroft (apw) wrote :

Ok I have pulled this change down and applied it to our Jaunty kernel. If those of you on Jaunty could test this kernel and report back here that would be very helpful. Kernels can be found at the URL below:

    http://people.ubuntu.com/~apw/lp224642-jaunty/

Andy Whitcroft (apw) on 2009-03-20
Changed in linux:
status: In Progress → Incomplete

Hi there,

Any chance of test kernels with the fix for 8.04? I'm keen to test/verify the fix, but we're currently working with Hardy (LTS), not Jaunty.

Thanks,

John Pearson.

Andy Whitcroft (apw) on 2009-03-23
Changed in linux:
status: Incomplete → In Progress
Andy Whitcroft (apw) wrote :

@John -- I have backported the patch to Hardy, it was not a slam-dunk so it will need some testing. Please could you test the kernels at the URL below and report back here:

    http://people.ubuntu.com/~apw/lp224642-hardy/

Changed in linux:
status: In Progress → Incomplete

Hi Andy.

The patched 2.6.24 kernel you provided resolves the issue on hardy for me, and hasn't caused any other problems so far. Will this make its way into 8.04 as an update?

Thanks,

John.

Changed in linux:
status: Unknown → Invalid
Changed in nautilus:
status: New → Invalid
Timo Aaltonen (tjaalton) wrote :

Is there a chance to get this in jaunty?

Andy Whitcroft (apw) on 2009-04-07
Changed in linux (Ubuntu Jaunty):
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.28-11.41

---------------
linux (2.6.28-11.41) jaunty; urgency=low

  [ Amit Kucheria ]

  * ixp4xx: Enabled TCP SYN_COOKIES
    - LP: #346378

  [ Brad Figg ]

  * Change LPIA configuration to compile with CONFIG_NETFILTER_XT_MATCH_RECENT
    - LP: #355291

  [ Kay Sievers ]

  * SAUCE: driver core: allow non-root users to listen to uevents
    - LP: #357124

  [ Manoj Iyer ]

  * SAUCE: Added quirk to recognize GE0301 3G modem as an interface.
    - LP: #348861

  [ Tim Gardner ]

  * Revert "SAUCE: [i915] allocate MCHBAR space & enable if necessary"
    Appears to cause hard locks in some cases.
    - LP: #349314

  [ Trond Myklebust ]

  * SAUCE: NFS: Fix the notifications when renaming onto an existing file
    - LP: #224642

  [ Upstream Kernel Changes ]

  * USB: option: add QUANTA HSDPA Data Card device ids
    - LP: #353321
  * hwmon: (abituguru3) Match partial DMI board name strings
    - LP: #298798
  * zd1211rw: adding Sitecom WL-603 (0df6:0036) to the USB id list
    - LP: #339631
  * USB: unusual dev for Option N.V. ZeroCD modems
    - LP: #348861

 -- Tim Gardner <email address hidden> Sat, 04 Apr 2009 08:42:14 -0600

Changed in linux (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Andy Ruddock (andy-ruddock) wrote :

Will there also be a fix for Hardy? The type of users who have /home mounted via NFS are exactly the kind of users who run LTS releases.

Changed in linux:
importance: Unknown → Medium
status: Invalid → Unknown
Changed in nautilus:
importance: Unknown → Medium
status: Invalid → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.