gmplayer does not fall back to other vo modules if the first one fails

Bug #65165 reported by matt nicholson on 2006-10-10
46
This bug affects 4 people
Affects Status Importance Assigned to Milestone
MPlayer
Confirmed
Unknown
mplayer (Baltix)
Undecided
Unassigned
mplayer (Debian)
Confirmed
Unknown
mplayer (Ubuntu)
Low
Unassigned

Bug Description

gmplayer fails to play a video file in a default configuration, as xmga is selected as the default video out device, and autodetect fails to work. As a result, errors are shown and the video does not play.

The command-line mplayer will, however, correctly autodetect a suitable video out (vo) and play the same video file in a default install.

This happens on a new install, with no config file present in ~/.mplayer. If the preferences are changed, and the video out is set to xv, x11 or another suitable for the system, the file will play.

Related branches

I've noticed the same problem on edgy (mplayer package version 2:0.99+1.0pre8-0ubuntu8) and tried to examine it a bit:

Problem exists only when mplayer is started with gui (as gmplayer) the tail of the output in terminal looks like this:

----begin quotation----
AVI file format detected.
VIDEO: [divx] 480x320 24bpp 30.000 fps 918.5 kbps (112.1 kbyte/s)
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
open: No such file or directory
vo_mga: Couldn't open /dev/mga_vid
----end quotation----

and the window with message about error in opening video_out (-vo) device appears.

However when started without gui (as mplayer) the problem does not exist.

I've tried to downgrade to version 2:0.99+1.0pre7try2+cvs20060117-0ubuntu8 which used to work on dapper, but unexpectedly problem still appeared! It also appeared when I tried by my self compiled version 1.0rc1 downloaded from mplayerhq.hu. So I suspect that this is something wrong with edgy environment, not with mplayer it self, that makes it not work properly when started with gui.

oh, and by the way: a simple workaround is to add the following line at the end of your ~/.bashrc file:
alias gmplayer='gmplayer -vo xv'

ok, the other versions I've tried probably didn't work because of vo_driver entry in ~/.mplayer/gui.conf made by 2:0.99+1.0pre8-0ubuntu8 so now I think problem is in mplayer it self (sorry for the mess...), and a better workaround is to edit ~/.mplayer/gui.conf and change vo_driver to xv

You can do this from the GUI by choosing preferences -> Video and choosing "xv" or "x11" driver. No need to edit conf files by hand or add aliases.

Changed in mplayer:
importance: Undecided → Low
status: Unconfirmed → Confirmed
Mark Reitblatt (mark-reitblatt) wrote :

Ok, I'm not sure why it is defaulting to xmga, but if we just change the "example.conf" to uncomment "#vo=xv", this should work. I'd include a patch, but I don't do .deb so I don't know what it should be relative to.

Nafallo Bjälevik (nafallo) wrote :

Is this still the case with 2:1.0~rc1-0ubuntu6 or later?

Changed in mplayer:
status: Confirmed → Needs Info
Mark Reitblatt (mark-reitblatt) wrote :

Yes. xmga is still the default for me in Feisty.

Changed in mplayer:
status: Needs Info → Confirmed
ruskie (ruzkie) wrote :

Weird that this isnt fixed yet, still xmga in 7.04 and mplayer rc1

ruskie (ruzkie) wrote :

status?

Mario Limonciello (superm1) wrote :

mplayer (2:1.0~rc1-0ubuntu12) gutsy; urgency=low

  * Add 01_default_config.dpatch.
    - Sets screensaver by default for non gmplayer.
      (LP: #95038), (LP: #139770)
    - Sets xv as video output for gmplayer and mplayer.
      (LP: #65165), (LP: #146307)
  * Add dpatch to build-depends in debian/control.
  * Add dpatch support to debian/rules.

 -- Mario Limonciello <email address hidden> Mon, 08 Oct 2007 01:07:53 -0500

Changed in mplayer:
status: Confirmed → Fix Released
José Cabo (folcwine) on 2008-07-20
Changed in mplayer:
status: New → Invalid
Guy Taylor (thebiggerguy) wrote :

Same thing in Karmic (x64)

w1zard (pacehead) wrote :

This bug appears to have regressed in the latest releases - specifically Lucid in my case, but potentially Karmic as well, judging by the comment above.

Changing the default video out away from xmga fixes the issue. I'm assuming this default setting is no longer being applied for whatever reason?

Changed in mplayer (Ubuntu):
status: Fix Released → Confirmed
Reinhard Tartler (siretart) wrote :

a better explanation of this issue can be found in #537740

summary: - default video output is xmga
+ gmplayer does not fall back to other vo modules if the first one fails
description: updated
Changed in mplayer (Ubuntu):
status: Confirmed → Triaged
Changed in mplayer:
status: Unknown → Confirmed
Changed in mplayer (Debian):
status: Unknown → New
Changed in mplayer (Debian):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mplayer - 2:1.0~rc4~try1.dsfg1-1ubuntu1

---------------
mplayer (2:1.0~rc4~try1.dsfg1-1ubuntu1) maverick; urgency=low

  * merge from debian, remaining changes:
    - build depend against, lame, x264, xvid
  * debian/patches/60eval-api.patch, backport patch from upstream to
    unbreak compilation for eval.h move not yet in 0.6
  * gmplayer is gone now, please see smplayer as alternative frontend.
    LP: #503537, #493088, #467534, #467524, #460326, #390399, #285570,
        #208680, #118709, #513065, #459595, #455913, #179918, #65165.

mplayer (2:1.0~rc4~try1.dsfg1-1) experimental; urgency=low

  * enable the mencoder package
  * sort build depends alphabetically
  * enable dvdnav support, Closes: #582508, #488226, LP: #611749
  * prepare new upload
  * no longer build mplayer-gui, it doesn't build anymore with shared
    swscale
 -- Reinhard Tartler <email address hidden> Sat, 07 Aug 2010 12:03:56 -0400

Changed in mplayer (Ubuntu):
status: Triaged → Fix Released
Changed in mplayer (Debian):
status: Confirmed → Fix Released
Changed in mplayer (Debian):
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.