udevd: failed to execute '/lib/udev/mtp-probe'

Bug #915368 reported by Sworddragon on 2012-01-12
66
This bug affects 15 people
Affects Status Importance Assigned to Milestone
libmtp (Debian)
New
Unknown
libmtp (Ubuntu)
Low
Unassigned

Bug Description

I'm using Ubuntu 12.04 dev with udev 175-0ubuntu3. If I boot my ystem I'm getting some warnings from udev:

udevd[527]: failed to execute '/lib/udev/mtp-probe' 'mtp-probe /sys/devices/pci0000:00/0000:00:02.0/usb2/2-4 2 3': No such file or directory
udevd[528]: failed to execute '/lib/udev/mtp-probe' 'mtp-probe /sys/devices/pci0000:00/0000:00:02.0/usb2/2-5 2 4': No such file or directory
udevd[529]: failed to execute '/lib/udev/mtp-probe' 'mtp-probe /sys/devices/pci0000:00/0000:00:02.0/usb2/2-3 2 2': No such file or directory

My system is a minimalistic system wih no recommended packages and all seems to be working fine. If this messages are just non-critical warnings they should be in my opinion logged somewhere instead of be printed during the boot process.

Martin Pitt (pitti) on 2012-01-12
affects: udev (Ubuntu) → libmtp (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libmtp (Ubuntu):
status: New → Confirmed
Sworddragon (sworddragon) wrote :

I have removed the duplicate status because the old ticket is already fixed but the problem still exists.

robegue (r087r70) wrote :

resolved by installing libmtp-runtime

Sworddragon (sworddragon) wrote :

The problem is that libmtp-runtime is not a dependency so it can be missing on some systems.

Sworddragon (sworddragon) wrote :

I'm now using Ubuntu 13.10 dev with udev 202-0ubuntu7 and I doesn't see the warnings anymore on booting.

Changed in libmtp (Ubuntu):
status: Confirmed → Fix Released
Sworddragon (sworddragon) wrote :

It seems that this bug isn't really fixed but the behavior has changed. Instead of seeing the warning 3 times on booting it is randomly appearing 0-3 times.

Changed in libmtp (Ubuntu):
status: Fix Released → Confirmed
Rolf Leggewie (r0lf) wrote :

For those that are affected by this bug, can you please report whether you have the package libmtp-runtime installed or not? "dpkg -l libmtp-runtime" should tell you. Installing the package resolved the issue for me.

Sworddragon (sworddragon) wrote :

This was indirectly answered in a previous post:

"The problem is that libmtp-runtime is not a dependency so it can be missing on some systems."

No, libmtp-runtime is not installed on my system. But there are some possible solutions:

1. libmtp-runtime will get a dependency.
2. The warning will be suppressed and only logged in this case (if this is easily possible with udev).
3. The problem gets fixed on another way.

Redsandro (redsandro) wrote :

I have this problem on Ubuntu 13.10 when I try do force a disk check by touching forcefsck on the drives.

failed to execute '/lib/udev/mtp-probe' [numbers]

Rolf Leggewie (r0lf) on 2014-02-11
Changed in libmtp (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Changed in libmtp (Debian):
status: Unknown → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.