iperf2 long time run on 40Gb/s NIC crashes

Bug #1771283 reported by Ike Panhc on 2018-05-15
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
iperf (Debian)
Fix Released
Unknown
iperf (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Artful
Undecided
Unassigned
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned

Bug Description

[Impact]
Running iperf2 across 40GB connection for a long period of time causes iperf to segfault.

[Test]
ubuntu@recht:~$ iperf -c 192.168.121.2 -P10 -w 130k -t 3600
------------------------------------------------------------
Client connecting to 192.168.121.2, TCP port 5001
TCP window size: 254 KByte (WARNING: requested 127 KByte)
------------------------------------------------------------
[ 10] local 192.168.121.3 port 40756 connected with 192.168.121.2 port 5001
[ 12] local 192.168.121.3 port 40760 connected with 192.168.121.2 port 5001
[ 11] local 192.168.121.3 port 40758 connected with 192.168.121.2 port 5001
[ 8] local 192.168.121.3 port 40754 connected with 192.168.121.2 port 5001
[ 9] local 192.168.121.3 port 40752 connected with 192.168.121.2 port 5001
[ 7] local 192.168.121.3 port 40750 connected with 192.168.121.2 port 5001
[ 6] local 192.168.121.3 port 40746 connected with 192.168.121.2 port 5001
[ 5] local 192.168.121.3 port 40748 connected with 192.168.121.2 port 5001
[ 3] local 192.168.121.3 port 40744 connected with 192.168.121.2 port 5001
[ 4] local 192.168.121.3 port 40742 connected with 192.168.121.2 port 5001
Segmentation fault (core dumped)

[Fix]
This is fixed latest iperf2
git clone https://git.code.sf.net/p/iperf2/code

commit fce3254827eb05fee56aa6a2e9f0d69cbe599a69
Author: Robert McMahon <email address hidden>
Date: Sat Jun 2 11:48:22 2018 -0700

    fix for: iperf2 long time run on 40Gb/s NIC crashes, found ubuntu Bug #1771283, reported by Ike Panhc, increase format support to Peta as well

[Regression Potential]
This patch was tested on ARM64 Cavium ThunderX2 systems and no regressions were found.
iperf calculates the sum of all bytes transferred and prints this sum like 'Sum: 100Mbytes'. For example if total data transferred was (simplified) 100,000,000 Bytes, iperf would print Sum: 100 Mbytes. The suffix Mbytes is stored in a static array and it uses the number of time it had to divide the sum by 1000 to determine the index to that array. iperf only accounted for Sums up to GBytes, causing it to segfault on Sums of +TBytes. Currently the patch extends this array to Peta Bytes, but you will segfault again if the sum is in the order of Exabyte or larger. This might be achievable by using 100G connections between server-client (Mellanox 100G nic & switch) and running iperf at max throughput for a long long long periods of time.

Manoj Iyer (manjo) wrote :

Is your packet size bigger than the MTU size? Could you use jumbo and see if you still see this issue?

Manoj Iyer (manjo) wrote :

-- Core dump with gdb --
Using host libthread_db library "/lib/aarch64-linux-gnu/libthread_db.so.1".
Core was generated by `iperf -c 192.168.120.2 -P10 -w 130k -t 3600'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0 strlen () at ../sysdeps/aarch64/strlen.S:94
94 ../sysdeps/aarch64/strlen.S: No such file or directory.
[Current thread is 1 (Thread 0xffff827fc1d0 (LWP 3788))]
(gdb) bt
#0 strlen () at ../sysdeps/aarch64/strlen.S:94
#1 0x0000ffff9b2caf18 in _IO_vfprintf_internal (s=s@entry=0xffff827fb5f8,
    format=format@entry=0xaaaae1c3b0a8 "%4.0f %s", ap=...) at vfprintf.c:1643
#2 0x0000ffff9b361a64 in ___vsnprintf_chk (
    s=0xaaaae1c4e280 <buffer> "4227448246536 ", maxlen=<optimized out>,
    flags=1, slen=<optimized out>, format=0xaaaae1c3b0a8 "%4.0f %s", args=...)
    at vsnprintf_chk.c:63
#3 0x0000ffff9b361980 in ___snprintf_chk (s=<optimized out>,
    maxlen=<optimized out>, flags=<optimized out>, slen=<optimized out>,
    format=<optimized out>) at snprintf_chk.c:34
#4 0x0000aaaae1c310d0 in ?? ()
#5 0x0000000000000001 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)
(gdb)

Manoj Iyer (manjo) wrote :

byte_snprintf() calls snprintf() with a bad format pointer and snprintf() segfaults. The root cause of the bad pointer is very elusive because there is so much information being printed. Further debug needed to find out the root cause.

-- with GDB and debug --
(gdb) bt
#0 strlen () at ../sysdeps/aarch64/strlen.S:94
#1 0x0000ffffa35b5f18 in _IO_vfprintf_internal (s=s@entry=0xffff99ffa578,
    format=format@entry=0xaaaad52878f0 "%4.0f %s", ap=...) at vfprintf.c:1643
#2 0x0000ffffa364ca64 in ___vsnprintf_chk (
    s=s@entry=0xaaaad529a280 <buffer> "4235479613440 ",
    maxlen=<optimized out>, maxlen@entry=32, flags=flags@entry=1,
    slen=slen@entry=18446744073709551615, format=0xaaaad52878f0 "%4.0f %s",
    args=...) at vsnprintf_chk.c:63
#3 0x0000ffffa364c980 in ___snprintf_chk (
    s=s@entry=0xaaaad529a280 <buffer> "4235479613440 ",
    maxlen=maxlen@entry=32, flags=flags@entry=1,
    slen=slen@entry=18446744073709551615, format=<optimized out>)
    at snprintf_chk.c:34
#4 0x0000aaaad5283cb8 in snprintf (__fmt=<optimized out>, __n=32,
    __s=0xaaaad529a280 <buffer> "4235479613440 ")
    at /usr/include/aarch64-linux-gnu/bits/stdio2.h:64
#5 byte_snprintf (
    outString=outString@entry=0xaaaad529a280 <buffer> "4235479613440 ",
    inLen=inLen@entry=32, inNum=<optimized out>, inFormat=<optimized out>)
    at stdio.c:247
#6 0x0000aaaad527d928 in reporter_multistats (stats=0xaaab104a38e0)
    at ReportDefault.c:205
#7 0x0000aaaad527f264 in reporter_print (stats=0xaaab104a3850,
    type=type@entry=16, end=end@entry=1) at Reporter.c:1154
#8 0x0000aaaad527f628 in reporter_handle_multiple_reports (
    reporthdr=reporthdr@entry=0xaaab104a37c0,
    stats=stats@entry=0xffffa03910a8, force=force@entry=1) at Reporter.c:996
#9 0x0000aaaad527f938 in reporter_condprintstats (stats=0xffffa0391018,
    multireport=0xaaab104a37c0, force=1) at Reporter.c:1075
#10 0x0000aaaad527fd6c in reporter_process_report (reporthdr=0xffffa0391010)
    at Reporter.c:759
#11 0x0000aaaad527fdfc in reporter_process_report (reporthdr=0xffffa04cb010)
    at Reporter.c:719
#12 0x0000aaaad527fdfc in reporter_process_report (reporthdr=0xffffa01ba010)
    at Reporter.c:719
#13 0x0000aaaad527fdfc in reporter_process_report (reporthdr=0xffffa0080010)
    at Reporter.c:719
#14 0x0000aaaad527fdfc in reporter_process_report (
    reporthdr=reporthdr@entry=0xffffa02f4010) at Reporter.c:719
#15 0x0000aaaad527ff10 in reporter_spawn (thread=0xaaab104a5cd0)
    at Reporter.c:627
#16 0x0000aaaad52843cc in thread_run_wrapper (paramPtr=0xaaab104a5cd0)
    at Thread.c:247
#17 0x0000ffffa36ce088 in start_thread (arg=0xffffc669f3ff)
    at pthread_create.c:463
#18 0x0000ffffa363e4ec in thread_start ()
    at ../sysdeps/unix/sysv/linux/aarch64/clone.S:78

Manoj Iyer (manjo) wrote :

After fixing that bug iperf no longer seg faults. I will submit an SRU for B/A/X releases.

ubuntu@recht:~/iperf-2.0.10+dfsg1$ src/iperf -c 192.168.120.2 -P10 -w 130k -t 3600
------------------------------------------------------------
Client connecting to 192.168.120.2, TCP port 5001
TCP window size: 254 KByte (WARNING: requested 127 KByte)
------------------------------------------------------------
[ 11] local 192.168.120.3 port 58206 connected with 192.168.120.2 port 5001
[ 4] local 192.168.120.3 port 58192 connected with 192.168.120.2 port 5001
[ 5] local 192.168.120.3 port 58194 connected with 192.168.120.2 port 5001
[ 3] local 192.168.120.3 port 58196 connected with 192.168.120.2 port 5001
[ 7] local 192.168.120.3 port 58198 connected with 192.168.120.2 port 5001
[ 6] local 192.168.120.3 port 58200 connected with 192.168.120.2 port 5001
[ 9] local 192.168.120.3 port 58202 connected with 192.168.120.2 port 5001
[ 10] local 192.168.120.3 port 58204 connected with 192.168.120.2 port 5001
[ 12] local 192.168.120.3 port 58208 connected with 192.168.120.2 port 5001
[ 8] local 192.168.120.3 port 58210 connected with 192.168.120.2 port 5001
[ ID] Interval Transfer Bandwidth
[ 11] 0.0-3600.0 sec 157 GBytes 376 Mbits/sec
[ 4] 0.0-3600.0 sec 986 GBytes 2.35 Gbits/sec
[ 5] 0.0-3600.0 sec 981 GBytes 2.34 Gbits/sec
[ 3] 0.0-3600.0 sec 113 GBytes 269 Mbits/sec
[ 7] 0.0-3600.0 sec 495 GBytes 1.18 Gbits/sec
[ 6] 0.0-3600.0 sec 493 GBytes 1.18 Gbits/sec
[ 9] 0.0-3600.0 sec 257 GBytes 614 Mbits/sec
[ 10] 0.0-3600.0 sec 112 GBytes 268 Mbits/sec
[ 12] 0.0-3600.0 sec 113 GBytes 270 Mbits/sec
[ 8] 0.0-3600.0 sec 238 GBytes 568 Mbits/sec
[SUM] 0.0-3600.0 sec 4236189630464 bits 9.41 Gbits/sec

Manoj Iyer (manjo) wrote :

Available in PPA: ppa:manjo/lp1771283

Robert J McMahon (rjmcmahon) wrote :

Can you share the bug fix? I'd like to make sure it gets committed in to the iperf2 repository.

Thanks,
Bob

Manoj Iyer (manjo) wrote :

Robert, could you pls give me the git repo or source for iperf? Or would a debdiff of the version in ubuntu bionic work just fine?

Robert J McMahon (rjmcmahon) wrote :

Either way works. The code repository is on sourceforge.

https://sourceforge.net/projects/iperf2/?source=directory

Note: We just released 2.0.11 and I wonder if this bug is there as well.

Bob

Manoj Iyer (manjo) wrote :
Download full text (3.6 KiB)

Robert,

Please review and consider this patch to iperf to fix the segfault. Looks like in function byte_snprintf() when calculating SUM, where SUM is in terabyte, we go past the kLabel_Byte/kLabel_bit array limit (by increment of conv past kConv_Giga) and this causes iperf to segfault because suffix is pointing past the array bounds. The attached patch addresses this issue.

-- Before patch --
$ iperf -c 192.168.120.2 -P10 -w 130k -t 1200
------------------------------------------------------------
Client connecting to 192.168.120.2, TCP port 5001
TCP window size: 254 KByte (WARNING: requested 127 KByte)
------------------------------------------------------------
[ 12] local 192.168.120.3 port 47668 connected with 192.168.120.2 port 5001
[ 10] local 192.168.120.3 port 47664 connected with 192.168.120.2 port 5001
[ 11] local 192.168.120.3 port 47666 connected with 192.168.120.2 port 5001
[ 8] local 192.168.120.3 port 47662 connected with 192.168.120.2 port 5001
[ 5] local 192.168.120.3 port 47656 connected with 192.168.120.2 port 5001
[ 4] local 192.168.120.3 port 47650 connected with 192.168.120.2 port 5001
[ 6] local 192.168.120.3 port 47654 connected with 192.168.120.2 port 5001
[ 9] local 192.168.120.3 port 47660 connected with 192.168.120.2 port 5001
[ 7] local 192.168.120.3 port 47658 connected with 192.168.120.2 port 5001
[ 3] local 192.168.120.3 port 47652 connected with 192.168.120.2 port 5001
 [ ID] Interval Transfer Bandwidth
[ 12] 0.0-1200.0 sec 73.3 GBytes 525 Mbits/sec
[ 10] 0.0-1200.0 sec 164 GBytes 1.17 Gbits/sec
[ 11] 0.0-1200.0 sec 219 GBytes 1.57 Gbits/sec
[ 8] 0.0-1200.0 sec 73.3 GBytes 525 Mbits/sec
[ 5] 0.0-1200.0 sec 164 GBytes 1.18 Gbits/sec
[ 4] 0.0-1200.0 sec 165 GBytes 1.18 Gbits/sec
[ 6] 0.0-1200.0 sec 109 GBytes 784 Mbits/sec
[ 9] 0.0-1200.0 sec 165 GBytes 1.18 Gbits/sec
[ 7] 0.0-1200.0 sec 109 GBytes 783 Mbits/sec
[ 3] 0.0-1200.0 sec 73.3 GBytes 525 Mbits/sec
Segmentation fault (core dumped)

-- After patch --
$ src/iperf -c 192.168.120.2 -P10 -w 130k -t 1200
------------------------------------------------------------
Client connecting to 192.168.120.2, TCP port 5001
TCP window size: 254 KByte (WARNING: requested 127 KByte)
------------------------------------------------------------
[ 12] local 192.168.120.3 port 47626 connected with 192.168.120.2 port 5001
[ 8] local 192.168.120.3 port 47616 connected with 192.168.120.2 port 5001
[ 10] local 192.168.120.3 port 47622 connected with 192.168.120.2 port 5001
[ 3] local 192.168.120.3 port 47610 connected with 192.168.120.2 port 5001
[ 9] local 192.168.120.3 port 47620 connected with 192.168.120.2 port 5001
[ 4] local 192.168.120.3 port 47608 connected with 192.168.120.2 port 5001
[ 7] local 192.168.120.3 port 47614 connected with 192.168.120.2 port 5001
[ 11] local 192.168.120.3 port 47624 connected with 192.168.120.2 port 5001
[ 5] local 192.168.120.3 port 47612 connected with 192.168.120.2 port 5001
[ 6] local 192.168.120.3 port 47618 connected with 192.168.120.2 port 5001
[ ID] Interval Transfer Bandwidth
[ 3] 0.0-1200.0 sec 142 GBytes 1.02 Gbits/sec
[ 9] 0.0-1200.0 ...

Read more...

The attachment "fix segfault in iperf" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Robert J McMahon (rjmcmahon) wrote :

Thanks for finding this. I'm thinking we add support for both Terabytes and Petabytes while fixing this bug. Thoughts?

Bob

Robert J McMahon (rjmcmahon) wrote :

Attached is the likely fix I'll commit in to the source forge repository.

Bob

Robert J McMahon (rjmcmahon) wrote :

Thanks all for finding this. Here is the commit to iperf which should address this as well as increase format support up to Peta. It will be part of the iperf 2.0.12 release.

https://sourceforge.net/p/iperf2/code/ci/fce3254827eb05fee56aa6a2e9f0d69cbe599a69/

Bob

Manoj Iyer (manjo) wrote :

Thank you for applying that, I will SRU that to Bionic/Artful/Xenial for Ubuntu.

Manoj Iyer (manjo) wrote :

Please review and consider this debdiff to iperf that fixes this iperf bug for cosmic.

A build with this patch is available in ppa:manjo/iperf

dann frazier (dannf) wrote :

Thanks Manoj & Bob - I'll take a look at sponsoring your upload. Do you mind filing a bug in Debian as well, and linking that bug to this one using "Also affects distribution/package"? That way we'll know when we can drop our diff & resync w/ Debian.

Manoj Iyer (manjo) wrote :

Please review and consider this debdiff to iperf that fixes this iperf bug for Bionic

Manoj Iyer (manjo) wrote :

Please review and consider this debdiff to iperf that fixes this iperf bug for Artful

Manoj Iyer (manjo) wrote :

Please review and consider this debdiff to iperf that fixes this iperf bug for Xenial

Changed in iperf (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package iperf - 2.0.10+dfsg1-1ubuntu1

---------------
iperf (2.0.10+dfsg1-1ubuntu1) cosmic; urgency=medium

  * fix for: iperf2 long time run on 40Gb/s NIC crashes (LP: #1771283)

 -- Manoj Iyer <email address hidden> Mon, 04 Jun 2018 18:10:31 -0500

Changed in iperf (Ubuntu Cosmic):
status: New → Fix Released
Manoj Iyer (manjo) on 2018-06-13
description: updated
dann frazier (dannf) on 2018-06-13
Changed in iperf (Ubuntu Bionic):
status: New → In Progress
Changed in iperf (Ubuntu Xenial):
status: New → In Progress
Changed in iperf (Ubuntu Artful):
status: New → In Progress
Manoj Iyer (manjo) on 2018-06-13
description: updated
Manoj Iyer (manjo) on 2018-06-13
description: updated

Hello Ike, or anyone else affected,

Accepted iperf into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/iperf/2.0.10+dfsg1-1ubuntu0.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in iperf (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Changed in iperf (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed-artful
Brian Murray (brian-murray) wrote :

Hello Ike, or anyone else affected,

Accepted iperf into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/iperf/2.0.10+dfsg1-1ubuntu0.17.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in iperf (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
Brian Murray (brian-murray) wrote :

Hello Ike, or anyone else affected,

Accepted iperf into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/iperf/2.0.5+dfsg1-2ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Manoj Iyer (manjo) wrote :

-- Bionic verification --
ubuntu@starbuck:~$ cat /etc/issue
Ubuntu 18.04 LTS \n \l

ubuntu@starbuck:~$ apt policy iperf
iperf:
  Installed: 2.0.10+dfsg1-1ubuntu0.18.04.1
  Candidate: 2.0.10+dfsg1-1ubuntu0.18.04.1
  Version table:
 *** 2.0.10+dfsg1-1ubuntu0.18.04.1 500
        500 http://ports.ubuntu.com/ubuntu-ports bionic-proposed/universe arm64 Packages
        100 /var/lib/dpkg/status
     2.0.10+dfsg1-1 500
        500 http://ports.ubuntu.com/ubuntu-ports bionic/universe arm64 Packages
ubuntu@starbuck:~$

ubuntu@starbuck:~$ iperf -c 192.168.120.2 -P10 -w 130k -t 1200
------------------------------------------------------------
Client connecting to 192.168.120.2, TCP port 5001
TCP window size: 254 KByte (WARNING: requested 127 KByte)
------------------------------------------------------------
[ 12] local 192.168.120.3 port 47238 connected with 192.168.120.2 port 5001
[ 11] local 192.168.120.3 port 47236 connected with 192.168.120.2 port 5001
[ 9] local 192.168.120.3 port 47232 connected with 192.168.120.2 port 5001
[ 10] local 192.168.120.3 port 47234 connected with 192.168.120.2 port 5001
[ 3] local 192.168.120.3 port 47220 connected with 192.168.120.2 port 5001
[ 5] local 192.168.120.3 port 47222 connected with 192.168.120.2 port 5001
[ 6] local 192.168.120.3 port 47224 connected with 192.168.120.2 port 5001
[ 8] local 192.168.120.3 port 47228 connected with 192.168.120.2 port 5001
[ 7] local 192.168.120.3 port 47230 connected with 192.168.120.2 port 5001
[ 4] local 192.168.120.3 port 47226 connected with 192.168.120.2 port 5001
[ ID] Interval Transfer Bandwidth
[ 12] 0.0-1200.0 sec 343 GBytes 2.46 Gbits/sec
[ 11] 0.0-1200.0 sec 300 GBytes 2.15 Gbits/sec
[ 9] 0.0-1200.0 sec 270 GBytes 1.93 Gbits/sec
[ 10] 0.0-1200.0 sec 347 GBytes 2.49 Gbits/sec
[ 3] 0.0-1200.0 sec 147 GBytes 1.05 Gbits/sec
[ 5] 0.0-1200.0 sec 172 GBytes 1.23 Gbits/sec
[ 6] 0.0-1200.0 sec 254 GBytes 1.82 Gbits/sec
[ 8] 0.0-1200.0 sec 147 GBytes 1.05 Gbits/sec
[ 7] 0.0-1200.0 sec 171 GBytes 1.23 Gbits/sec
[ 4] 0.0-1200.0 sec 251 GBytes 1.79 Gbits/sec
[SUM] 0.0-1200.0 sec 2.34 TBytes 17.2 Gbits/sec
ubuntu@starbuck:~$

Manoj Iyer (manjo) on 2018-06-29
tags: added: verification-done-bionic
removed: verification-needed-bionic
Manoj Iyer (manjo) wrote :

-- Xenial verification --
ubuntu@starbuck:~$ cat /etc/issue
Ubuntu 16.04.4 LTS \n \l

ubuntu@starbuck:~$ apt policy iperf
iperf:
  Installed: 2.0.5+dfsg1-2ubuntu0.1
  Candidate: 2.0.5+dfsg1-2ubuntu0.1
  Version table:
 *** 2.0.5+dfsg1-2ubuntu0.1 500
        500 http://ports.ubuntu.com/ubuntu-ports xenial-proposed/universe arm64 Packages
        100 /var/lib/dpkg/status
     2.0.5+dfsg1-2 500
        500 http://ports.ubuntu.com/ubuntu-ports xenial/universe arm64 Packages
ubuntu@starbuck:~$

ubuntu@starbuck:~$ iperf -c 192.168.120.2 -P10 -w 130k -t 1200
------------------------------------------------------------
Client connecting to 192.168.120.2, TCP port 5001
TCP window size: 260 KByte (WARNING: requested 130 KByte)
------------------------------------------------------------
[ 11] local 192.168.120.3 port 41638 connected with 192.168.120.2 port 5001
[ 4] local 192.168.120.3 port 41620 connected with 192.168.120.2 port 5001
[ 5] local 192.168.120.3 port 41622 connected with 192.168.120.2 port 5001
[ 6] local 192.168.120.3 port 41624 connected with 192.168.120.2 port 5001
[ 3] local 192.168.120.3 port 41626 connected with 192.168.120.2 port 5001
[ 8] local 192.168.120.3 port 41628 connected with 192.168.120.2 port 5001
[ 10] local 192.168.120.3 port 41632 connected with 192.168.120.2 port 5001
[ 9] local 192.168.120.3 port 41630 connected with 192.168.120.2 port 5001
[ 7] local 192.168.120.3 port 41634 connected with 192.168.120.2 port 5001
[ 12] local 192.168.120.3 port 41636 connected with 192.168.120.2 port 5001
[ ID] Interval Transfer Bandwidth
[ 11] 0.0-1200.0 sec 347 GBytes 2.48 Gbits/sec
[ 4] 0.0-1200.0 sec 148 GBytes 1.06 Gbits/sec
[ 5] 0.0-1200.0 sec 172 GBytes 1.23 Gbits/sec
[ 6] 0.0-1200.0 sec 285 GBytes 2.04 Gbits/sec
[ 3] 0.0-1200.0 sec 247 GBytes 1.77 Gbits/sec
[ 8] 0.0-1200.0 sec 148 GBytes 1.06 Gbits/sec
[ 10] 0.0-1200.0 sec 284 GBytes 2.03 Gbits/sec
[ 9] 0.0-1200.0 sec 172 GBytes 1.23 Gbits/sec
[ 7] 0.0-1200.0 sec 307 GBytes 2.20 Gbits/sec
[ 12] 0.0-1200.0 sec 291 GBytes 2.08 Gbits/sec
[SUM] 0.0-1200.0 sec 2.35 TBytes 17.2 Gbits/sec
ubuntu@starbuck:~$

tags: added: verification-done-xenial
removed: verification-needed-xenial
Manoj Iyer (manjo) wrote :

-- Artful verification --
ubuntu@starbuck:~$ cat /etc/issue
Ubuntu 17.10 \n \l

ubuntu@starbuck:~$ apt policy iperf
iperf:
  Installed: 2.0.10+dfsg1-1ubuntu0.17.10.1
  Candidate: 2.0.10+dfsg1-1ubuntu0.17.10.1
  Version table:
 *** 2.0.10+dfsg1-1ubuntu0.17.10.1 500
        500 http://ports.ubuntu.com/ubuntu-ports artful-proposed/universe arm64 Packages
        100 /var/lib/dpkg/status
     2.0.10+dfsg1-1 500
        500 http://ports.ubuntu.com/ubuntu-ports artful/universe arm64 Packages
ubuntu@starbuck:~$

ubuntu@starbuck:~$ iperf -c 192.168.120.2 -P10 -w 130k -t 1200
------------------------------------------------------------
Client connecting to 192.168.120.2, TCP port 5001
TCP window size: 254 KByte (WARNING: requested 127 KByte)
------------------------------------------------------------
[ 12] local 192.168.120.3 port 52618 connected with 192.168.120.2 port 5001
[ 11] local 192.168.120.3 port 52614 connected with 192.168.120.2 port 5001
[ 5] local 192.168.120.3 port 52602 connected with 192.168.120.2 port 5001
[ 10] local 192.168.120.3 port 52616 connected with 192.168.120.2 port 5001
[ 6] local 192.168.120.3 port 52606 connected with 192.168.120.2 port 5001
[ 3] local 192.168.120.3 port 52600 connected with 192.168.120.2 port 5001
[ 8] local 192.168.120.3 port 52608 connected with 192.168.120.2 port 5001
[ 7] local 192.168.120.3 port 52610 connected with 192.168.120.2 port 5001
[ 9] local 192.168.120.3 port 52612 connected with 192.168.120.2 port 5001
[ 4] local 192.168.120.3 port 52604 connected with 192.168.120.2 port 5001
[ ID] Interval Transfer Bandwidth
[ 12] 0.0-1200.0 sec 156 GBytes 1.12 Gbits/sec
[ 11] 0.0-1200.0 sec 316 GBytes 2.26 Gbits/sec
[ 5] 0.0-1200.0 sec 347 GBytes 2.48 Gbits/sec
[ 10] 0.0-1200.0 sec 165 GBytes 1.18 Gbits/sec
[ 6] 0.0-1200.0 sec 227 GBytes 1.62 Gbits/sec
[ 3] 0.0-1200.0 sec 266 GBytes 1.91 Gbits/sec
[ 8] 0.0-1200.0 sec 161 GBytes 1.15 Gbits/sec
[ 7] 0.0-1200.0 sec 153 GBytes 1.10 Gbits/sec
[ 9] 0.0-1200.0 sec 304 GBytes 2.18 Gbits/sec
[ 4] 0.0-1200.0 sec 319 GBytes 2.28 Gbits/sec
[SUM] 0.0-1200.0 sec 2.36 TBytes 17.3 Gbits/sec
ubuntu@starbuck:~$

tags: added: verification-done verification-done-artful
removed: verification-needed verification-needed-artful
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package iperf - 2.0.10+dfsg1-1ubuntu0.18.04.1

---------------
iperf (2.0.10+dfsg1-1ubuntu0.18.04.1) bionic; urgency=medium

  * fix for: iperf2 long time run on 40Gb/s NIC crashes (LP: #1771283)

 -- Manoj Iyer <email address hidden> Tue, 05 Jun 2018 11:48:25 -0500

Changed in iperf (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for iperf has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package iperf - 2.0.10+dfsg1-1ubuntu0.17.10.1

---------------
iperf (2.0.10+dfsg1-1ubuntu0.17.10.1) artful; urgency=medium

  * fix for: iperf2 long time run on 40Gb/s NIC crashes (LP: #1771283)

 -- Manoj Iyer <email address hidden> Tue, 05 Jun 2018 12:01:28 -0500

Changed in iperf (Ubuntu Artful):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package iperf - 2.0.5+dfsg1-2ubuntu0.1

---------------
iperf (2.0.5+dfsg1-2ubuntu0.1) xenial; urgency=medium

  * fix for: iperf2 long time run on 40Gb/s NIC crashes (LP: #1771283)

 -- Manoj Iyer <email address hidden> Tue, 05 Jun 2018 12:07:04 -0500

Changed in iperf (Ubuntu Xenial):
status: Fix Committed → Fix Released
Changed in iperf (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.