import -border ignores borders

Bug #159428 reported by Akkana Peck on 2007-11-02
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ImageMagick
In Progress
Undecided
Unassigned
imagemagick (Debian)
Confirmed
Unknown
imagemagick (Ubuntu)
Undecided
broucaries

Bug Description

Binary package hint: imagemagick

In gutsy, imagemagick (not graphicsmagick):

import -border foo.jpg
click on any window
view the resulting foo.jpg
Notice no borders! Tried in both gnome or openbox.

Just in case it was an argument parsing problem, I tried import --border, but that didn't get the borders either. It does seem to expose a different bug: it grabs twice (though only producing one foo.jpg, and no, it doesn't produce a file called --border the first time).

import -border worked in edgy and earlier, and I'm pretty sure it worked in feisty too.

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10?

Changed in imagemagick:
status: New → Incomplete
Akkana Peck (akkzilla) wrote :

I don't have 8.10 yet, but in hardy, -border still doesn't do anything obvious. -frame does include the window manager borders, however, which was what I was after. I'm not at all clear on what -border is supposed to do (if not that) so I don't know if it's working or not.

Nelson A. de Oliveira (naoliv) wrote :

hardy and intrepid both have the same version of ImageMagick (so probably you will see the same problem if you update your system).
Even using version 6.4.5.4 (Debian experimental) it seems that the problem is still there. I will take a better look at it (and forward upstream, if necessary).

Changed in imagemagick:
status: Incomplete → Confirmed
Akkana Peck (akkzilla) wrote :

Thanks -- and it may turn out to be just a misunderstanding on my part of what "image borders" mean in the import man page (-frame is probably what I should have been using all along, but now I'm curious about -border).

Changed in imagemagick (Debian):
status: Unknown → Confirmed

Upstream ask for help for documentation

Changed in imagemagick (Ubuntu):
assignee: nobody → broucaries (roucaries-bastien+bugs)
Changed in imagemagick:
status: New → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.