Debian GNU/Linux

glstreamer0.10-gl disapeared in hardy

Reported by Guillaume Bottex on 2008-05-07
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gstreamer0.10 (Debian)
Fix Released
Unknown
gstreamer0.10 (Ubuntu)
Wishlist
Unassigned

Bug Description

Ubuntu 8.04

After upgrading from 7.10 to 8.04 the package gstreamer0.10-gl disappeared in the repository and was uninstalled during the upgarde process.
The problem is that on my computer the xvimagesink pipleline deos not work and the ximagesink pipeline give a non-smoothed image and is very slow.

So the best solution for me was to use the glimagesink pipeline, but now I connot do it anymore.

Emilio Pozuelo Monfort (pochu) wrote :

From gst-plugins-bad0.10's changelog:

    + debian/control.in,
      debian/build-deps.in,
      debian/rules:
      - Drop the OpenGL plugin. This will go to a new source package named
        gst-plugins-gl once we have mesa >= 7.1 somewhere.

Changed in gstreamer0.10:
importance: Undecided → Wishlist
status: New → Confirmed
Changed in gstreamer0.10:
status: Unknown → New
Changed in gstreamer0.10:
status: Confirmed → Triaged

That's nice. What do people who need to use gl output do in the meantime other than mplayer -vo gl2 ?

David Jaša (dejv) wrote :

Well, glimagesink is still missing in 9.04 as well...

Takmadeus (takmadeus) wrote :

Still missing in karmic.... is it so hard to include in karmic?

Daniel Ellis (danellisuk) wrote :

Still missing in Ubuntu 10.04 (Lucid) and so far this is still missing in Maverick (the beta is due next week).

What needs to be done to include this? Is there someone this should be assigned to? Or is it something I could assist with?

Daniel Ellis (danellisuk) wrote :

I can see from the remote bug watch (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=464905) that this package has now reached debian experimental. I found the package here: http://packages.debian.org/experimental/gstreamer0.10-plugins-gl.

Anyone trying to use the ATI XvBA extension for VA-API can't use accelerated gstreamer output without gstreamer0.10-plugins-gl

It's available in Debian's experimental branch since 2009:

Date: Thu, 18 Jun 2009 13:35:45 +0200
Source: gst-plugins-gl0.10
Binary: gstreamer0.10-plugins-gl-doc libgstreamer-plugins-gl0.10-0 libgstreamer-plugins-gl0.10-dev gstreamer0.10-plugins-gl gstreamer0.10-plugins-gl-dbg
Architecture: source all amd64
Version: 0.10.1-1
Distribution: experimental
Urgency: low
Maintainer: Maintainers of GStreamer packages <email address hidden>
Changed-By: Sebastian Dröge <email address hidden>
Description:
 gstreamer0.10-plugins-gl - GStreamer plugins from the "gl" set
 gstreamer0.10-plugins-gl-dbg - GStreamer plugins from the "gl" set
 gstreamer0.10-plugins-gl-doc - GStreamer documentation for plugins from the "gl" set
 libgstreamer-plugins-gl0.10-0 - GStreamer libraries from the "gl" set
 libgstreamer-plugins-gl0.10-dev - GStreamer development files for libraries from the "gl" set
Closes: 464905

You can download the .deb files from:
* http://packages.debian.org/experimental/i386/libgstreamer-plugins-gl0.10-0/download
* http://packages.debian.org/experimental/i386/gstreamer0.10-plugins-gl/download

They seem to work fine under Natty Beta 2.

Changed in gstreamer0.10 (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.