Debian GNU/Linux

"Disable touchpad while typing" should ignore modifier keys when monitoring keyboard activity

Reported by Dag Asheim on 2009-08-02
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Debian)
Fix Released
Medium
gnome-settings-daemon (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-settings-daemon

The "Disable touchpad while typing" option is useful to avoid accidental touchpad actions while typing. But the current implementation makes it inconvenient to press e.g. "Ctrl" and "Left touchpad button" simultaneously. (This opens a link in a new tab in Firefox, so it is a handy combination when browsing using a computer with less than three touchpad buttons.) It would be much better if the modifier keys where ignored when monitoring keyboard activity.

I don't know if everybody else use modifier key combos as often as me, but for me this qualifies as a potential "papercut". At least the bug has the papercut-quality of being trivially fixable; it is just to start "syndaemon" with a "k" option in gnome-settings-daemon-2.27.5/plugins/mouse/gsd-mouse-manager.c:

                args[0] = "syndaemon";
                args[1] = "-i";
                args[2] = "0.5";
                args[3] = "-k";
                args[4] = NULL;

ProblemType: Bug
Architecture: i386
Date: Sun Aug 2 21:29:12 2009
DistroRelease: Ubuntu 9.10
Package: gnome-settings-daemon 2.27.5-0ubuntu2
ProcEnviron:
 LANGUAGE=nb_NO.UTF-8
 LANG=nb_NO.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-4.23-generic
SourcePackage: gnome-settings-daemon
Uname: Linux 2.6.31-4-generic i686

Dag Asheim (dash) wrote :
C de-Avillez (hggdh2) wrote :

This bug was brought up in the #ubuntu-bugs channel by Scienceman123. This seems, indeed, a clear case for a quick fix. While I check, I will add a patch (as proposed by the reporter), and set it as wishlist.

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Wishlist
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
C de-Avillez (hggdh2) wrote :

Debdiff attached. Seems to work OK, or at least works for me. Still to check upstream, though.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Changed in gnome-settings-daemon (Debian):
status: Unknown → New
C de-Avillez (hggdh2) wrote :

To my unending shame, the patch (and, by extension, the debdiff) is wrong... one should never add a new entry in an array without resizing the bloody thing. Corrected patch submitted upstream.

C de-Avillez (hggdh2) wrote :

patch has been committed upstream, should land on next update.

C de-Avillez (hggdh2) on 2009-08-03
Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 2.27.90-0ubuntu1

---------------
gnome-settings-daemon (2.27.90-0ubuntu1) karmic; urgency=low

  * New upstream version (LP: #413618):
    - Update gnome-volume-control from gnome-media (Bastien Nocera)
      (#589825).
    - Fix crash in gvc_mixer_stream_is_running() (Chris Coulson)
      (#590073).
    - Add '-k' option to syndaemon call for 'Disable touchpad while
      typing' (C de-Avillez) (#590588, LP: #408095).
    - Low disk space warning bug-fixes (Chris Coulson)
      (#591153, LP: #404340).
  * Removed patches that are merged upstream now:
    - 60_ldsm_notification_fixup.patch
    - 62_fix_media_keys_memory_errors.patch
  * Removed 11_sleepkey.patch - there is no key assigned to sleep by
    default and gdm-signal does not exist on the default install.
  * Refreshed patches:
    - 61_fix_volume_notification.patch
    - 70_migrate_touchpad_config.patch
    - 90_autoreconf.patch
  * debian/control:
    - Add versioned build-dep on libpulse-dev (>= 0.9.15).
  * Also fixes LP: #404340.

 -- Chris Coulson <email address hidden> Fri, 14 Aug 2009 15:04:39 +0100

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-settings-daemon (Debian):
importance: Unknown → Medium
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.