glines segfault

Bug #995281 reported by ernesto on 2012-05-05
210
This bug affects 33 people
Affects Status Importance Assigned to Milestone
GNOME Games
Fix Released
Critical
Baltix
Undecided
Unassigned
five-or-more (Ubuntu)
Undecided
Unassigned
Raring
Undecided
Unassigned
gnome-games (Debian)
New
Unknown
gnome-games (Ubuntu)
Medium
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

[Impact] glines does not start from application menu. From a terminal, glines receives a Segment fault.
It was working fine with Ubuntu 11.10 and crash after update to 12.04

[Fix] the cause is the use of uninitialized data in a preview, the fix is to simply not do this.

[TEST CASE]
start glines on 32 bit, it should not segfault

[Regression potential]
pretty low, it just delays drawing of some preview data before the games has actually started

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: glines 1:3.4.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic i686
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
Date: Sun May 6 00:18:08 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
SourcePackage: gnome-games
UpgradeStatus: Upgraded to precise on 2012-05-03 (2 days ago)

Related branches

ernesto (erns) wrote :
Changed in gnome-games (Ubuntu):
status: New → Incomplete

I could not reproduce the error, but I am using 64-bit. The error could be due to an old configuration file, so try to purge the application and reinstall it.

sudo apt-get purge glines
sudo apt-get install glines

If it still segfault's, please get a backtrace: https://wiki.ubuntu.com/Backtrace

msznapka (bigmartin) wrote :

I have same problem with clean install of Ubuntu 12.04 i386. Purge and install didn't help, still same: SIGSEGV

I am afraid I can not debug the problem. I have followed
DebuggingProgramCrash instructions but there is no -dbg package nor
glines-dbgsym.

Shaun Crampton (fasaxc) wrote :

I gathered a backtrace using gdb but I couldn't find a dbg package so some of the symbols are missing.

Colin Law (colin-law) on 2012-05-07
Changed in gnome-games (Ubuntu):
status: Incomplete → Confirmed
Jussi Saarinen (jms) wrote :

One more backtrace...

rpkrawczyk (rpkrawczyk) wrote :

BTW, the 64bit version works without problem...

rpkrawczyk (rpkrawczyk) wrote :

Does anybody know why a "catchsegv glines" also just segfaults without any further output?

rpkrawczyk (rpkrawczyk) wrote :

I think I found the same bug in the gnome-games bugtracker at https://bugzilla.gnome.org/show_bug.cgi?id=675628

Carey Underwood (cwillu) wrote :

I just wrote this patch to get things working again; not at all certain it's completely sane though.

The attachment "Reset game before starting and bail out draw_preview if things are not ready" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
rpkrawczyk (rpkrawczyk) wrote :

I just tested the patch from Carey Underwood (see #10). It works like a charm.

Changed in gnome-games:
importance: Unknown → Critical
status: Unknown → Confirmed
Luc Vergely (z-luq-v) wrote :

How to add a patch,

Thank you in advance

Luc Vergely (z-luq-v) wrote :

I am sorry I meant how to apply the patch ?

For me there is an error line 12

Changed in gnome-games (Ubuntu):
importance: Undecided → High
importance: High → Medium
status: Confirmed → Triaged
Changed in gnome-games (Debian):
status: Unknown → New
Hans Joachim Desserud (hjd) wrote :

Still happens with version 1:3.6.1-0ubuntu2 on Ubuntu Raring.

tags: added: quantal raring

Observed also on Kubuntu 13.04 (Dev)
 uname -r
3.7.0-3-generic

Colin Law (colin-law) wrote :

Since there is a simple patch that appears to work it would be good if someone who knows how to do it could incorporate it. I suppose they all have more important issues to deal with however.

MarcH (mhregister) wrote :

The patch that Carrie posted (post #10 above) worked for me on Ubuntu 12.04. I'm a novice Linux user, so most anyone should be able to apply her patch. Here is what I did.

1. Uninstalled Gnome-Games completely.
2. Downoaded gnome-games-3.6.1.tar.xz from http://www.linuxfromscratch.org.
3. Extracted the tar file to the /tmp directory. This extracted a diretory named "gnome-games-3.6.1" containing all of the files needed to install Gnome Games.
4. Navigated to the subdirectory named "glines", and then opened the subdirectory named "src".
5. Added the additonal lines of source code from Carrie's patch to the file named"glines.c". I added just the lines with a plus (+) sign in front of them.
6.Navigated back to the parent directory (gnome-games-3.6.1), and then ran the following commands to install Gnome Games. After the install completed, I had to reboot before I could see the games in Dashboard.

./configure
make
sudo make install

 And after that glines are working?

Воскресенье, 16 декабря 2012, 1:57 от MarcH <email address hidden>:
>The patch that Carrie posted (post #10 above) worked for me on Ubuntu
>12.04. I'm a novice Linux user, so most anyone should be able to apply
>her patch. Here is what I did.
>
>1. Uninstalled Gnome-Games completely.
>2. Downoaded gnome-games-3.6.1.tar.xz from http://www.linuxfromscratch.org .
>3. Extracted the tar file to the /tmp directory. This extracted a diretory named "gnome-games-3.6.1" containing all of the files needed to install Gnome Games.
>4. Navigated to the subdirectory named "glines", and then opened the subdirectory named "src".
>5. Added the additonal lines of source code from Carrie's patch to the file named"glines.c". I added just the lines with a plus (+) sign in front of them.
>6.Navigated back to the parent directory (gnome-games-3.6.1), and then ran the following commands to install Gnome Games. After the install completed, I had to reboot before I could see the games in Dashboard.
>
>./configure
>make
>sudo make install
>
>--
>You received this bug notification because you are subscribed to a
>duplicate bug report (1082735).
>https://bugs.launchpad.net/bugs/995281
>
>Title:
>  glines segfault
>
>Status in GNOME Games:
>  Confirmed
>Status in “gnome-games” package in Ubuntu:
>  Triaged
>Status in Baltix GNU/Linux:
>  New
>Status in “gnome-games” package in Debian:
>  New
>
>Bug description:
>  glines does not start from application menu. From a terminal, glines receives a Segment fault.
>  It was working fine with Ubuntu 11.10 and crash after update to 12.04
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 12.04
>  Package: glines 1:3.4.1-0ubuntu2
>  ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
>  Uname: Linux 3.2.0-24-generic i686
>  ApportVersion: 2.0.1-0ubuntu7
>  Architecture: i386
>  Date: Sun May 6 00:18:08 2012
>  InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
>  SourcePackage: gnome-games
>  UpgradeStatus: Upgraded to precise on 2012-05-03 (2 days ago)
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/gnome-games/+bug/995281/+subscriptions

I'll donate AUD$50 to any charity if a developer who can get this into ubuntu 12.10.

It's my Mum's favourite game and donating $50 is worth getting her off my back about fixing this game.

Julian Taylor (jtaylor) wrote :

the patch works fine in precise
can someone confirm that 12.10 and 13.04 are still affected, the code as changed a bit.

Kev (ukev) wrote :

I can confirm the patch is working on 12.04.

For all the people out there trying to get it working as soon as possible I've created a fixed package for Ubuntu 12.04 (32 Bit). (see attachment)
You can just download and install it with the gui (double click) or in terminal (with dpkg -i filename.deb) until the fixed package is in ubuntu...

Merry Christmas!

Jussi Saarinen (jms) wrote :

I can confirm that 12.10 (32bit) is affected and applying the patch fixes
the problem.
On Dec 26, 2012 3:20 AM, "Julian Taylor" <email address hidden>
wrote:

> the patch works fine in precise
> can someone confirm that 12.10 and 13.04 are still affected, the code as
> changed a bit.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/995281
>
> Title:
> glines segfault
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-games/+bug/995281/+subscriptions
>

Julian Taylor (jtaylor) wrote :

I confirmed it for 13.04 too
the patch in the upstream bug which looks a bit nicer and seems to work fine too.

Julian Taylor (jtaylor) on 2012-12-26
description: updated

Kev #22 - Good enough for me. $50 donated to the Australian Red Cross to support cyclone recovery in Samoa and Fiji.

Iain Lane (laney) wrote :

All uploaded. Thanks!

Changed in gnome-games (Ubuntu):
status: Triaged → Fix Committed
Changed in gnome-games (Ubuntu Precise):
status: New → In Progress
Changed in gnome-games (Ubuntu Quantal):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-games - 1:3.6.1-0ubuntu3

---------------
gnome-games (1:3.6.1-0ubuntu3) raring; urgency=low

  * fix-glines-crash.patch:
    fix glines crash on startup (LP: #995281)
 -- Julian Taylor <email address hidden> Wed, 26 Dec 2012 19:42:38 +0100

Changed in gnome-games (Ubuntu):
status: Fix Committed → Fix Released

Hello ernesto, or anyone else affected,

Accepted gnome-games into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-games/1:3.4.1-0ubuntu2.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-games (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in gnome-games (Ubuntu Quantal):
status: In Progress → Fix Committed
Colin Watson (cjwatson) wrote :

Hello ernesto, or anyone else affected,

Accepted gnome-games into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-games/1:3.6.0.2-0ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Nikolay Morozov (nmorozov) wrote :

Quantal i386 looks good for me

Hb (hbb) wrote :

Me too!

The new version doesn't throw an inital set of balls onto the board after startup. The user needs to start the game with Strg+N. I remember that the former version did this automatically.

Hello,

just for your information, I am under Kubuntu Raring alpha 1 (13.04) and
glines works fine.

Thanks.

Xavier

Le 15/01/2013 12:28, Colin Watson a écrit :
> Hello ernesto, or anyone else affected,
>
> Accepted gnome-games into quantal-proposed. The package will build now
> and be available at http://launchpad.net/ubuntu/+source/gnome-
> games/1:3.6.0.2-0ubuntu1.2 in a few hours, and then in the -proposed
> repository.
>
> Please help us by testing this new package. See
> https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
> enable and use -proposed. Your feedback will aid us getting this update
> out to other Ubuntu users.
>
> If this package fixes the bug for you, please add a comment to this bug,
> mentioning the version of the package you tested, and change the tag
> from verification-needed to verification-done. If it does not fix the
> bug for you, please add a comment stating that, and change the tag to
> verification-failed. In either case, details of your testing will help
> us make a better decision.
>
> Further information regarding the verification process can be found at
> https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in
> advance!
>

ernesto (erns) wrote :

Hi Colin,

the precise-proposed is running ok in Ubuntu 12.04 precise.

Thanks for your work.
Ernesto

Julian Taylor (jtaylor) on 2013-01-16
tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-games - 1:3.6.0.2-0ubuntu1.2

---------------
gnome-games (1:3.6.0.2-0ubuntu1.2) quantal-proposed; urgency=low

  * fix-glines-crash.patch:
    fix glines crash on startup (LP: #995281)
 -- Julian Taylor <email address hidden> Wed, 26 Dec 2012 20:15:01 +0100

Changed in gnome-games (Ubuntu Quantal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-games - 1:3.4.1-0ubuntu2.2

---------------
gnome-games (1:3.4.1-0ubuntu2.2) precise-proposed; urgency=low

  * fix-glines-crash.patch:
  fix glines crash on startup (LP: #995281)
 -- Julian Taylor <email address hidden> Wed, 26 Dec 2012 19:59:17 +0100

Changed in gnome-games (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in gnome-games:
status: Confirmed → Fix Released
Carey Underwood (cwillu) wrote :

Still broken in a fresh raring install.

Julian Taylor (jtaylor) wrote :

the patch was dropped in the split to five-or-more in raring as upstream claimed it was fixed, it seems this is not the case.
the old patch applied to quantal and older still works.

Julian Taylor (jtaylor) on 2013-05-30
no longer affects: five-or-more (Ubuntu Precise)
no longer affects: five-or-more (Ubuntu Quantal)
Changed in five-or-more (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in five-or-more (Ubuntu Raring):
status: New → Confirmed
Changed in gnome-games (Ubuntu Raring):
status: New → Confirmed
Julian Taylor (jtaylor) wrote :

I have uploaded a fix for ubuntu 13.04, please test it when it has been accepted.
The release will post instructions.

no longer affects: gnome-games (Ubuntu Raring)
Changed in gnome-games:
status: Fix Released → Confirmed
Changed in gnome-games:
status: Confirmed → Fix Released

Hello ernesto, or anyone else affected,

Accepted five-or-more into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/five-or-more/1:3.8.0-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in five-or-more (Ubuntu Raring):
status: Confirmed → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Julian Taylor (jtaylor) wrote :

the version in proposed works for me in raring i386 and amd64

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package five-or-more - 1:3.8.0-0ubuntu1.1

---------------
five-or-more (1:3.8.0-0ubuntu1.1) raring-proposed; urgency=low

  * re-apply fix-glines-crash.patch dropped in gnome-games split
    fixes crash in 32 bit installs (LP: #995281)
 -- Julian Taylor <email address hidden> Thu, 30 May 2013 18:16:35 +0200

Changed in five-or-more (Ubuntu Raring):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.