Debian GNU/Linux

Comment 0 for bug 25544

Package: emacs-goodies-el
Version: 26.3-1
Severity: serious

It seems to me that some Emacs Lisp packages in emacs-goodies-el are
only of any use if non-free software is installed on the system,
namely: maplev.el needs Maple, matlab.el needs Matlab and tcl.el needs
the Target Language Compiler (whatever that is, but it is certainly
not part of Debian). Therefore, these files belong in the "contrib"
section of Debian (see section 2.2.2 of the Policy Manual) and must
not go into a package in the main section. Please remove them from
emacs-goodies-el and make a separate package of them for the contrib
section.

-- System Information:
Debian Release: testing/unstable
   APT prefers unstable
   APT policy: (500, 'unstable'), (500, 'testing'), (3, 'testing'), (2, 'unstable'), (1, 'unstable')
Architecture: i386 (i686)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.4.31
Locale: LANG=de_DE, LC_CTYPE=de_DE (charmap=ISO-8859-1)

Versions of packages emacs-goodies-el depends on:
ii bash 3.0-17 The GNU Bourne Again SHell
ii emacs-snapshot [emacsen] 1:20051103-1 The GNU Emacs editor (development
ii emacs21 [emacsen] 21.4a-1 The GNU Emacs editor

Versions of packages emacs-goodies-el recommends:
pn dict <none> (no description available)
ii perl-doc 5.8.7-7 Perl documentation
ii wget 1.10.1-1 retrieves files from the web

-- no debconf information