Please upgrade to new upstream version 0.7.0

Bug #307958 reported by Noel J. Bergman on 2008-12-14
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dstat (Debian)
New
Undecided
Unassigned
dstat (Ubuntu)
Wishlist
Unassigned
Declined for Intrepid by Steve Langasek
Declined for Jaunty by Steve Langasek
Declined for Karmic by Iulian Udrea
Declined for Lucid by Iulian Udrea

Bug Description

From upstream repository (http://svn.rpmforge.net/svn/trunk/tools/dstat/ChangeLog):

* 0.7.0 - Tokyo - release 31/10/2009
- Fixed dstat_disk plugin for total calculation on 2.6.25+ kernels (Noel J. Bergman)
- Precompile regular expressions used as a disk filter (self.diskfilter)
- Raise a warning when discovery returns empty
- Improvements to dstat_battery and dstat_cpufreq
- Added external dstat_power plugin to show ACPI power usage
- Simplified logic inside dstat_time
- Added external dstat_ntp plugin to show time from an NTP server
- Flush sys.stdout later in the loop
- Filtering out more interfaces (eg. bonding) in total values (Bert de Bruijn)
- Provide error output when now power information is available (AC power)
- Make topcpu plugin SMP aware (values are not percent per CPU)
- Drop support for Python 1.5 (and removed dstat15 version)
- Introduced splitlines() function that allows a replace/split on readlines()
- Added external dstat_fan plugin to show fan speed
- Added theming support (not exposed to users yet)
- Added --bw/--blackonwhite option to use dark colors on white background
- Allow any plugin to be added by using long options (ie. --topbio)
- Added external dstat_memcache_hits plugin to show memcache hits and misses (Dean Wilson)
- Various changes to simplify plugin interface and performance improvements
- Added external dstat_proccount plugin to show total number of process (Dean Wilson)
- Added external dstat_vzio plugin to show I/O account number per OpenVZ container
- Added external dstat_battery_remain plugin to show how much battery time is remaining
- Added getnamebypid() function to simplify finding bast process name by process id
- This release was 'sponsored' by the Linux Foundation during the Japan Linux Symposium

Chris Coulson (chrisccoulson) wrote :

Thank you for your bug report.

Changed in dstat:
importance: Undecided → Wishlist
status: New → Triaged
Noel J. Bergman (noeljb) wrote :

Actually, it would be best if we upgrade to a patched version (Bug 307961). The fix corrects erroneous output on Intrepid and Jaunty related to total values for disk I/O.

Joseph Smidt (jsmidt) wrote :

Here is the needed debdiff to close this bug. Please sponsor the upload.

Daniel Holbach (dholbach) wrote :

Joseph: can you please just add the .diff.gz of the new source package? Your debdiff includes a bunch of upstream changes as well.

On Fri, 30 Jan 2009, Daniel Holbach wrote:

> Joseph: can you please just add the .diff.gz of the new source package?
> Your debdiff includes a bunch of upstream changes as well.

Hi Daniel,

Is there an index of the patches that are applied in the Ubuntu release ?

I am interested to learn how I could track them in the future. I am
already tracking the individual bug-reports for dstat, but there may be
fixes going into the package that are not related to a bug ? (eg.
packaging changes ?)

--
-- dag wieers, <email address hidden>, http://dag.wieers.com/ --
[Any errors in spelling, tact or fact are transmission errors]

dag: There's no changes to dstat at the moment. We ship the same version as Debian: https://launchpad.net/ubuntu/+source/dstat has info about which releases we're shipping. There's nothing in http://patches.ubuntu.com/d/ either.

Noel J. Bergman (noeljb) wrote :

Daniel,

> > can you please just add the .diff.gz of the new source package?

> There's no changes to dstat at the moment. We ship the same version as Debian

For what are you looking? It appears that debian is still shipping 0.6.8 (q.v., http://packages.debian.org/search?keywords=dstat), and this issue is for us to package a later version. Should we start to get dstat directly from dag, who is the true upstream? Or do you want a diff of the desired dag source against the package we're currently including?

What I'd like to see is 0.6.9 plus the patch that dag and I already did to resolve Bug 307961. It is a simple patch to a single file. I would take dag's version from source control, which supersedes the patch I had proposed.

Daniel Holbach (dholbach) wrote :

Whatever you want to be reviewed, please attach the .diff.gz (of the source package) to the bug report or link to the source package please. The debdiff also includes upstream changes.

Daniel Holbach (dholbach) wrote :

Unsubscribing Ubuntu Sponsors for universe from this bug for now. Please re-subscribe when ready.

Noel J. Bergman (noeljb) wrote :

Daniel,

Please make sure I understand, and I can try to provide the patch. To be clear, you want for me to unpack the current Ubuntu source package, grab the source that we want, and just generate a diff -u of the two? Or do you want for me to follow the recipe found at https://wiki.ubuntu.com/PackagingGuide/Complete#Recipe:%20Updating%20An%20Ubuntu%20Package, which (I notice) has your name in it? :-)

Just let me know, and I'll try to get to it. :-)

Daniel Holbach (dholbach) wrote :

A diff of the two debian directories is sure going to work. :-)

Noel J. Bergman (noeljb) wrote :

Daniel,

Here you go. I followed the instructions in your packaging guide, down to the point right before executing the debuild, and then ran a diff of the current and desired versions:

 $ diff -u dstat-0.6.8/ dstat-0.6.9+15DEC2008/ > dstat-0.6.8-to-0.6.9+15DEC2008

That diff is attached, and I hope that this is what you want.

Daniel Holbach (dholbach) wrote :

Can you please do the following?

diff -ruN dstat-0.6.8/debian dstat-0.6.9+15DEC2008/debian > patch

Also since we're in Feature Freeze and this release adds new features you probably should follow https://wiki.ubuntu.com/FreezeExceptionProcess

Noel J. Bergman (noeljb) wrote :

Sample output from the new version of dstat:

  $ dstat-0.6.9+15DEC2008/dstat --all -Dsda8,sda10,sda,total
  ----total-cpu-usage---- --dsk/sda8---dsk/sda10----dsk/sda----dsk/total- -net/total- ---paging-- ---system--
  usr sys idl wai hiq siq| read writ: read writ: read writ: read writ| recv send| in out | int csw
    5 9 84 2 0 0|9540B 19k: 99k 118k: 109k 137k: 109k 137k| 0 0 | 61B 237B|1317 1751
    5 3 92 0 0 0| 0 0 : 0 0 : 0 0 : 0 0 | 0 0 | 0 0 |1228 1402
    8 3 89 0 0 0| 0 0 : 0 0 : 0 0 : 0 0 |1011B 1028B| 0 0 |1274 1425

That just shows main functionality, and also that the disk I/O total values are not doubled, as they are with the currently packaged version of dstat (Bug 307961):

  $ dstat-0.6.8/dstat --all -Dsda8,sda10,sda,total
  ----total-cpu-usage---- --dsk/sda8---dsk/sda10----dsk/sda----dsk/total- -net/total- ---paging-- ---system--
  usr sys idl wai hiq siq| read writ: read writ: read writ: read writ| recv send| in out | int csw
    5 9 84 2 0 0|9528B 19k: 99k 118k: 109k 137k: 217k 274k| 0 0 | 61B 236B|1317 1751
    5 2 92 0 0 0| 0 40k: 0 0 : 0 40k: 0 80k| 432B 0 | 0 0 |1199 1366
    7 2 90 0 0 0| 0 0 : 0 0 : 0 0 : 0 0 | 0 0 | 0 0 |1209 1401

dstat is in Universe:
  Package: dstat
  Priority: optional
  Section: universe/admin
  Maintainer: Ubuntu MOTU Developers <email address hidden>

Noel J. Bergman (noeljb) wrote :

As per request, extract from /var/log/dpkg.log:

2009-03-16 11:10:48 upgrade dstat 0.6.8-1 0.6.9+15DEC2008-0ubuntu1
2009-03-16 11:10:48 status half-configured dstat 0.6.8-1
2009-03-16 11:10:48 status unpacked dstat 0.6.8-1
2009-03-16 11:10:48 status half-installed dstat 0.6.8-1
2009-03-16 11:10:48 status triggers-pending man-db 2.5.4-2
2009-03-16 11:10:48 status half-installed dstat 0.6.8-1
2009-03-16 11:10:48 status half-installed dstat 0.6.8-1
2009-03-16 11:10:48 status unpacked dstat 0.6.9+15DEC2008-0ubuntu1
2009-03-16 11:10:48 status unpacked dstat 0.6.9+15DEC2008-0ubuntu1
2009-03-16 11:10:48 configure dstat 0.6.9+15DEC2008-0ubuntu1 0.6.9+15DEC2008-0ubuntu1
2009-03-16 11:10:48 status unpacked dstat 0.6.9+15DEC2008-0ubuntu1
2009-03-16 11:10:48 status half-configured dstat 0.6.9+15DEC2008-0ubuntu1
2009-03-16 11:10:49 status triggers-awaited dstat 0.6.9+15DEC2008-0ubuntu1
2009-03-16 11:10:49 trigproc man-db 2.5.4-2 2.5.4-2
2009-03-16 11:10:49 status half-configured man-db 2.5.4-2
2009-03-16 11:10:49 status installed dstat 0.6.9+15DEC2008-0ubuntu1
2009-03-16 11:10:49 status installed man-db 2.5.4-2

I've also attached the .deb file.

Iulian Udrea (iulian) wrote :

Please attach both build and install logs. I can see from dpkg.log that the upgrade has succeeded.

If you read https://wiki.ubuntu.com/FreezeExceptionProcess#FeatureFreeze%20for%20new%20upstream%20versions carefully it says that you don't need to attach the diff between the old debian/changelog and the newly created one. That being said you should have not attached it because we see the debian/changelog when uploading :-)

What testing have you done with this?

What about bug #249013? Is this fixed upstream? It seems that dstat version 0.6.6-5 crashes. Is this bug still valid?

It looks like bug #297772 has been fixed in version 0.6.8. Would you like to take care of this bug and close it if it's really fixed?

Changed in dstat:
status: Triaged → New
Noel J. Bergman (noeljb) wrote :

Iulian,

This is the version of dstat that I've been using locally, so I've tested it mostly by using it. I've also checked that I cannot reproduce either bug 249013 or bug 297772 with this code, and have indicated so on those reports.

Am attaching the pbuilder log. The diff of debian/ was because Daniel explicitly requested it, as you can see above.

Install log:

  $ sudo dpkg -i dstat_0.6.9+15DEC2008-0ubuntu1_all.deb
  (Reading database ... 144565 files and directories currently installed.)
  Preparing to replace dstat 0.6.8-1 (using dstat_0.6.9+15DEC2008-0ubuntu1_all.deb) ...
  Unpacking replacement dstat ...
  Setting up dstat (0.6.9+15DEC2008-0ubuntu1) ...

  Processing triggers for man-db ...
  $

Is there anything else I can do? :-)

StefanPotyra (sistpoty) wrote :

No rdepends, and while the changes to source are not the smallest, these don't look too bad to me, ACK #1.

Iulian Udrea (iulian) wrote :

I'm fine with it as well. ACK #2

Exception granted.

Changed in dstat:
status: New → Confirmed
Iulian Udrea (iulian) on 2009-04-18
Changed in dstat (Ubuntu):
assignee: nobody → iulian
status: Confirmed → In Progress
Iulian Udrea (iulian) wrote :

From where can I download 0.6.9+15DEC2008? I couldn't find any links pointing to the tarball.

Noel J. Bergman (noeljb) wrote :

Iulian asked:

> From where can I download 0.6.9+15DEC2008? I couldn't find any links pointing to the tarball

I don't know that there is one. I didn't make one. No one asked for one. I provided the patch between what Jaunty has, and what we want. I provided other diffs as requested. I provided a .deb. I feel rather like we're playing "Fetch me a Rock" (q.v. http://intertwingly.net/blog/2005/05/11/Fetch-Me-A-Rock).

What more do you want now, so that we can get this long delayed fix released? Are you asking me to post the file, dstat_0.6.9+15DEC2008.orig.tar.gz, that I used when going through the build process? Fine, attached. Anything else?

Iulian Udrea (iulian) wrote :

I wanted a link from where I can get the newest version of dstat. As far as I can see from http://dag.wieers.com/home-made/dstat/, that page is saying that the latest version is 0.6.9 which is packed (tar.gz file).

I don't know where to check on the md5sums since there is no packed tarball. From where should I know that the tarball you were using is the one that upstream uses? I usually don't upload to the archive if the md5sums of both tarballs (the one that upstream packed and the other one that we use) do not match.

Don't be disappointed but what you've attached is not what we asked for, except the pbuilder log and the ChangeLog diff.

The .deb is not necessary, we don't do binary uploads, source only.

Having that said, all I want is a link pointing to the latest version of dstat packed by upstream which is downloadable from the project website.

Changed in dstat (Ubuntu):
assignee: iulian → nobody
status: In Progress → Confirmed
Iulian Udrea (iulian) wrote :

Jaunty is currently in Deep Freeze and we are just a couple of days away from the Final Release. Unfortunately, the new version of this package is not in Jaunty and it's way too late for this to go in.

The package will be upgraded to the new version when Karmic opens its doors.

Noel J. Bergman (noeljb) wrote :

Lovely. So this won't happen for Jaunty, despite doing the work and getting the freeze exceptions? Or can we get this into jaunty updates?

I have no problem with source only. Makes perfect sense.

Yes, 0.6.9 is the latest that dag has rolled, which is why I build from source control, and why I provided the attached tarball with the selected version of the code, and the diff from the Jaunty package. There is no later version of dstat packaged by dag unless he decides to post one now in response to your comments.

What would it take to set dag up as the maintainer? This is a ridiculous situation.

Bhavani Shankar (bhavi) wrote :

New upstream version already in the repos..

Changed in dstat (Ubuntu):
status: Confirmed → Fix Released
Noel J. Bergman (noeljb) wrote :

Upstream never grabbed the code that had the actual fixes. Dag didn't formally release that until a week ago, so the only way to have had them would have been to take my patch.

I can prepare a package based on the current code.

Changed in dstat (Ubuntu):
status: Fix Released → Fix Committed
description: updated
summary: - Please upgrade to new upstream version 0.6.9
+ Please upgrade to new upstream version 0.7.0
Fabrice Coutadeur (fabricesp) wrote :

Hi,

You could perhaps work with Debian maintainer to get version 0.7.0 into Debian. This way, it will go to Ubuntu automatically.

As there is nothing to sponsor at the moment for version 0.7.0, I'll unsubscribe u-u-s. Please feel free to subscribe u-u-s again as soon as you have something to sponsor.

Also, please don't put the bug report as fix Committed as it won't get the required attention from Sponsors.

Thanks,
Fabrice

Changed in dstat (Ubuntu):
status: Fix Committed → New
Noel J. Bergman (noeljb) wrote :

Fabrice,

Yes, I'll work with dag on it. As for Fix Committed, please note that I was backing it off from Fix Released, since that certainly wasn't the case. The fix is (at least) committed upstream. In any event, I'll see what I can do with dag.

On Thu, 12 Nov 2009, Noel J. Bergman wrote:

> Fabrice,
>
> Yes, I'll work with dag on it. As for Fix Committed, please note that I
> was backing it off from Fix Released, since that certainly wasn't the
> case. The fix is (at least) committed upstream. In any event, I'll see
> what I can do with dag.

Noel,

Can you please test the current snapshot on various Ubuntu releases ? I am
in this spiral where without testing I don't feel confident to release,
but without release I don't seem to get any testing.

And since I do everything on CentOS 5, that doesn't cover enough grounds.

--
-- dag wieers, <email address hidden>, http://dag.wieers.com/ --
[Any errors in spelling, tact or fact are transmission errors]

Nigel Babu (nigelbabu) wrote :

Lucid has dstat 0.7.0-2, closing the bug

Changed in dstat (Ubuntu):
status: New → Fix Released
To post a comment you must log in.