Broken dependency for docker.io package on Yakkety and Debian

Bug #1653912 reported by Po-Hsu Lin
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
docker.io (Debian)
New
Undecided
Tim Potter
docker.io (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

While trying to install docker.io package, it complains about the dependency problem for runc

$ sudo apt-get install docker.io
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 docker.io : Depends: runc (>= 1.0.0~rc1-0ubuntu2) but 1.0.0~rc1-0ubuntu2~16.10.1 is to be installed
E: Unable to correct problems, you have held broken packages.

Revision history for this message
Michael Hudson-Doyle (mwhudson) wrote : Re: [Bug 1653912] [NEW] Broken dependency for docker.io package on Yakkety

This is only if you have -proposed enabled, right? There is a fix waiting
in the SRU queue for this.

On 4 January 2017 at 21:45, Po-Hsu Lin <email address hidden> wrote:

> Public bug reported:
>
> While trying to install docker.io package, it complains about the
> dependency problem for runc
>
> $ sudo apt-get install docker.io
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
> docker.io : Depends: runc (>= 1.0.0~rc1-0ubuntu2) but
> 1.0.0~rc1-0ubuntu2~16.10.1 is to be installed
> E: Unable to correct problems, you have held broken packages.
>
> ** Affects: docker.io (Ubuntu)
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are subscribed to
> docker.io in Ubuntu.
> https://bugs.launchpad.net/bugs/1653912
>
> Title:
> Broken dependency for docker.io package on Yakkety
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/docker.io/+bug/
> 1653912/+subscriptions
>

Revision history for this message
Po-Hsu Lin (cypressyew) wrote : Re: Broken dependency for docker.io package on Yakkety

Yep, I encounter this while running the Kernel SRU test.

Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

The two fixes passed SRU, does this still occur with 1.12.6-0ubuntu1~16.10.1?

Changed in docker.io (Ubuntu):
status: New → Incomplete
Revision history for this message
Po-Hsu Lin (cypressyew) wrote :

Hello,

I didn't see this issue during this cycle, please feel free to close this bug.

Thank you!

Revision history for this message
Jon Grimm (jgrimm) wrote :

Marked invalid. Thanks for the update.

Changed in docker.io (Ubuntu):
status: Incomplete → Invalid
Revision history for this message
xtsbdu3reyrbrmroezob (xtsbdu3reyrbrmroezob) wrote :

Also affects Debian 10, Buster

docker.io : Depends: runc (>= 1.0.0~rc2+git20170201.133.9df8b30~) but 0.1.1+dfsg1-2+b2 is to be installed

Changed in docker.io (Debian):
assignee: nobody → Tim Potter (tpot)
summary: - Broken dependency for docker.io package on Yakkety
+ Broken dependency for docker.io package on Yakkety and Debian
Revision history for this message
xtsbdu3reyrbrmroezob (xtsbdu3reyrbrmroezob) wrote :

Buster versions are not worked out yet, so this bug can be a placeholder for when Buster is released to prod. Encountered this on a testing virtual machine.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers