dhcp3-client: Does not send hostname to server by default

Bug #10239 reported by Debian Bug Importer on 2004-11-12
148
This bug affects 4 people
Affects Status Importance Assigned to Milestone
dhcp3 (Debian)
Fix Released
Unknown
dhcp3 (Ubuntu)
Wishlist
Martin Pitt

Bug Description

Automatically imported from Debian bug report #151820 http://bugs.debian.org/151820

On Wed, Jul 03, 2002 at 12:29:01PM -0400, Daniel Jacobowitz wrote:

> (This also applies to dhcp-client)
>
> In order to get server-side dynamic DNS updates to work, you need to
> add "send host-name "hostname";" to the configuration file for dhclient.
> Most other clients seem to default to sending the hostname (including pump
> and the MS client). There's also no documentation which mentions that this
> might be necessary, as far as I could find - only comments about the
> somewhat rarer case of client-side dynamic DNS. And if it needs to go in
> the configuration file that's one more thing to remember when the hostname
> changes...

I have started using dynamic DNS a lot lately, and I have wondered about
this as well. I noticed the same thing with pump and the MS Windows client,
and I agree about the badness of duplicating configuration information like
the hostname in the DHCP client config.

I just haven't gotten around to asking upstream about this. Could it be
that sending this information by default breaks some DHCP servers? I
haven't seen any problems, but I mostly use ISC's.

--
 - mdz

If the send host-name construct in the conf file was modified to allow an
unquoted keyword such as default to mean the machine's current hostname, and
the line

send host-name default;

was added to the default config file, these two bugs could be closed.

--
Brian Ristuccia
<email address hidden>
<email address hidden>

merge 165086 151820
thanks

#131365 reports the same problem with the dhcp-client package.

Please follow up at #151820.

severity 151820 wishlist
thanks

--
 - mdz

tags 211261 pending
tags 165086 pending
tags 217769 pending
tags 152287 pending
tags 208549 pending
thanks

--
 - mdz

Download full text (5.4 KiB)

Source: dhcp3
Source-Version: 3.0+3.0.1rc13-1

We believe that the bug you reported is fixed in the latest version of
dhcp3, which is due to be installed in the Debian FTP archive:

dhcp3-client-udeb_3.0+3.0.1rc13-1_i386.udeb
  to pool/main/d/dhcp3/dhcp3-client-udeb_3.0+3.0.1rc13-1_i386.udeb
dhcp3-client_3.0+3.0.1rc13-1_i386.deb
  to pool/main/d/dhcp3/dhcp3-client_3.0+3.0.1rc13-1_i386.deb
dhcp3-common_3.0+3.0.1rc13-1_i386.deb
  to pool/main/d/dhcp3/dhcp3-common_3.0+3.0.1rc13-1_i386.deb
dhcp3-dev_3.0+3.0.1rc13-1_i386.deb
  to pool/main/d/dhcp3/dhcp3-dev_3.0+3.0.1rc13-1_i386.deb
dhcp3-relay_3.0+3.0.1rc13-1_i386.deb
  to pool/main/d/dhcp3/dhcp3-relay_3.0+3.0.1rc13-1_i386.deb
dhcp3-server_3.0+3.0.1rc13-1_i386.deb
  to pool/main/d/dhcp3/dhcp3-server_3.0+3.0.1rc13-1_i386.deb
dhcp3_3.0+3.0.1rc13-1.diff.gz
  to pool/main/d/dhcp3/dhcp3_3.0+3.0.1rc13-1.diff.gz
dhcp3_3.0+3.0.1rc13-1.dsc
  to pool/main/d/dhcp3/dhcp3_3.0+3.0.1rc13-1.dsc
dhcp3_3.0+3.0.1rc13.orig.tar.gz
  to pool/main/d/dhcp3/dhcp3_3.0+3.0.1rc13.orig.tar.gz

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Eloy A. Paris <email address hidden> (supplier of updated dhcp3 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 24 Feb 2004 12:06:30 -0500
Source: dhcp3
Binary: dhcp3-client-udeb dhcp3-common dhcp3-relay dhcp3-dev dhcp3-client dhcp3-server
Architecture: source i386
Version: 3.0+3.0.1rc13-1
Distribution: unstable
Urgency: low
Maintainer: Eloy A. Paris <email address hidden>
Changed-By: Eloy A. Paris <email address hidden>
Description:
 dhcp3-client - DHCP Client
 dhcp3-client-udeb - DHCP Client for debian-installer (udeb)
 dhcp3-common - Common files used by all the dhcp3* packages.
 dhcp3-dev - API for accessing and modifying the DHCP server and client state
 dhcp3-relay - DHCP Relay
 dhcp3-server - DHCP server for automatic IP address assignment
Closes: 95262 110927 152287 165086 177846 201086 204329 208549 211261 217769 231577
Changes:
 dhcp3 (3.0+3.0.1rc13-1) unstable; urgency=low
 .
   * Eloy Paris <email address hidden>:
     - New upstream version. (closes: #231577)
       + Dropping dhcrelay.c.patch since a similar version is now
         included upstream. This patch was applied in 3.0+3.0.1rc11-3
         to prevent a DoS condition.
     - Have the dhcp3-server init script exit if dhcp3 is removed but not purged
       by testing for the existence of /usr/sbin/dhcpd3 (Closes: #201086)
     - Tighten versioned dependency on debianutils, since we need run-parts
      --list (Closes: #204329)
     - Added the "netbios-scope" option to the list of options the DHCP
       client requests from the server to play nicely with the samba
       package.
     - Prevent dh_md5sums from creating a md5sums file for dhcp3-...

Read more...

unmerge 151820
reopen 151820
thanks

#151820 and #165086 are different bugs.

--
 - mdz

severity 246692 wishlist
merge 246692 151820

clone 238350 -1
retitle -1 Please add german translation
severity -1 wishlist
tags -1 + d-i
reassign -1 baseconfig-udeb
thanks

Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #151820 http://bugs.debian.org/151820

Debian Bug Importer (debzilla) wrote :

Message-Id: <E17Pn02-0000jQ-00@branoic>
Date: Wed, 03 Jul 2002 12:29:01 -0400
From: Daniel Jacobowitz <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: dhcp3-client: Does not send hostname to server by default

Package: dhcp3-client
Version: 3.0+3.0.1rc9-2
Severity: normal

(This also applies to dhcp-client)

In order to get server-side dynamic DNS updates to work, you need to
add "send host-name "hostname";" to the configuration file for dhclient.
Most other clients seem to default to sending the hostname (including pump
and the MS client). There's also no documentation which mentions that this
might be necessary, as far as I could find - only comments about the
somewhat rarer case of client-side dynamic DNS. And if it needs to go in
the configuration file that's one more thing to remember when the hostname
changes...

-- System Information
Debian Release: 3.0
Architecture: i386
Kernel: Linux branoic 2.4.19-pre10-ac2-branoic #3 Tue Jun 18 11:20:20 EDT 2002 i586
Locale: LANG=en_US, LC_CTYPE=en_US

Versions of packages dhcp3-client depends on:
ii debconf 1.0.32 Debian configuration management sy
ii debianutils 1.16 Miscellaneous utilities specific t
ii dhcp3-common 3.0+3.0.1rc9-2 Common files used by all the dhcp3
ii libc6 2.2.5-6 GNU C Library: Shared libraries an

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Wed, 3 Jul 2002 23:33:28 -0400
From: Matt Zimmerman <email address hidden>
To: Daniel Jacobowitz <email address hidden>, <email address hidden>
Subject: Re: Bug#151820: dhcp3-client: Does not send hostname to server by default

On Wed, Jul 03, 2002 at 12:29:01PM -0400, Daniel Jacobowitz wrote:

> (This also applies to dhcp-client)
>
> In order to get server-side dynamic DNS updates to work, you need to
> add "send host-name "hostname";" to the configuration file for dhclient.
> Most other clients seem to default to sending the hostname (including pump
> and the MS client). There's also no documentation which mentions that this
> might be necessary, as far as I could find - only comments about the
> somewhat rarer case of client-side dynamic DNS. And if it needs to go in
> the configuration file that's one more thing to remember when the hostname
> changes...

I have started using dynamic DNS a lot lately, and I have wondered about
this as well. I noticed the same thing with pump and the MS Windows client,
and I agree about the badness of duplicating configuration information like
the hostname in the DHCP client config.

I just haven't gotten around to asking upstream about this. Could it be
that sending this information by default breaks some DHCP servers? I
haven't seen any problems, but I mostly use ISC's.

--
 - mdz

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Thu, 8 Aug 2002 16:34:35 -0400
From: Brian Ristuccia <email address hidden>
To: <email address hidden>, <email address hidden>
Subject: an elegant solution

If the send host-name construct in the conf file was modified to allow an
unquoted keyword such as default to mean the machine's current hostname, and
the line

send host-name default;

was added to the default config file, these two bugs could be closed.

--
Brian Ristuccia
<email address hidden>
<email address hidden>

Debian Bug Importer (debzilla) wrote :

Message-Id: <1054980904.16570.291.camel@thanatos>
Date: 07 Jun 2003 12:15:05 +0200
From: Thomas Hood <email address hidden>
To: <email address hidden>, <email address hidden>
Subject: merge 165086 151820

merge 165086 151820
thanks

#131365 reports the same problem with the dhcp-client package.

Please follow up at #151820.

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Thu, 18 Dec 2003 12:40:11 -0800
From: Matt Zimmerman <email address hidden>
To: <email address hidden>
Subject: Cleanup

severity 151820 wishlist
thanks

--
 - mdz

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Thu, 18 Dec 2003 14:05:50 -0800
From: Matt Zimmerman <email address hidden>
To: <email address hidden>
Subject: Pending

tags 211261 pending
tags 165086 pending
tags 217769 pending
tags 152287 pending
tags 208549 pending
thanks

--
 - mdz

Debian Bug Importer (debzilla) wrote :
Download full text (5.6 KiB)

Message-Id: <email address hidden>
Date: Tue, 24 Feb 2004 14:32:04 -0500
From: <email address hidden> (Eloy A. Paris)
To: <email address hidden>
Subject: Bug#165086: fixed in dhcp3 3.0+3.0.1rc13-1

Source: dhcp3
Source-Version: 3.0+3.0.1rc13-1

We believe that the bug you reported is fixed in the latest version of
dhcp3, which is due to be installed in the Debian FTP archive:

dhcp3-client-udeb_3.0+3.0.1rc13-1_i386.udeb
  to pool/main/d/dhcp3/dhcp3-client-udeb_3.0+3.0.1rc13-1_i386.udeb
dhcp3-client_3.0+3.0.1rc13-1_i386.deb
  to pool/main/d/dhcp3/dhcp3-client_3.0+3.0.1rc13-1_i386.deb
dhcp3-common_3.0+3.0.1rc13-1_i386.deb
  to pool/main/d/dhcp3/dhcp3-common_3.0+3.0.1rc13-1_i386.deb
dhcp3-dev_3.0+3.0.1rc13-1_i386.deb
  to pool/main/d/dhcp3/dhcp3-dev_3.0+3.0.1rc13-1_i386.deb
dhcp3-relay_3.0+3.0.1rc13-1_i386.deb
  to pool/main/d/dhcp3/dhcp3-relay_3.0+3.0.1rc13-1_i386.deb
dhcp3-server_3.0+3.0.1rc13-1_i386.deb
  to pool/main/d/dhcp3/dhcp3-server_3.0+3.0.1rc13-1_i386.deb
dhcp3_3.0+3.0.1rc13-1.diff.gz
  to pool/main/d/dhcp3/dhcp3_3.0+3.0.1rc13-1.diff.gz
dhcp3_3.0+3.0.1rc13-1.dsc
  to pool/main/d/dhcp3/dhcp3_3.0+3.0.1rc13-1.dsc
dhcp3_3.0+3.0.1rc13.orig.tar.gz
  to pool/main/d/dhcp3/dhcp3_3.0+3.0.1rc13.orig.tar.gz

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Eloy A. Paris <email address hidden> (supplier of updated dhcp3 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 24 Feb 2004 12:06:30 -0500
Source: dhcp3
Binary: dhcp3-client-udeb dhcp3-common dhcp3-relay dhcp3-dev dhcp3-client dhcp3-server
Architecture: source i386
Version: 3.0+3.0.1rc13-1
Distribution: unstable
Urgency: low
Maintainer: Eloy A. Paris <email address hidden>
Changed-By: Eloy A. Paris <email address hidden>
Description:
 dhcp3-client - DHCP Client
 dhcp3-client-udeb - DHCP Client for debian-installer (udeb)
 dhcp3-common - Common files used by all the dhcp3* packages.
 dhcp3-dev - API for accessing and modifying the DHCP server and client state
 dhcp3-relay - DHCP Relay
 dhcp3-server - DHCP server for automatic IP address assignment
Closes: 95262 110927 152287 165086 177846 201086 204329 208549 211261 217769 231577
Changes:
 dhcp3 (3.0+3.0.1rc13-1) unstable; urgency=low
 .
   * Eloy Paris <email address hidden>:
     - New upstream version. (closes: #231577)
       + Dropping dhcrelay.c.patch since a similar version is now
         included upstream. This patch was applied in 3.0+3.0.1rc11-3
         to prevent a DoS condition.
     - Have the dhcp3-server init script exit if dhcp3 is removed but not purged
       by testing for the existence of /usr/sbin/dhcpd3 (Closes: #201086)
     - Tighten versioned dependency on debianutils, since we need run-parts
      --list (Closes: #204329)
     - A...

Read more...

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Mon, 8 Mar 2004 21:06:18 -0800
From: Matt Zimmerman <email address hidden>
To: <email address hidden>
Cc: Thomas Hood <email address hidden>
Subject: unmerge

unmerge 151820
reopen 151820
thanks

#151820 and #165086 are different bugs.

--
 - mdz

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Fri, 30 Apr 2004 16:12:49 +0200
From: David =?iso-8859-1?Q?H=E4rdeman?= <david@2gen.com>
To: <email address hidden>
Subject: Installation reports

severity 246692 wishlist
merge 246692 151820

clone 238350 -1
retitle -1 Please add german translation
severity -1 wishlist
tags -1 + d-i
reassign -1 baseconfig-udeb
thanks

Daniel Stone (daniels) wrote :

From what I can tell (man, that source is obscure), this is incredibly difficult
to achieve.

By default, we cannot create a new option without sending it to the DHCP server
(and thus breaking RFC, which will probably confuse the server to hell).
Injecting specialised hostname cases into the client parser looks to be
extremely difficult. I think it would be easiest to write the hostname into
this file when it gets created.

Matt, comments?

Sivan Greenberg (sivan) wrote :

(In reply to comment #10)
> From what I can tell (man, that source is obscure), this is incredibly difficult
> to achieve.
>
> By default, we cannot create a new option without sending it to the DHCP server
> (and thus breaking RFC, which will probably confuse the server to hell).
> Injecting specialised hostname cases into the client parser looks to be
> extremely difficult. I think it would be easiest to write the hostname into
> this file when it gets created.
>
> Matt, comments?

I also noticed that, using dhclient 3.0.1-1ubuntu1 and didn't know why the
machine names do not appear in the
dhcp (debian sarge) box cache. I enabled it on the dhclient config file and it
works now. Why not just adding the
line which tells it to send the default hostname?

Matt Zimmerman (mdz) wrote :

(In reply to comment #11)
>
> Why not just adding the line which tells it to send the default hostname?

Because that isn't the way that the program works, and as Daniel noted, it's not
at all straightforward to make it so.

Daniel Stone (daniels) wrote :

per comment #12

Matt Zimmerman (mdz) wrote :

*** Bug 17409 has been marked as a duplicate of this bug. ***

Matt Zimmerman (mdz) wrote :

*** Bug 22919 has been marked as a duplicate of this bug. ***

Matt Zimmerman (mdz) wrote :

*** Bug 23320 has been marked as a duplicate of this bug. ***

Daniel Stone (daniels) on 2006-03-10
Changed in dhcp3:
assignee: daniels → nobody

Package: dhcp3-client
Followup-For: Bug #151820

I ran into this recently. I was trying to get the dhcp3 server to do
dynamic updates of DNS. The server doesn't even try if it doesn't get
a hostname, and the default Debian configuration doesn't send it.
Windows2000 server does, so it seems to work better with Linux than
Linux!

I've asked on the dhcp list (which recently merged server and client
lists) whether the client is expected to supply the hostname. So far,
no answer (I did kind of bury the question).

The way the dhcp3d.conf man page is written there is no mention of the
fact that dynamic DNS updates will not be attempted if there is no
hostname (though it makes sense, in retrospect). This might indicate
that the name is expected.

Also, there is a lot of code associated with the dhcp3-client that
gets the hostname (/etc/dhcp3/dhclient-script I think, though I'm not
on the system that has it right now). I couldn't tell exactly what
the intended purpose was, but if that's supposed to be sending the
hostname to the dhcp server, it isn't working. Or, maybe the script
isn't invoked by default (though the comments in the conf file seem to
imply it is).

Minimally, it would be nice to document the fact that the default
config doesn't send the hostname, explain how to change that, and list
the consequences of not sending the hostname.

Is there a security reason not to send the hostname?

Note this is talking about getting the dhcp3 server to make the
request to update DNS, not having the client do so directly (241388's
subject, though that bug mentions in passing the need to explicitly
set configurations on the client to get the serve to do the updates).

If the client code that I mentioned earlier is
intended to update DNS directly, it may be relevant that doing some
probably requires some intervention from the user, like setting a
shared secret to allow the updates to happen.

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (990, 'testing'), (990, 'stable'), (50, 'unstable')
Architecture: i386 (i686)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.4.27advncdfs
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)

Carthik Sharma (carthik) wrote :

Confirmed. I hate editing the conf file too, if only so that my Linksys router will call my computer by a name, instead of "Unknown".

Changed in dhcp3:
status: Unconfirmed → Confirmed

Here's a simple patch against dhcp3-3.0.3-6ubuntu7 . It lets you use

send host-name "<hostname>";

(that is, the above line literally - paste it as is into your dhclient.conf)

dhclient will then send your computer's hostname to the DHCP server.

Martin Pitt (pitti) on 2007-01-13
Changed in dhcp3:
assignee: nobody → pitti
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

 dhcp3 (3.0.4-12ubuntu2) feisty; urgency=low
 .
   * Add debian/patches/dynamic-hostname.dpatch:
      - Add support for a new string type 'h' which behaves like 't' except
        that '<hostname>' is changed to the current hostname.
      - Change 'host-name' DHCP option type from 't' to 'h'.
      - Based on a patch from Nathan O'Sullivan, thank you!
   * debian/dhclient.conf: Enable send-hostname by default (value '<hostname>',
     which our shiny new patch from above will translate to the actual
     hostname). Closes: LP#10239 and two handful of duplicates.

Changed in dhcp3:
status: In Progress → Fix Released

Hi!

I just implemented this long-standing feature request in Ubuntu:

 dhcp3 (3.0.4-12ubuntu2) feisty; urgency=low
 .
   * Add debian/patches/dynamic-hostname.dpatch:
      - Add support for a new string type 'h' which behaves like 't' except
        that '<hostname>' is changed to the current hostname.
      - Change 'host-name' DHCP option type from 't' to 'h'.
      - Based on a patch from Nathan O'Sullivan, thank you!
   * debian/dhclient.conf: Enable send-hostname by default (value '<hostname>',
     which our shiny new patch from above will translate to the actual
     hostname). Closes: LP#10239 and two handful of duplicates.

You can find the debdiff at

  http://people.ubuntu.com/patches/dhcp3.client-send-hostname.patch

Thanks,

Martin

--
Martin Pitt http://www.piware.de
Ubuntu Developer http://www.ubuntu.com
Debian Developer http://www.debian.org

tags 151820 patch
thanks

--
Simon Law http://www.law.yi.org/~sfllaw/

severity 403143 wishlist
merge 403143 151820
thanks

--
Simon Law http://www.law.yi.org/~sfllaw/

Marc D. (marc.d) wrote :

I now have dhcp3 3.0.4-12ubuntu4 here, and it seems like the "<hostname>" fix doesn't work anymore on my Feisty installation. It worked with the 3.0.4-12ubuntu2 version.

I haven't changed my dhclient.conf (attached)

Martin Pitt (pitti) wrote :

Weird, I just checked my router's log, and my hostname is still transfered correctly. Do you have any DHCP related error in /var/log/daemon.log?

Marc D. (marc.d) wrote :

Just checked: I don't have any DHCP related errors in the log file.

When I did a "nslookup hostname" or "nslookup hostname.domain.com" it returned an old IP address I had a few weeks ago. Then I did "sudo dhclient -r eth0" to release, replaced <hostname> in dhclient.conf with the actual hostname followed by a "sudo dhclient eht0". Then I did a nslookup again and then nslookup couldn't resolve it anymore.

When I use this instead:
send fqdn.fqdn "hostname.domain.com";
send fqdn.server-update on;
it does work, but I don't want to send a fqdn since I use my laptop at other sites too.

Weird indeed..

dhclient does send the hostname with the patch (I verified via wireshark), but it doesn't send a client identifier (cid). A fritz box (DSL router, market leader in germany) won't update it's dns records with the sent hostname without a cid, and some other DSL routers show this behavior, too, at least from what I gather using google. Maybe the relevant RFCs have something to say about this.

To make dhclient send a cid, you have to manually enter the mac address in /etc/dhcp3/dhclient.conf.

dhcpcd *does* send a cid (and hostname) by default without any patches, as does windows and OS X. In light of bug 26949 perhaps you might consider making dhcpcd the default client?

Package: dhcp3-client
Version: 3.0.6.dfsg-1
Followup-For: Bug #151820

Hi,

Why has this feature not been implemented yet?
A patch is available.

Greetings,

Olaf

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'stable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.22-3-686 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages dhcp3-client depends on:
ii debconf [debconf-2.0] 1.5.17 Debian configuration management sy
ii debianutils 2.28.2 Miscellaneous utilities specific t
ii dhcp3-common 3.0.6.dfsg-1 common files used by all the dhcp3
ii libc6 2.7-3 GNU C Library: Shared libraries

dhcp3-client recommends no packages.

-- debconf information:
  dhcp3-client/dhclient-needs-restarting:
  dhcp3-client/dhclient-script_moved:

On Fri, Dec 07, 2007 at 09:52:19PM +0100, Olaf van der Spek wrote:
> Package: dhcp3-client
> Version: 3.0.6.dfsg-1
> Followup-For: Bug #151820
>
> Hi,
>
> Why has this feature not been implemented yet?
> A patch is available.
>

Multiple reasons. I'd forgotten about it. I also have a policy of not making
Debian's package of DHCPv3 vary wildly from what the upstream codebase does.

I'll send this patch upstream and see what they say about it.

regards

Andrew

Hi,

Debian has a wishlist bug that the DHCP client would send the hostname
by default.

The full conversation is at http://bugs.debian.org/151820

Ubuntu made a patch that implements the feature, it's at
http://people.ubuntu.com/patches/dhcp3.client-send-hostname.patch

My personal preference is for these sort of changes to be incorporated
upstream, rather than having distro-specific behavioural changes to the
DHCP software.

Please consider this patch, and let us know what you think of it. Please
maintain the Cc line on all correspondence so that our bug tracking
system is kept in the loop.

regards

Andrew

On Dec 7, 2007 10:34 PM, Andrew Pollock <email address hidden> wrote:
> > Why has this feature not been implemented yet?
> > A patch is available.
> >
>
> Multiple reasons. I'd forgotten about it. I also have a policy of not making
> Debian's package of DHCPv3 vary wildly from what the upstream codebase does.
>
> I'll send this patch upstream and see what they say about it.

Thanks. What about the other bug reports?

On Fri, Dec 07, 2007 at 10:51:07PM +0100, Olaf van der Spek wrote:
> On Dec 7, 2007 10:34 PM, Andrew Pollock <email address hidden> wrote:
> > > Why has this feature not been implemented yet?
> > > A patch is available.
> > >
> >
> > Multiple reasons. I'd forgotten about it. I also have a policy of not making
> > Debian's package of DHCPv3 vary wildly from what the upstream codebase does.
> >
> > I'll send this patch upstream and see what they say about it.
>
> Thanks. What about the other bug reports?

What in particular are you talking about?

regards

Andrew

Changed in dhcp3:
status: New → Confirmed

On Dec 8, 2007 12:33 AM, Andrew Pollock <email address hidden> wrote:
> > Thanks. What about the other bug reports?
>
> What in particular are you talking about?

http://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=dhcp3-client;dist=unstable

On Sat, Dec 08, 2007 at 12:21:10PM +0100, Olaf van der Spek wrote:
> On Dec 8, 2007 12:33 AM, Andrew Pollock <email address hidden> wrote:
> > > Thanks. What about the other bug reports?
> >
> > What in particular are you talking about?
>
> http://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=dhcp3-client;dist=unstable
>

Patches accepted.

I fix bugs based on my availability and the severity/priority of the bug.

Is there a particular bug that you have an issue with, or are just feeling
the need to point out that there are open bug in dhcp3?

regards

Andrew

On Dec 10, 2007 12:11 AM, Andrew Pollock <email address hidden> wrote:
>
> On Sat, Dec 08, 2007 at 12:21:10PM +0100, Olaf van der Spek wrote:
> > On Dec 8, 2007 12:33 AM, Andrew Pollock <email address hidden> wrote:
> > > > Thanks. What about the other bug reports?
> > >
> > > What in particular are you talking about?
> >
> > http://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=dhcp3-client;dist=unstable
> >
>
> Patches accepted.
>
> I fix bugs based on my availability and the severity/priority of the bug.
>
> Is there a particular bug that you have an issue with, or are just feeling

Yes, the hostname one, stopping without releasing and I think I've
also seen the pid file issue, but that one is less important.

> the need to point out that there are open bug in dhcp3?

No, I guess you knew already.
I'm merely wondering why some bug reports are like they are,
especially the hostname one.

Greetings,

Olaf

Hi Andrew, you had sent an email to '<email address hidden>' back on
Dec 7, 2007 requesting comment on the inclusion of sending the
default hostname (patch provided by the ubuntu team), has that
come to some sort of a conclusion ? If not, can we push for an
opinion and/or an alternate solution...

I've recently been bitten by this seemingly simple issue and dread
having yet another location to note the hostname instead of specifying
'default' (or even the suggested <hostname>).

Regards...

      ____________________________________________________________________________________
Be a better friend, newshound, and
know-it-all with Yahoo! Mobile. Try it now. http://mobile.yahoo.com/;_ylt=Ahu06i62sR8HDtDypao8Wcj9tAcJ

On Mon, Jan 21, 2008 at 03:47:52AM -0800, Tim Freedom wrote:
> Hi Andrew, you had sent an email to '<email address hidden>' back on
> Dec 7, 2007 requesting comment on the inclusion of sending the
> default hostname (patch provided by the ubuntu team), has that
> come to some sort of a conclusion ? If not, can we push for an
> opinion and/or an alternate solution...
>
> I've recently been bitten by this seemingly simple issue and dread
> having yet another location to note the hostname instead of specifying
> 'default' (or even the suggested <hostname>).

Strangely, the upstream correspondence that came back from that bug, whilst
being Cc'ed to the BTS, didn't seem to make it in. I'll see what I can do
about injecting it in.

Basically, don't hold your breath.

I'm not over the moon about the Ubuntu patch, but I guess if push comes to
shove, we might have to look at putting that one in.

regards

Andrew

Marc D. (marc.d) wrote :

Update: I now have a fresh installation and after adding the line "send fqdn.server-update on" to dhcient.conf (the default one after installation) it works here, I can lookup my IP via nslookup <hostname> again. Without it it doesn't work.

 > I'll see what I can do about injecting it in.

Isn't it on some public mailing list archive?

 > Basically, don't hold your breath.

 > I'm not over the moon about the Ubuntu patch, but I guess if push

What's 'wrong' with it?
And what are other distributions doing?

Greetings,

Olaf

On Sat, Feb 09, 2008 at 07:14:49PM +0100, Olaf van der Spek wrote:
> > I'll see what I can do about injecting it in.
>
> Isn't it on some public mailing list archive?

The -bugs lists don't appear to have archives.

> > Basically, don't hold your breath.
>
> > I'm not over the moon about the Ubuntu patch, but I guess if push
>
> What's 'wrong' with it?

As I've said previously, I'd rather not make the downstream DHCP package
deviate significantly in behaviour from the upstream software. I don't
particularly like having magical strings that are interpretted differently
to literal strings. I'd rather see it be a directive than a magical string
that gets special treatment. According to upstream, their config parser
can't cope with that concept though.

> And what are other distributions doing?

Not sure, I haven't looked. Why don't you and let me know?

I suggest you lobby upstream to implement the functionality, as I have been.

http://marc.info/?l=dhcp-users&m=120027890132057&w=4

regards

Andrew

Andrew Pollock wrote:
>> What's 'wrong' with it?
>
> As I've said previously, I'd rather not make the downstream DHCP package
> deviate significantly in behaviour from the upstream software. I don't

Ah, I thought you didn't like the patch itself either.

> particularly like having magical strings that are interpretted differently
> to literal strings.

Good point.

 > I'd rather see it be a directive than a magical string
> that gets special treatment. According to upstream, their config parser
> can't cope with that concept though.
>
>> And what are other distributions doing?
>
> Not sure, I haven't looked. Why don't you and let me know?

I will.
Apparently Fedora is using a command line option (-H).
I don't think that's a good idea though. The conf file is the proper place.

> I suggest you lobby upstream to implement the functionality, as I have been.
>
> http://marc.info/?l=dhcp-users&m=120027890132057&w=4

I will.

Greetings,

Olaf

Andrew Pollock wrote:
> As I've said previously, I'd rather not make the downstream DHCP package
> deviate significantly in behaviour from the upstream software. I don't
> particularly like having magical strings that are interpretted differently
> to literal strings. I'd rather see it be a directive than a magical string
> that gets special treatment. According to upstream, their config parser
> can't cope with that concept though.
>
>> And what are other distributions doing?
>
> Not sure, I haven't looked. Why don't you and let me know?
>
> I suggest you lobby upstream to implement the functionality, as I have been.
>
> http://marc.info/?l=dhcp-users&m=120027890132057&w=4

Upstream appears to prefer a solution that accepts the pipe output of
applications for values in the conf file.
Such a solution doesn't exist yet, so I think it's best to apply the
Ubuntu patch until there's a better solution.

Greetings,

Olaf

On Mon, Feb 18, 2008 at 04:01:40PM +0100, Olaf van der Spek wrote:
> Andrew Pollock wrote:
> >As I've said previously, I'd rather not make the downstream DHCP package
> >deviate significantly in behaviour from the upstream software. I don't
> >particularly like having magical strings that are interpretted differently
> >to literal strings. I'd rather see it be a directive than a magical string
> >that gets special treatment. According to upstream, their config parser
> >can't cope with that concept though.
> >
> >>And what are other distributions doing?
> >
> >Not sure, I haven't looked. Why don't you and let me know?
> >
> >I suggest you lobby upstream to implement the functionality, as I have
> >been.
> >
> >http://marc.info/?l=dhcp-users&m=120027890132057&w=4
>
> Upstream appears to prefer a solution that accepts the pipe output of
> applications for values in the conf file.
> Such a solution doesn't exist yet, so I think it's best to apply the
> Ubuntu patch until there's a better solution.
>

And then what? We have a behaviour change to deal with? This is one of the
reasons why I don't like making distribution packages differ in behaviour
and functionality from upstream.

As it happens, I had lunch with a bunch of the DHCP folks from ISC
yesterday. I discussed this particular feature with them (again). They have
feature releases and point releases. The only way this will get into
upstream is in another feature release.

regards

Andrew

Changed in dhcp3:
status: Confirmed → Fix Released
renbag (renbag) wrote :

I tested today a jaunty virtual machine in an AD network: it does a dynamic DNS update out of the box.
Until now I had to use additional lines in dhclient.conf (#send fqdn.fqdn "hostname.mydomain.it."; #send fqdn.server-update on;) or use nsupdate in a hook script.
Thanks for fixing this bug.

Changed in dhcp3:
status: Fix Released → Confirmed
Adrie (adrie-6) wrote :

A week ago I installed Xubuntu 9.04 Jaunty Jackalope on my old Pentium Pro machine and this bug still seems to exists.
Spend days with trying to solve this, found many posts about it, none where recent though.
I have installed all the available updates, still the problem persists.

On Sat, Oct 24, 2009 at 07:08:35PM -0000, Adrie wrote:
> A week ago I installed Xubuntu 9.04 Jaunty Jackalope on my old Pentium Pro machine and this bug still seems to exists.
> Spend days with trying to solve this, found many posts about it, none where recent though.
> I have installed all the available updates, still the problem persists.

Works for me here; check that you have:

send host-name "<hostname>";

in /etc/dhcp3/dhclient.conf (this is in the default configuration file)

--
 - mdz

Adrie (adrie-6) wrote :

Thanks for your quick response Mat.
The default was the first I've tried.
I thought I had tried everything, but I overlooked post #23 about the FRITZ!Box that I have as well. The solution mentioned there works for me too !!

I don't understand the logic behind it, the FRITZ!Box already knows the MAC address (from the nic itself, I guess).
Upgrading the firmware did not change this behaviour, but it does now enable you to enter the hostname yourself.

oliver (oliver-schinagl) wrote :

I'm not entirely sure if this is the same bug, I can always open a new one, but my University wired network requires me to send my student ID (e.g. an arbitrary string) as hostname. Uni laptops have their hostname setup as heir student ID. Of course, I could just setup my hostname as my student ID but why if there's a proper way of doing this.

With ISC dhcpcd I simply supplied the -h parameter and it worked. Network manager since then has under the DHCP Client ID field under IPV4 settings for a wired connection. However this does not seem to get passed to dhclient, as send host-name "<hostname>"; from the config file gets used and always sent.

E.g. the DHCP Client ID field doesn't do anything. A workaround is to go into /etc/dhcp3/dhclient.conf and comment out the send host-name "<hostname> "; part. Now network manager nicely passes along the host-name from the DHCP Client ID field and everything works.

So I suppose, 'a' proper fix would be to set the DHCP Client ID field to hostname default and pass that to dhclient and not have a hardcoded override in dhclient.conf. I also belive, and I do not know the inner workings of network-manager, but this should be in the daemon bit of it, and not only in the GUI bit.

oliver

Changed in dhcp3 (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
COKEDUDE (cokedude) wrote :

I still have this problem even though it says it is fixed.

description: updated
Donatas Elvikis (kyvislt) wrote :

The same here on Ubuntu Lucid 10.4, even though /etc/dhcp3/dhclient.conf has "send host-name "<hostname>";" by default in it.

oliver (oliver-schinagl) wrote :

Sept. 2010; bug is still present, I still have to comment the "send host-name "<hostname>";" for Network Manager to send the string entered into the 'DHCP Client ID' field. Otherwise it simply gets ignored.

Brent Roman (brent-mbari) wrote :

Dec. 2010; bug is still present in Mint Linux Debian Edition.
A nice way to fix this would be to modify dhclient, adding a function to its Data Expression parser called, something like, hostname that would simply return the client's hostname. Or, solve this and the whole class of related problems in one blow by adding a more generic function called shell, which would take a shell command string as its argument and return the string output to stdout as its result. With such a "shell" function, one could simply add the following to the dhclient.conf file:

send host-name = shell "hostname -s" #the -s suppresses any domain name

Such functions would be straightforward extensions. See man page dhcp-eval.5 for details on "Data Expressions". I don't understand the earlier comment that "the program doesn't work this way"

But, given that the upstream maintainers do not seem to be readily accepting patches, I have resorted to the simple hack of rewriting the dhclient.conf file just before dhclient starts.

# mv /etc/dhcp/dhclient.conf /etc/dhcp/dhclient.base
# mv /sbin/dhclient /sbin/dhclient.original
# save the attached script to /sbin/dhclient
# chmod +x /sbin/dhclient

After you do this, just remember that dhclient.conf will be rewritten. Make any configuration changes in dhclient.base instead.

If the upstream devs indicate that they are interested in accepting the Data Function patches described above, I would be willing to submit them. However, I won't investigate further until the basic idea is discussed and accepted. Otherwise, the effort is just wasting everyone's time. (mostly mine :-)

Mike (bild85) wrote :

Wow. A 6+ year old bug in basic network connectivity. My home router runs DD-WRT with DNSMasq enabled which "...is designed to provide DNS and, optionally, DHCP, to a small network. It can serve the names of local machines which are not in the global DNS."

But DNSMasq was unable to resolve a hostname for my Ubuntu 10.10 machine, thus other machines failed to locate it. This broke BackupPC for me as it could never resolve the hostname and gave errors like this:
"Error: Can't find IP address for [myHostname]
[myHostname] is a DHCP host, and I don't know its IP address. I checked the netbios name of [myIP_Address], and found that that machine is not [myHostname].
Until I see [myHostname] at a particular DHCP address, you can only start this request from the client machine itself."

I checked /etc/dhcp3/dhclient.conf and it already contained:
send host-name "<hostname>";

However, as mentioned in comment #47, adding the following after that line made it work for me:
send fqdn.server-update on

Now my router knows my hostname and I can ping it (by hostname) from other machines.

i don't know toomuch about these things and am completely new to ubuntu...but...i have been hacked for 4 years and, among other things am on a network controlled by others who set permissions, global policy etc and hide themselves effectively..so nothing new here

Changed in dhcp3 (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.