cdebconf: package is uninstallable

Bug #21741 reported by Debian Bug Importer on 2005-09-15
8
Affects Status Importance Assigned to Milestone
cdebconf (Debian)
New
Unknown
cdebconf (Ubuntu)
Wishlist
Colin Watson

Bug Description

Automatically imported from Debian bug report #328498 http://bugs.debian.org/328498

Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #328498 http://bugs.debian.org/328498

# Automatically generated email from bts, devscripts version 2.9.7
severity 328498 important

Colin Watson (cjwatson) wrote :

(Please leave it this way for now. It's a very complicated change being worked
on across all of Debian.)

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Thu, 15 Sep 2005 19:23:51 +0200
From: Robert Jaeschke <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: cdebconf: package is uninstallable

Package: cdebconf
Version: 0.84
Severity: grave
Justification: renders package unusable

this package is uninstallable because it depends on libpango, which
depends on debconf, which conflicts with cdebconf

(maybe this is intended, because of the package description, which
advises against the installation of the package :-)

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.6.8-2-686
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Thu, 15 Sep 2005 15:22:03 -0400
From: Joey Hess <email address hidden>
To: <email address hidden>
Subject: severity of 328498 is important

# Automatically generated email from bts, devscripts version 2.9.7
severity 328498 important

Download full text (10.8 KiB)

block 328498 with 331730
block 328498 with 331731
block 328498 with 331732
block 328498 with 331733
block 328498 with 331734
block 328498 with 331735
block 328498 with 331736
block 328498 with 331737
block 328498 with 331738
block 328498 with 331739
block 328498 with 331740
block 328498 with 331741
block 328498 with 331742
block 328498 with 331743
block 328498 with 331744
block 328498 with 331745
block 328498 with 331746
block 328498 with 331747
block 328498 with 331748
block 328498 with 331749
block 328498 with 331751
block 328498 with 331750
block 328498 with 331752
block 328498 with 331753
block 328498 with 331754
block 328498 with 331756
block 328498 with 331768
block 328498 with 331763
block 328498 with 331764
block 328498 with 331765
block 328498 with 331766
block 328498 with 331767
block 328498 with 331797
block 328498 with 331800
block 328498 with 331839
block 328498 with 331822
block 328498 with 331769
block 328498 with 331770
block 328498 with 331771
block 328498 with 331772
block 328498 with 331773
block 328498 with 331774
block 328498 with 331775
block 328498 with 331806
block 328498 with 331809
block 328498 with 331811
block 328498 with 331813
block 328498 with 331817
block 328498 with 331818
block 328498 with 331840
block 328498 with 331842
block 328498 with 331848
block 328498 with 331852
block 328498 with 331854
block 328498 with 331855
block 328498 with 331776
block 328498 with 331777
block 328498 with 331778
block 328498 with 331779
block 328498 with 331780
block 328498 with 331781
block 328498 with 331782
block 328498 with 331783
block 328498 with 331784
block 328498 with 331785
block 328498 with 331786
block 328498 with 331787
block 328498 with 331788
block 328498 with 331789
block 328498 with 331790
block 328498 with 331791
block 328498 with 331792
block 328498 with 331793
block 328498 with 331794
block 328498 with 331795
block 328498 with 331796
block 328498 with 331798
block 328498 with 331799
block 328498 with 331801
block 328498 with 331802
block 328498 with 331803
block 328498 with 331804
block 328498 with 331805
block 328498 with 331807
block 328498 with 331808
block 328498 with 331810
block 328498 with 331812
block 328498 with 331814
block 328498 with 331815
block 328498 with 331816
block 328498 with 331819
block 328498 with 331820
block 328498 with 331821
block 328498 with 331823
block 328498 with 331824
block 328498 with 331825
block 328498 with 331826
block 328498 with 331827
block 328498 with 331828
block 328498 with 331829
block 328498 with 331830
block 328498 with 331831
block 328498 with 331832
block 328498 with 331833
block 328498 with 331834
block 328498 with 331835
block 328498 with 331836
block 328498 with 331837
block 328498 with 331838
block 328498 with 331841
block 328498 with 331843
block 328498 with 331844
block 328498 with 331845
block 328498 with 331846
block 328498 with 331847
block 328498 with 331849
block 328498 with 331850
block 328498 with 331851
block 328498 with 331853
block 328498 with 331856
block 328498 with 331857
block 328498 with 331858
block 328498 with 331859
block 328498 with 331860
block 328498 with 331861
block 328498 with 331862
block 328498 with 331863
block 328498 with 331864
...

Debian Bug Importer (debzilla) wrote :
Download full text (11.5 KiB)

Message-ID: <email address hidden>
Date: Tue, 4 Oct 2005 22:15:59 -0400
From: Joey Hess <email address hidden>
To: <email address hidden>
Subject: ... mommy

--EeQfGwPcQSOJBaQU
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

block 328498 with 331730
block 328498 with 331731
block 328498 with 331732
block 328498 with 331733
block 328498 with 331734
block 328498 with 331735
block 328498 with 331736
block 328498 with 331737
block 328498 with 331738
block 328498 with 331739
block 328498 with 331740
block 328498 with 331741
block 328498 with 331742
block 328498 with 331743
block 328498 with 331744
block 328498 with 331745
block 328498 with 331746
block 328498 with 331747
block 328498 with 331748
block 328498 with 331749
block 328498 with 331751
block 328498 with 331750
block 328498 with 331752
block 328498 with 331753
block 328498 with 331754
block 328498 with 331756
block 328498 with 331768
block 328498 with 331763
block 328498 with 331764
block 328498 with 331765
block 328498 with 331766
block 328498 with 331767
block 328498 with 331797
block 328498 with 331800
block 328498 with 331839
block 328498 with 331822
block 328498 with 331769
block 328498 with 331770
block 328498 with 331771
block 328498 with 331772
block 328498 with 331773
block 328498 with 331774
block 328498 with 331775
block 328498 with 331806
block 328498 with 331809
block 328498 with 331811
block 328498 with 331813
block 328498 with 331817
block 328498 with 331818
block 328498 with 331840
block 328498 with 331842
block 328498 with 331848
block 328498 with 331852
block 328498 with 331854
block 328498 with 331855
block 328498 with 331776
block 328498 with 331777
block 328498 with 331778
block 328498 with 331779
block 328498 with 331780
block 328498 with 331781
block 328498 with 331782
block 328498 with 331783
block 328498 with 331784
block 328498 with 331785
block 328498 with 331786
block 328498 with 331787
block 328498 with 331788
block 328498 with 331789
block 328498 with 331790
block 328498 with 331791
block 328498 with 331792
block 328498 with 331793
block 328498 with 331794
block 328498 with 331795
block 328498 with 331796
block 328498 with 331798
block 328498 with 331799
block 328498 with 331801
block 328498 with 331802
block 328498 with 331803
block 328498 with 331804
block 328498 with 331805
block 328498 with 331807
block 328498 with 331808
block 328498 with 331810
block 328498 with 331812
block 328498 with 331814
block 328498 with 331815
block 328498 with 331816
block 328498 with 331819
block 328498 with 331820
block 328498 with 331821
block 328498 with 331823
block 328498 with 331824
block 328498 with 331825
block 328498 with 331826
block 328498 with 331827
block 328498 with 331828
block 328498 with 331829
block 328498 with 331830
block 328498 with 331831
block 328498 with 331832
block 328498 with 331833
block 328498 with 331834
block 328498 with 331835
block 328498 with 331836
block 328498 with 331837
block 328498 with 331838
block 328498 with 331841
block 328498 with 331843
block 328498 with 331844
block 328498 with 331845
block 328498 with 331846
block 328498 with 331847
block 328498 with 3318...

block 328498 with 327730
merge 331875 327730
thanks

Jeremy

--
http://www.jerryweb.org/ : JerryWeb.org
http://sailcut.sourceforge.net/ : Sailcut CAD
http://opensource.polytechnique.org/ : Polytechnique.org Free Software

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Tue, 18 Oct 2005 17:40:10 +0100
From: Jeremy Laine <email address hidden>
To: <email address hidden>
Subject:

block 328498 with 327730
merge 331875 327730
thanks

Jeremy

--
http://www.jerryweb.org/ : JerryWeb.org
http://sailcut.sourceforge.net/ : Sailcut CAD
http://opensource.polytechnique.org/ : Polytechnique.org Free Software

Colin Watson (cjwatson) wrote :

I've made cdebconf not conflict with debconf any more. All these blocking bugs are still significant because they block the eventual removal of debconf, but they don't block testing of cdebconf any more.

Changed in cdebconf:
status: Unconfirmed → Fix Committed
Colin Watson (cjwatson) wrote :

cdebconf is now installable, so I don't care about this bug in Ubuntu any more. The Debian bug has been changed to track bugs that block an eventual switch to cdebconf as the default frontend.

Changed in cdebconf:
status: Unconfirmed → Fix Released

retitle 328498 switch to cdebconf as default
severity 328498 wishlist
thanks

On Thu, Sep 15, 2005 at 07:23:51PM +0200, Robert Jaeschke wrote:
> Package: cdebconf
> Version: 0.84
> Severity: grave
> Justification: renders package unusable
>
>
> this package is uninstallable because it depends on libpango, which
> depends on debconf, which conflicts with cdebconf
>
> (maybe this is intended, because of the package description, which
> advises against the installation of the package :-)

I've now uploaded versions of cdebconf and debconf that don't conflict,
and created a DEBCONF_USE_CDEBCONF environment variable to allow you to
test the cdebconf frontend (providing that you've set up a database,
etc.).

However, this bug is still useful to track the bugs that block us
switching to cdebconf as default and ultimately perhaps dropping
debconf, so I've left it open with an updated title.

Cheers,

--
Colin Watson [<email address hidden>]

Package: apticron
Version: 1.1.13

Hey, this bug was closed in this version but there is no changelog
entries about it.

--
Tiago Bortoletto Vaz
http://tiagovaz.org
0xA504FECA - http://pgp.mit.edu

"É preciso não ter medo,
é preciso ter a coragem de dizer."

Rondó da Liberdade, Carlos Marighella

reopen 328498

--
Tiago Bortoletto Vaz
http://tiagovaz.org
0xA504FECA - http://pgp.mit.edu

"É preciso não ter medo,
é preciso ter a coragem de dizer."

Rondó da Liberdade, Carlos Marighella

# both of these two bugs block the cdebconf transition #328498
block 328498 with 397890
block 328498 with 397891
thanks

--
Regards,
EddyP
=============================================
"Imagination is more important than knowledge" A.Einstein

block 328498 with 393455
thanks

block 328498 with 402570
thanks
--
<email address hidden> - http://tevp.net
Illegitimus non carborundum

block 328498 with 415684
block 328498 with 415685
block 328498 with 415688
block 328498 with 415689
block 328498 with 415691

--
Magnus Holmgren <email address hidden>

Well, there should be no more blocking bugs on this, thanks to Amaya.

Now we just need to figure out a procedure to migrate from debconf to
cdebconf.

The first problem I've run into is that cdebconf fails to run if any of
/var/lib/cdebconf/*.dat are missing. And installing the package doesn't
provide these, though it does provide questions and templates _directories_,
which the default config doesn't use.

The second problem is probably that it defaults to the text frontend,
though it can easily be changed to newt by editing /etc/cdebconf.conf.

Then after setting

PATH=/usr/lib/cdebconf:$PATH
export DEBCONF_USE_CDEBCONF=1

I was ready to start testing and filing bugs. :-)

--
see shy jo

# Automatically generated email from bts, devscripts version 2.10.8
block 328498 with 247744

# Automatically generated email from bts, devscripts version 2.10.8
block 328498 with 442287

# Automatically generated email from bts, devscripts version 2.10.8
block 328498 with 442288

# Automatically generated email from bts, devscripts version 2.10.8
block 328498 with 442290

# Automatically generated email from bts, devscripts version 2.10.8
block 328498 with 212881

# Automatically generated email from bts, devscripts version 2.10.8
block 328498 with 442291

# Automatically generated email from bts, devscripts version 2.10.8
unblock 328498 with 442287

block 328498 with 448477
block 328498 with 448476

# Automatically generated email from bts, devscripts version 2.10.7
# death to spam
reopen 328498

block 328498 with 449540

# Automatically generated email from bts, devscripts version 2.10.10
retitle 451130 cdebconf deb does not initalise the template database, which is needed to work out of the box
reassign 451130 cdebconf
block 328498 with 451130

block 328498 with 443760
block 328498 with 469363

block 328498 with 537535
block 328498 with 537536

unblock 328498 with 212881

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.